]> git.pld-linux.org Git - packages/crossmingw32-cairo.git/blob - crossmingw32-cairo.spec
- don't disable svg
[packages/crossmingw32-cairo.git] / crossmingw32-cairo.spec
1 #
2 # Conditional build:
3 %bcond_with     glitz           # build with glitz backend
4 #
5 Summary:        Cairo - multi-platform 2D graphics library - cross Mingw32 version
6 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D - skrośna wersja Mingw32
7 %define         realname   cairo
8 Name:           crossmingw32-%{realname}
9 Version:        1.4.10
10 Release:        1
11 License:        LGPL v2.1 or MPL v1.1
12 Group:          Development/Libraries
13 Source0:        http://cairographics.org/releases/%{realname}-%{version}.tar.gz
14 # Source0-md5:  5598a5e500ad922e37b159dee72fc993
15 URL:            http://cairographics.org/
16 BuildRequires:  autoconf >= 2.54
17 BuildRequires:  automake >= 1:1.7
18 BuildRequires:  crossmingw32-fontconfig
19 BuildRequires:  crossmingw32-freetype >= 2.1.10
20 %{?with_glitz:BuildRequires:    crossmingw32-glitz >= 0.5.1}
21 BuildRequires:  crossmingw32-libpng
22 BuildRequires:  crossmingw32-zlib
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig >= 1:0.15
25 Requires:       crossmingw32-fontconfig
26 Requires:       crossmingw32-freetype >= 2.1.10
27 %{?with_glitz:Requires: crossmingw32-glitz >= 0.5.1}
28 Requires:       crossmingw32-libpng
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %description
44 Cairo provides anti-aliased vector-based rendering for X. Paths
45 consist of line segments and cubic splines and can be rendered at any
46 width with various join and cap styles. All colors may be specified
47 with optional translucence (opacity/alpha) and combined using the
48 extended Porter/Duff compositing algebra as found in the X Render
49 Extension.
50
51 Cairo exports a stateful rendering API similar in spirit to the path
52 construction, text, and painting operators of PostScript, (with the
53 significant addition of translucence in the imaging model). When
54 complete, the API is intended to support the complete imaging model of
55 PDF 1.4.
56
57 This package contains the cross version for Win32.
58
59 %description -l pl.UTF-8
60 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
61 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
62 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
63 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
64 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
65 przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
66 można znaleźć w rozszerzeniu X Render.
67
68 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
69 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
70 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
71 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
72
73 Ten pakiet zawiera wersję skrośną dla Win32.
74
75 %package static
76 Summary:        Static cairo library (cross mingw32 version)
77 Summary(pl.UTF-8):      Statyczna biblioteka cairo (wersja skrośna mingw32)
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description static
82 Static cairo library (cross mingw32 version).
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka cairo (wersja skrośna mingw32).
86
87 %package dll
88 Summary:        DLL cairo library for Windows
89 Summary(pl.UTF-8):      Biblioteka DLL cairo dla Windows
90 Group:          Applications/Emulators
91 Requires:       crossmingw32-fontconfig-dll
92 Requires:       crossmingw32-freetype-dll >= 2.1.10
93 %{?with_glitz:Requires: crossmingw32-glitz-dll >= 0.5.1}
94 Requires:       crossmingw32-libpng-dll
95
96 %description dll
97 DLL cairo library for Windows.
98
99 %description dll -l pl.UTF-8
100 Biblioteka DLL cairo dla Windows.
101
102 %prep
103 %setup -q -n %{realname}-%{version}
104
105 %build
106 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         lt_cv_deplibs_check_method=pass_all \
114         --target=%{target} \
115         --host=%{target} \
116         --disable-gtk-doc \
117         --disable-xlib \
118         --disable-xlib-render \
119         --enable-freetype \
120         %{?with_glitz:--enable-glitz} \
121         --enable-pdf \
122         --enable-png \
123         --enable-ps \
124         --enable-windows \
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install -d $RPM_BUILD_ROOT%{_dlldir}
135 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
136
137 %if 0%{!?debug:1}
138 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
139 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
140 %endif
141
142 rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 # COPYING contains only notes, not LGPL/MPL texts
150 %doc AUTHORS COPYING ChangeLog NEWS README TODO
151 %{_libdir}/libcairo.dll.a
152 %{_libdir}/libcairo.la
153 %{_includedir}/cairo
154 %{_pkgconfigdir}/*.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libcairo.a
159
160 %files dll
161 %defattr(644,root,root,755)
162 %{_dlldir}/libcairo-*.dll
This page took 0.06727 seconds and 3 git commands to generate.