]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blob - crossmingw32-boost.spec
- updated to 1.53.0
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
1 #
2 # Conditional build:
3 %bcond_with     serialization   # enable Boost Serialization
4 #
5 %define         realname        boost
6 Summary:        The Boost C++ Libraries - MinGW32 cross version
7 Summary(pl.UTF-8):      Biblioteki C++ "Boost" - wersja skrośna dla MinGW32
8 Name:           crossmingw32-%{realname}
9 Version:        1.53.0
10 %define fver    %(echo %{version} | tr . _)
11 Release:        1
12 License:        Boost Software License and others
13 Group:          Development/Libraries
14 Source0:        http://downloads.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
15 # Source0-md5:  a00d22605d5dbcfb4c9936a9b35bc4c2
16 URL:            http://www.boost.org/
17 BuildRequires:  crossmingw32-bzip2
18 BuildRequires:  crossmingw32-gcc-c++
19 BuildRequires:  crossmingw32-runtime
20 BuildRequires:  crossmingw32-w32api
21 BuildRequires:  crossmingw32-zlib
22 %{?with_serialization:BuildRequires:    wine-programs}
23 Requires:       crossmingw32-bzip2
24 Requires:       crossmingw32-runtime
25 Requires:       crossmingw32-zlib
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         no_install_post_strip   1
29
30 %define         target          i386-mingw32
31 %define         target_platform i386-pc-mingw32
32
33 %define         _sysprefix      /usr
34 %define         _prefix         %{_sysprefix}/%{target}
35 %define         _libdir         %{_prefix}/lib
36 %define         _dlldir         /usr/share/wine/windows/system
37
38 %define         __cc            %{target}-gcc
39 %define         __cxx           %{target}-g++
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45
46 %description
47 The Boost web site provides free peer-reviewed portable C++ source
48 libraries. The emphasis is on libraries which work well with the C++
49 Standard Library. One goal is to establish "existing practice" and
50 provide reference implementations so that the Boost libraries are
51 suitable for eventual standardization. Some of the libraries have
52 already been proposed for inclusion in the C++ Standards Committee's
53 upcoming C++ Standard Library Technical Report.
54
55 %description -l pl.UTF-8
56 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
57 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
58 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
59 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
60 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
61 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
62 Raporcie Technicznym Biblioteki Standardowej C++.
63
64 %package static
65 Summary:        Static Boost libraries (cross MinGW32 version)
66 Summary(pl.UTF-8):      Statyczne biblioteki Boost (wersja skrośna MinGW32)
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description static
71 Static Boost libraries (cross MinGW32 version).
72
73 %description static -l pl.UTF-8
74 Statyczne biblioteki Boost (wersja skrośna MinGW32).
75
76 %package dll
77 Summary:        Boost - DLL libraries for Windows
78 Summary(pl.UTF-8):      Boost - biblioteki DLL dla Windows
79 Group:          Applications/Emulators
80 Requires:       crossmingw32-bzip2-dll
81 Requires:       crossmingw32-zlib-dll
82 Requires:       wine
83
84 %description dll
85 Boost - DLL libraries for Windows.
86
87 %description dll -l pl.UTF-8
88 Boost - biblioteki DLL dla Windows.
89
90 %prep
91 %setup -q -n %{realname}_%{fver}
92
93 echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}"' \
94         '<archiver>%{target}-ar ;' >tools/build/v2/user-config.jam
95
96 %build
97 %if %{with serialization}
98 export WINEPREFIX=`pwd`/wineprefix
99 install -d wineprefix/drive_c/windows/system32
100 install %{_prefix}/bin/mingwm10.dll wineprefix/drive_c/windows/system32/
101 %endif
102
103 ./bootstrap.sh --prefix=%{_prefix}
104 ./b2 \
105         -d2 \
106         -j %{__jobs} \
107         --layout=versioned \
108         -sBZIP2_BINARY=bzip2 \
109         toolset=gcc \
110         --without-python \
111         %{!?with_serialization:--without-serialization} \
112         --without-test \
113         --without-context \
114         variant=release \
115         debug-symbols=on \
116         inlining=on \
117         link=static,shared \
118         target-os=windows \
119         threading=multi \
120         threadapi=win32
121
122 %if 0%{!?debug:1}
123 %{target}-strip stage/lib/*.dll
124 %{target}-strip -g -R.comment -R.note stage/lib/*.a
125 %endif
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
130
131 cp -r boost $RPM_BUILD_ROOT%{_includedir}
132 cp -a stage/lib/*.a $RPM_BUILD_ROOT%{_libdir}
133 install stage/lib/*.dll $RPM_BUILD_ROOT%{_dlldir}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %{_libdir}/libboost_*-mgw*-mt-*.dll.a
141 %{_includedir}/boost
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libboost_*-mgw*-mt-*1_53.a
146
147 %files dll
148 %defattr(644,root,root,755)
149 %{_dlldir}/libboost_*-mgw*-mt-*.dll
This page took 0.083149 seconds and 3 git commands to generate.