]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blob - crossmingw32-atk.spec
- updated to 2.14.0
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
1 %define         realname   atk
2 Summary:        ATK - Accessibility Toolkit - cross MinGW32 version
3 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.14.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/2.14/%{realname}-%{version}.tar.xz
10 # Source0-md5:  ecb7ca8469a5650581b1227d78051b8b
11 URL:            https://developer.gnome.org/atk/
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-glib2 >= 2.32.0
16 BuildRequires:  libtool >= 2:2.2
17 BuildRequires:  perl-base
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  rpmbuild(macros) >= 1.197
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-glib2 >= 2.32.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47
48 %description
49 The ATK library provides a set of interfaces for adding accessibility
50 support to applications and graphical user interface toolkits. By
51 supporting the ATK interfaces, an application or toolkit can be used
52 as tools such as screen readers and magnifiers, and alternative input
53 devices.
54
55 This package contains the cross version for Win32.
56
57 %description -l pl.UTF-8
58 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
59 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
60 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
61 ATK, aplikacja lub element interfejsu może być używany z takimi
62 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
63 alternatywnymi urządzeniami wejściowymi.
64
65 Ten pakiet zawiera wersję skrośną dla Win32.
66
67 %package static
68 Summary:        Static atk library (cross MinGW32 version)
69 Summary(pl.UTF-8):      Statyczna biblioteka atk (wersja skrośna MinGW32)
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description static
74 Static atk library (cross MinGW32 version).
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka atk (wersja skrośna MinGW32).
78
79 %package dll
80 Summary:        DLL atk library for Windows
81 Summary(pl.UTF-8):      Biblioteka DLL atk dla Windows
82 Group:          Applications/Emulators
83 Requires:       crossmingw32-glib2-dll >= 2.32.0
84 Requires:       wine
85
86 %description dll
87 DLL atk library for Windows.
88
89 %description dll -l pl.UTF-8
90 Biblioteka DLL atk dla Windows.
91
92 %prep
93 %setup -q -n %{realname}-%{version}
94
95 %build
96 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --target=%{target} \
104         --host=%{target} \
105         --disable-gtk-doc \
106         --disable-silent-rules \
107         --enable-static
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} -j1 install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT%{_dlldir}
118 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
119
120 %if 0%{!?debug:1}
121 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
122 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
123 %endif
124
125 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
126 # runtime
127 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS NEWS README
135 %{_libdir}/libatk-1.0.dll.a
136 %{_libdir}/libatk-1.0.la
137 %{_includedir}/atk-1.0
138 %{_pkgconfigdir}/atk.pc
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libatk-1.0.a
143
144 %files dll
145 %defattr(644,root,root,755)
146 %{_dlldir}/libatk-1.0-*.dll
This page took 0.119351 seconds and 3 git commands to generate.