]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blob - crossmingw32-atk.spec
- updated to 2.38.0
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
1 %define         realname   atk
2 Summary:        ATK - Accessibility Toolkit - cross MinGW32 version
3 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.26.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/2.26/%{realname}-%{version}.tar.xz
10 # Source0-md5:  7cddcc313b9a3efd19b2ddf079ba68f5
11 URL:            https://developer.gnome.org/atk/
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-glib2 >= 2.32.0
16 BuildRequires:  libtool >= 2:2.2
17 BuildRequires:  perl-base
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  python >= 1:2.5
20 BuildRequires:  rpmbuild(macros) >= 1.197
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-glib2 >= 2.32.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39 %define         __pkgconfig_requires    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker, most of -f options are Linux-specific
46 %define         filterout_ld    -Wl,-z,.*
47 %define         filterout_c     -f[-a-z0-9=]*
48
49 %description
50 The ATK library provides a set of interfaces for adding accessibility
51 support to applications and graphical user interface toolkits. By
52 supporting the ATK interfaces, an application or toolkit can be used
53 as tools such as screen readers and magnifiers, and alternative input
54 devices.
55
56 This package contains the cross version for Win32.
57
58 %description -l pl.UTF-8
59 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
60 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
61 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
62 ATK, aplikacja lub element interfejsu może być używany z takimi
63 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
64 alternatywnymi urządzeniami wejściowymi.
65
66 Ten pakiet zawiera wersję skrośną dla Win32.
67
68 %package static
69 Summary:        Static atk library (cross MinGW32 version)
70 Summary(pl.UTF-8):      Statyczna biblioteka atk (wersja skrośna MinGW32)
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description static
75 Static atk library (cross MinGW32 version).
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka atk (wersja skrośna MinGW32).
79
80 %package dll
81 Summary:        DLL atk library for Windows
82 Summary(pl.UTF-8):      Biblioteka DLL atk dla Windows
83 Group:          Applications/Emulators
84 Requires:       crossmingw32-glib2-dll >= 2.32.0
85 Requires:       wine
86
87 %description dll
88 DLL atk library for Windows.
89
90 %description dll -l pl.UTF-8
91 Biblioteka DLL atk dla Windows.
92
93 %prep
94 %setup -q -n %{realname}-%{version}
95
96 %build
97 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --target=%{target} \
105         --host=%{target} \
106         --disable-gtk-doc \
107         --disable-silent-rules \
108         --enable-static
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} -j1 install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install -d $RPM_BUILD_ROOT%{_dlldir}
119 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
120
121 %if 0%{!?debug:1}
122 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
123 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
124 %endif
125
126 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
127 # runtime
128 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS NEWS README
136 %{_libdir}/libatk-1.0.dll.a
137 %{_libdir}/libatk-1.0.la
138 %{_includedir}/atk-1.0
139 %{_pkgconfigdir}/atk.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libatk-1.0.a
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libatk-1.0-*.dll
This page took 0.074877 seconds and 3 git commands to generate.