]> git.pld-linux.org Git - packages/crossmingw32-atk.git/blob - crossmingw32-atk.spec
- Source0 URL fix
[packages/crossmingw32-atk.git] / crossmingw32-atk.spec
1 %define         realname   atk
2 Summary:        ATK - Accessibility Toolkit - cross MinGW32 version
3 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.32.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/1.32/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  b9a19a3e426cd9ca930f0108c4ee343f
11 URL:            http://library.gnome.org/devel/atk/
12 BuildRequires:  autoconf >= 2.62
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-glib2 >= 2.20.0
16 BuildRequires:  libtool >= 2:1.5.16
17 BuildRequires:  perl-base
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  rpmbuild(macros) >= 1.197
20 BuildRequires:  sed >= 4.0
21 Requires:       crossmingw32-glib2 >= 2.20.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         no_install_post_strip   1
25
26 %define         target                  i386-mingw32
27 %define         target_platform         i386-pc-mingw32
28
29 %define         _sysprefix              /usr
30 %define         _prefix                 %{_sysprefix}/%{target}
31 %define         _libdir                 %{_prefix}/lib
32 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
33 %define         _dlldir                 /usr/share/wine/windows/system
34 %define         __cc                    %{target}-gcc
35 %define         __cxx                   %{target}-g++
36
37 %ifnarch %{ix86}
38 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
39 %define         optflags        -O2
40 %endif
41 # -z options are invalid for mingw linker
42 %define         filterout_ld    -Wl,-z,.*
43
44 %description
45 The ATK library provides a set of interfaces for adding accessibility
46 support to applications and graphical user interface toolkits. By
47 supporting the ATK interfaces, an application or toolkit can be used
48 as tools such as screen readers and magnifiers, and alternative input
49 devices.
50
51 This package contains the cross version for Win32.
52
53 %description -l pl.UTF-8
54 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
55 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
56 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
57 ATK, aplikacja lub element interfejsu może być używany z takimi
58 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
59 alternatywnymi urządzeniami wejściowymi.
60
61 Ten pakiet zawiera wersję skrośną dla Win32.
62
63 %package static
64 Summary:        Static atk library (cross MinGW32 version)
65 Summary(pl.UTF-8):      Statyczna biblioteka atk (wersja skrośna MinGW32)
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description static
70 Static atk library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka atk (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        DLL atk library for Windows
77 Summary(pl.UTF-8):      Biblioteka DLL atk dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-glib2-dll >= 2.20.0
80 Requires:       wine
81
82 %description dll
83 DLL atk library for Windows.
84
85 %description dll -l pl.UTF-8
86 Biblioteka DLL atk dla Windows.
87
88 %prep
89 %setup -q -n %{realname}-%{version}
90
91 # workaround for libtool which calls AC_CANONICAL_HOST too late
92 sed -i -e '/AC_PROG_CC/iAC_CANONICAL_HOST' configure.in
93
94 %build
95 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --target=%{target} \
103         --host=%{target} \
104         --disable-gtk-doc \
105         --enable-static
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} -j1 install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT%{_dlldir}
116 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117
118 %if 0%{!?debug:1}
119 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
120 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
121 %endif
122
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
124 # runtime
125 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS NEWS README
133 %{_libdir}/libatk-1.0.dll.a
134 %{_libdir}/libatk-1.0.la
135 %{_libdir}/atk-1.0.def
136 %{_includedir}/atk-1.0
137 %{_pkgconfigdir}/atk.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libatk-1.0.a
142
143 %files dll
144 %defattr(644,root,root,755)
145 %{_dlldir}/libatk-1.0-*.dll
This page took 0.063924 seconds and 3 git commands to generate.