]> git.pld-linux.org Git - packages/crossavr-gcc.git/commitdiff
- added c++ subpackage. Tested on AT90S2313.
authorbszx <bszx@pld-linux.org>
Fri, 6 Feb 2004 21:04:54 +0000 (21:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    crossavr-gcc.spec -> 1.11

crossavr-gcc.spec

index c34ef00a935417e28e041a3ed6e04d3e980c2eee..f9b05d66ab7c7b988f2767c4e22275c5d276498e 100644 (file)
@@ -6,7 +6,7 @@ Summary(pt_BR): Utilit
 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
 Name:          crossavr-gcc
 Version:       3.3.2
 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
 Name:          crossavr-gcc
 Version:       3.3.2
-Release:       1
+Release:       2
 Epoch:         1
 License:       GPL
 Group:         Development/Languages
 Epoch:         1
 License:       GPL
 Group:         Development/Languages
@@ -40,6 +40,17 @@ i386-Rechner Code f
 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
 i386 binariów do uruchamiania na Atmel AVR.
 
 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
 i386 binariów do uruchamiania na Atmel AVR.
 
+%package c++
+Summary:        C++ support for avr-gcc
+Group:          Development/Languages
+Requires:       crossavr-gcc = %{epoch}:%{version}
+
+%description c++
+This package adds C++ support to the GNU Compiler Collection for AVR.
+
+%description c++ -l pl
+Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
+
 %prep
 %setup -q -n gcc-%{version}
 
 %prep
 %setup -q -n gcc-%{version}
 
@@ -55,7 +66,7 @@ TEXCONFIG=false ../configure \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
        --disable-shared \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
        --disable-shared \
-       --enable-languages="c" \
+       --enable-languages="c,c++" \
        --enable-long-long \
        --with-gnu-as \
        --with-gnu-ld \
        --enable-long-long \
        --with-gnu-as \
        --with-gnu-ld \
@@ -92,12 +103,16 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
 
 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
 
 
 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
 
+#%find_lang %{name}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files 
 %defattr(644,root,root,755)
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/%{target}-*
+%attr(755,root,root) %{_bindir}/%{target}-gcc*
+%attr(755,root,root) %{_bindir}/%{target}-cpp
+%attr(755,root,root) %{_bindir}/%{target}-gcov
 %dir %{gccarch}
 %dir %{gcclib}
 %attr(755,root,root) %{gcclib}/cc1
 %dir %{gccarch}
 %dir %{gcclib}
 %attr(755,root,root) %{gcclib}/cc1
@@ -110,3 +125,10 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{gcclib}/include
 %{gcclib}/include/*.h
 %{_mandir}/man1/%{target}-gcc.1*
 %dir %{gcclib}/include
 %{gcclib}/include/*.h
 %{_mandir}/man1/%{target}-gcc.1*
+
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/%{target}-g++
+%attr(755,root,root) %{_bindir}/%{target}-c++
+%attr(755,root,root) %{gcclib}/cc1plus
+%{_mandir}/man1/%{target}-g++.1*
This page took 0.073256 seconds and 4 git commands to generate.