]> git.pld-linux.org Git - packages/crossavr-gcc.git/blob - crossavr-gcc.spec
- added c++ subpackage. Tested on AT90S2313.
[packages/crossavr-gcc.git] / crossavr-gcc.spec
1 Summary:        Cross AVR GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AVR gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - AVR gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AVR - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AVR gcc
6 Summary(tr):    GNU geliþtirme araçlarý - AVR gcc
7 Name:           crossavr-gcc
8 Version:        3.3.2
9 Release:        2
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
14 # Source0-md5:  65999f654102f5438ac8562d13a6eced
15 BuildRequires:  crossavr-binutils
16 BuildRequires:  flex
17 BuildRequires:  bison
18 BuildRequires:  autoconf
19 BuildRequires:  /bin/bash
20 Requires:       crossavr-binutils
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         cxx             0
24 %define         target          avr
25 %define         _prefix         /usr
26 %define         arch            %{_prefix}/%{target}
27 %define         gccarch         %{_prefix}/lib/gcc-lib/%{target}
28 %define         gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
29 %define         no_install_post_strip   1
30
31 %description
32 This package contains a cross-gcc which allows the creation of
33 binaries to be run on Atmel AVR on i386-machines.
34
35 %description -l de
36 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
37 i386-Rechner Code für Atmel AVR zu generieren.
38
39 %description -l pl
40 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na maszynach
41 i386 binariów do uruchamiania na Atmel AVR.
42
43 %package c++
44 Summary:        C++ support for avr-gcc
45 Group:          Development/Languages
46 Requires:       crossavr-gcc = %{epoch}:%{version}
47
48 %description c++
49 This package adds C++ support to the GNU Compiler Collection for AVR.
50
51 %description c++ -l pl
52 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla AVR.
53
54 %prep
55 %setup -q -n gcc-%{version}
56
57 %build
58 rm -rf obj-%{target}
59 install -d obj-%{target}
60 cd obj-%{target}
61
62 CFLAGS="%{rpmcflags}" \
63 CXXFLAGS="%{rpmcflags}" \
64 TEXCONFIG=false ../configure \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --disable-shared \
69         --enable-languages="c,c++" \
70         --enable-long-long \
71         --with-gnu-as \
72         --with-gnu-ld \
73         --with-system-zlib \
74         --with-multilib \
75         --without-x \
76         --target=%{target}
77
78 PATH=$PATH:/sbin:%{_sbindir}
79
80 cd ..
81 #LDFLAGS_FOR_TARGET="%{rpmldflags}"
82
83 %{__make} -C obj-%{target}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_bindir},%{gcclib}}
88
89 cd obj-%{target}
90 PATH=$PATH:/sbin:%{_sbindir}
91
92 %{__make} -C gcc install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # c++filt is provided by binutils
96 #rm -f $RPM_BUILD_ROOT%{_bindir}/i386-mipsel-c++filt
97
98 # what is this there for???
99 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
100
101 # the same... make hardlink
102 #ln -f $RPM_BUILD_ROOT%{arch}/bin/gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
103
104 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}/libgcc.a
105
106 #%find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files 
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/%{target}-gcc*
114 %attr(755,root,root) %{_bindir}/%{target}-cpp
115 %attr(755,root,root) %{_bindir}/%{target}-gcov
116 %dir %{gccarch}
117 %dir %{gcclib}
118 %attr(755,root,root) %{gcclib}/cc1
119 #%attr(755,root,root) %{gcclib}/tradcpp0
120 #%attr(755,root,root) %{gcclib}/cpp0
121 %attr(755,root,root) %{gcclib}/collect2
122 %{gcclib}/libgcc.a
123 %{gcclib}/specs*
124 %{gcclib}/%{target}*
125 %dir %{gcclib}/include
126 %{gcclib}/include/*.h
127 %{_mandir}/man1/%{target}-gcc.1*
128
129 %files c++
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/%{target}-g++
132 %attr(755,root,root) %{_bindir}/%{target}-c++
133 %attr(755,root,root) %{gcclib}/cc1plus
134 %{_mandir}/man1/%{target}-g++.1*
This page took 0.0690499999999999 seconds and 3 git commands to generate.