]> git.pld-linux.org Git - packages/crossavr-gcc.git/blob - crossavr-gcc.spec
- updated to 4.1.2
[packages/crossavr-gcc.git] / crossavr-gcc.spec
1 Summary:        Cross AVR GNU binary utility development utilities - gcc
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR gcc
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR gcc
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - gcc
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR gcc
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR gcc
7 Name:           crossavr-gcc
8 Version:        4.1.2
9 Release:        1
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
14 # Source0-md5:  a4a3eb15c96030906d8494959eeda23c
15 BuildRequires:  autoconf
16 BuildRequires:  /bin/bash
17 BuildRequires:  bison
18 BuildRequires:  crossavr-binutils
19 BuildRequires:  flex
20 Requires:       crossavr-binutils
21 Requires:       gcc-dirs
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         target          avr
25 %define         arch            %{_prefix}/%{target}
26 %define         gccarch         %{_libdir}/gcc/%{target}
27 %define         gcclib          %{_libdir}/gcc/%{target}/%{version}
28 %define         _noautostrip    .*%{gcclib}.*/libgc.*\\.a
29
30 %description
31 This package contains a cross-gcc which allows the creation of
32 binaries to be run on Atmel AVR on other machines.
33
34 %description -l de.UTF-8
35 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
36 anderem Rechner Code für Atmel AVR zu generieren.
37
38 %description -l pl.UTF-8
39 Ten pakiet zawiera skrośny gcc pozwalający na robienie na innych
40 maszynach binariów do uruchamiania na Atmel AVR.
41
42 %package c++
43 Summary:        C++ support for avr-gcc
44 Summary(pl.UTF-8):      Obsługa C++ dla avr-gcc
45 Group:          Development/Languages
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47
48 %description c++
49 This package adds C++ support to the GNU Compiler Collection for AVR.
50
51 %description c++ -l pl.UTF-8
52 Ten pakiet dodaje obsługę C++ do kompilatora gcc dla AVR.
53
54 %prep
55 %setup -q -n gcc-%{version}
56
57 %build
58 rm -rf obj-%{target}
59 install -d obj-%{target}
60 cd obj-%{target}
61
62 CFLAGS="%{rpmcflags}" \
63 CXXFLAGS="%{rpmcflags}" \
64 TEXCONFIG=false \
65 ../configure \
66         --prefix=%{_prefix} \
67         --infodir=%{_infodir} \
68         --mandir=%{_mandir} \
69         --bindir=%{_bindir} \
70         --libdir=%{_libdir} \
71         --libexecdir=%{_libdir} \
72         --disable-shared \
73         --disable-libssp \
74         --enable-languages="c,c++" \
75         --with-gnu-as \
76         --with-gnu-ld \
77         --with-system-zlib \
78         --with-multilib \
79         --without-x \
80         --build=%{_target_platform} \
81         --host=%{_target_platform} \
82         --target=%{target}
83
84 %{__make} CFLAGS_FOR_TARGET="-Os"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C obj-%{target} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # don't want it here
93 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
94
95 %if 0%{!?debug:1}
96 # strip target libraries
97 %{target}-strip -g $RPM_BUILD_ROOT%{gcclib}{,/avr*}/libg*.a
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files 
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/%{target}-gcc*
106 %attr(755,root,root) %{_bindir}/%{target}-cpp
107 %attr(755,root,root) %{_bindir}/%{target}-gcov
108 %dir %{gccarch}
109 %dir %{gcclib}
110 %attr(755,root,root) %{gcclib}/cc1
111 %attr(755,root,root) %{gcclib}/collect2
112 %{gcclib}/libg*.a
113 %{gcclib}/%{target}*
114 %dir %{gcclib}/include
115 %{gcclib}/include/*.h
116 %{_mandir}/man1/%{target}-cpp.1*
117 %{_mandir}/man1/%{target}-gcc.1*
118 %{_mandir}/man1/%{target}-gcov.1*
119
120 %files c++
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/%{target}-g++
123 %attr(755,root,root) %{_bindir}/%{target}-c++
124 %attr(755,root,root) %{gcclib}/cc1plus
125 %{_mandir}/man1/%{target}-g++.1*
This page took 0.114733 seconds and 3 git commands to generate.