]> git.pld-linux.org Git - packages/crash.git/blob - crash.spec
- build eppic extension
[packages/crash.git] / crash.spec
1 # TODO:
2 # - memory_driver kernel module
3 # - libeppic if anything else (but crash extension) wants to use it
4 #
5 Summary:        Core Analysis Suite
6 Summary(pl.UTF-8):      Zestaw narzędzi do analizy zrzutów pamięci
7 Name:           crash
8 Version:        7.0.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Libraries
12 Source0:        http://people.redhat.com/anderson/%{name}-%{version}.tar.gz
13 # Source0-md5:  b59076aebaced87e9073328cb0a4f50a
14 # git clone https://code.google.com/p/eppic
15 Source1:        eppic.tar.xz
16 # Source1-md5:  a9f80ad71de9d6f5b77534a7ebdbed8e
17 URL:            http://people.redhat.com/anderson/
18 BuildRequires:  ncurses-devel
19 BuildRequires:  readline-devel
20 BuildRequires:  xz-devel
21 BuildRequires:  zlib-devel
22 ExclusiveArch:  %{ix86} %{x8664} alpha arm ia64 ppc64 s390 s390x
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The core analysis suite is a self-contained tool that can be used to
27 investigate either live systems, kernel core dumps created from the
28 netdump and diskdump packages offered by Red Hat, the LKCD kernel
29 patch or the mcore kernel patch available from Mission Critical Linux.
30
31 %description -l pl.UTF-8
32 Narzędzie do analizy zrzutów pamięci to samodzielny program służący do
33 badania systemów działających, zrzutów pamięci jądra utworzonych przez
34 pakiety Red Hata netdump lub diskdump, łatę jądra LKCD lub łatę jądra
35 mcore dostępną w Mission Critical Linuksie.
36
37 %package devel
38 Summary:        Header files for core analysis suite
39 Summary(pl.UTF-8):      Plik nagłówkowy narzędzia do analizy zrzutów pamięci
40 Group:          Development/Libraries
41 # doesn't require base
42
43 %description devel
44 Header files for core analysis suite.
45
46 %description devel -l pl.UTF-8
47 Plik nagłówkowy narzędzia do analizy zrzutów pamięci.
48
49 %prep
50 %setup -q -a1
51
52 %{__mv} eppic extensions
53 # TODO: download sources, disable git pull in eppic.mk
54 #%{__mv} extensions/eppic.c{,.skip}
55
56 %build
57 export CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses"
58 %{__make} -j1 all extensions \
59         ARCH="%{_target_cpu}" \
60         CC="%{__cc}" \
61         CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man8,%{_libdir}/crash/extensions,%{_includedir}/crash}
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 # omitted by make install
71 install extensions/*.so $RPM_BUILD_ROOT%{_libdir}/crash/extensions
72 cp -p crash.8 $RPM_BUILD_ROOT%{_mandir}/man8
73 cp -p defs.h $RPM_BUILD_ROOT%{_includedir}/crash
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README
81 %attr(755,root,root) %{_bindir}/crash
82 %dir %{_libdir}/crash
83 %dir %{_libdir}/crash/extensions
84 %attr(755,root,root) %{_libdir}/crash/extensions/dminfo.so
85 %attr(755,root,root) %{_libdir}/crash/extensions/echo.so
86 %attr(755,root,root) %{_libdir}/crash/extensions/eppic.so
87 %attr(755,root,root) %{_libdir}/crash/extensions/snap.so
88 %attr(755,root,root) %{_libdir}/crash/extensions/trace.so
89 %{_mandir}/man8/crash.8*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_includedir}/crash
This page took 0.151547 seconds and 3 git commands to generate.