]> git.pld-linux.org Git - packages/corona.git/blob - corona.spec
- release 5
[packages/corona.git] / corona.spec
1 Summary:        Image input/output library
2 Summary(pl.UTF-8):      Biblioteka wejścia/wyjścia dla obrazów
3 Name:           corona
4 Version:        1.0.2
5 Release:        5
6 License:        zlib
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/corona/%{name}-%{version}.tar.gz
9 # Source0-md5:  29d1a7f1e2c85a83e9620496c62740ce
10 Patch0:         %{name}-system-gif.patch
11 Patch1:         %{name}-config.patch
12 Patch2:         %{name}-gcc43.patch
13 URL:            http://corona.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  dos2unix
17 BuildRequires:  giflib-devel >= 4.1.0
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:1.5
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Corona is an image input/output library that can read, write, and
26 manipulate image files in just a few lines of code. It can write PNG
27 and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
28 designed to be easy to use, and exports a straightforward C++ API.
29 With just a few lines of C++, you can add image loading to your
30 application.
31
32 %description -l pl.UTF-8
33 Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
34 zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
35 Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
36 GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
37 bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
38 wczytywanie obrazów do swojej aplikacji.
39
40 %package devel
41 Summary:        Header files for corona library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki corona
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       giflib-devel >= 4.1.0
46 Requires:       libjpeg-devel
47 Requires:       libpng-devel
48 Requires:       libstdc++-devel
49
50 %description devel
51 Header files for corona library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki corona.
55
56 %package static
57 Summary:        Static corona library
58 Summary(pl.UTF-8):      Statyczna biblioteka corona
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static corona library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka corona.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72 dos2unix src/OpenTGA.cpp
73 %patch2 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
98 %attr(755,root,root) %{_bindir}/corconvert
99 %attr(755,root,root) %{_libdir}/libcorona-*.so
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc doc/tutorial.txt
104 %attr(755,root,root) %{_bindir}/corona-config
105 %attr(755,root,root) %{_libdir}/libcorona.so
106 %{_libdir}/libcorona.la
107 %{_includedir}/corona.h
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libcorona.a
This page took 0.051945 seconds and 3 git commands to generate.