]> git.pld-linux.org Git - packages/corona.git/blob - corona.spec
- new
[packages/corona.git] / corona.spec
1 Summary:        Image input/output library
2 Summary(pl.UTF-8):      Biblioteka wejścia/wyjścia dla obrazów
3 Name:           corona
4 Version:        1.0.2
5 Release:        1
6 License:        zlib
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/corona/%{name}-%{version}.tar.gz
9 # Source0-md5:  29d1a7f1e2c85a83e9620496c62740ce
10 Patch0:         %{name}-system-gif.patch
11 Patch1:         %{name}-config.patch
12 URL:            http://corona.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  giflib-devel >= 4.1.0
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Corona is an image input/output library that can read, write, and
24 manipulate image files in just a few lines of code. It can write PNG
25 and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
26 designed to be easy to use, and exports a straightforward C++ API.
27 With just a few lines of C++, you can add image loading to your
28 application.
29
30 %description -l pl.UTF-8
31 Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
32 zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
33 Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
34 GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
35 bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
36 wczytywanie obrazów do swojej aplikacji.
37
38 %package devel
39 Summary:        Header files for corona library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki corona
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       giflib-devel >= 4.1.0
44 Requires:       libjpeg-devel
45 Requires:       libpng-devel
46 Requires:       libstdc++-devel
47
48 %description devel
49 Header files for corona library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki corona.
53
54 %package static
55 Summary:        Static corona library
56 Summary(pl.UTF-8):      Statyczna biblioteka corona
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static corona library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka corona.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
94 %attr(755,root,root) %{_bindir}/corconvert
95 %attr(755,root,root) %{_libdir}/libcorona-*.so
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc doc/tutorial.txt
100 %attr(755,root,root) %{_bindir}/corona-config
101 %attr(755,root,root) %{_libdir}/libcorona.so
102 %{_libdir}/libcorona.la
103 %{_includedir}/corona.h
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libcorona.a
This page took 0.143011 seconds and 3 git commands to generate.