]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- updated to 1.0 (now uses unicode maildir naming scheme, needs upgrade synchronizati...
[packages/cone.git] / cone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # "make check"
4 %bcond_with     gnutls  # GnuTLS instead of OpenSSL
5 %bcond_with     socks   # (Courier) Socks support
6
7 Summary:        CONE - Console Newsreader and Emailer
8 Summary(pl.UTF-8):      CONE - tekstowy klient poczty i czytnik newsów
9 Name:           cone
10 Version:        1.0
11 Release:        1
12 License:        GPL v3 with OpenSSL exception
13 Group:          Applications/Mail
14 Source0:        http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15 # Source0-md5:  57ea2f089455c3eae4437f243d786606
16 Patch0:         %{name}-maildir.patch
17 Patch1:         %{name}-curses.patch
18 URL:            http://www.courier-mta.org/cone/
19 BuildRequires:  aspell-devel
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 %{?with_socks:BuildRequires:    courier-sox-devel}
23 BuildRequires:  courier-unicode-devel >= 2.0
24 BuildRequires:  fam-devel
25 # or gnupg2 --with-gpg2, will use the same at runtime
26 BuildRequires:  gnupg
27 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0}
28 %{?with_gnutls:BuildRequires:   libgcrypt-devel}
29 %{?with_gnutls:BuildRequires:   libgpg-error-devel}
30 BuildRequires:  libidn-devel >= 0.0.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  libxml2-devel >= 2.0
34 BuildRequires:  ncurses-devel >= 5
35 BuildRequires:  openldap-devel
36 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
37 BuildRequires:  pcre-devel
38 BuildRequires:  perl-base
39 BuildRequires:  pkgconfig
40 BuildRequires:  procps
41 BuildRequires:  sysconftool
42 BuildRequires:  zlib-devel
43 Requires:       ca-certificates
44 Suggests:       gnupg
45 Conflicts:      courier-imap < 5
46 Conflicts:      courier-imapd < 1
47 Conflicts:      maildrop < 3
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 CONE is a simple, text-based E-mail reader and writer, and a simple
52 newsreader.
53
54 %description -l pl.UTF-8
55 CONE jest prostym, tekstowym klientem pocztowym, a także prostym
56 czytnikiem newsów.
57
58 %package devel
59 Summary:        Header files and static LibMAIL library
60 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna LibMAIL
61 Group:          Development/Libraries
62 Requires:       courier-unicode-devel >= 2.0
63 %{?with_gnutls:Requires:        gnutls-devel >= 3.0}
64 Requires:       libidn-devel >= 0.0.0
65 Requires:       libstdc++-devel
66 %{!?with_gnutls:Requires:       openssl-devel >= 0.9.7d}
67 Obsoletes:      cone-static < 0.96
68
69 %description devel
70 This package includes the header files and static library for
71 developing applications using LibMAIL - a high level, C++ OO library
72 for mail clients.
73
74 %description devel -l pl.UTF-8
75 Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
76 tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
77 zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
78
79 %package -n leaf
80 Summary:        Console text file editor
81 Summary(pl.UTF-8):      Konsolowy edytor plików tekstowych
82 Group:          Applications/Editors
83
84 %description -n leaf
85 Leaf is a simple console text file editor, with paragraph
86 word-wrapping and spell checking. Leaf is based on the text editor in
87 the Cone mail reader and composer.
88
89 %description -n leaf -l pl.UTF-8
90 Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
91 wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
92 używanym w czytniku poczty Cone.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
101         if [ -d "$d" ]; then
102                 cd $d
103                 %{__aclocal}
104                 %{__autoconf}
105                 if grep -q AC_CONFIG_HEADER configure.ac ; then
106                         %{__autoheader}
107                 fi
108                 %{__automake}
109                 cd -
110         fi
111 done
112
113 %configure \
114         SENDMAIL=/usr/lib/sendmail \
115         --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
116         --with-devel \
117         %{?with_gnutls:--with-gnutls} \
118         --with-notice=unicode
119
120 %{__make}
121
122 %if %{with tests}
123 %{__make} check
124 %endif
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
133
134 # move docs to more specific location
135 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
136 %{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %triggerpostun -- %{name} < 1
142 %banner -e cone-unicode <<EOF
143 WARNING: you have to convert any existing maildirs to Unicode naming scheme.
144 See INSTALL file for details.
145 EOF
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS COPYING ChangeLog NEWS README
150 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
151 %attr(755,root,root) %{_bindir}/cone
152 %attr(755,root,root) %{_bindir}/mailtool
153 %attr(755,root,root) %{_libexecdir}/cone
154 %{_datadir}/cone
155 %{_mandir}/man1/cone.1*
156 %{_mandir}/man1/mailtool.1*
157 %dir %{_docdir}/%{name}
158 %{_docdir}/%{name}/FAQ.html
159 %{_docdir}/%{name}/INSTALL.html
160 %{_docdir}/%{name}/README.html
161 %{_docdir}/%{name}/add.html
162 %{_docdir}/%{name}/attributes.html
163 %{_docdir}/%{name}/bk01-toc.html
164 %{_docdir}/%{name}/cone*.html
165 %{_docdir}/%{name}/conn.html
166 %{_docdir}/%{name}/index.html
167 %{_docdir}/%{name}/maillist.html
168 %{_docdir}/%{name}/mailtool.html
169 %{_docdir}/%{name}/manpage.css
170 %{_docdir}/%{name}/moredocs.html
171 %{_docdir}/%{name}/search.html
172 %{_docdir}/%{name}/smap*.html
173 %{_docdir}/%{name}/store.html
174
175 %files devel
176 %defattr(644,root,root,755)
177 %{_libdir}/libmail.a
178 %{_libdir}/libmail.la
179 %{_includedir}/libmail
180 %{_mandir}/man3/mail::*.3x*
181 %dir %{_docdir}/%{name}
182 %{_docdir}/%{name}/account-*.html
183 %{_docdir}/%{name}/address.html
184 %{_docdir}/%{name}/cppnamespace.html
185 %{_docdir}/%{name}/emailaddress.html
186 %{_docdir}/%{name}/envelope.html
187 %{_docdir}/%{name}/folder-*.html
188 %{_docdir}/%{name}/header-*.html
189 %{_docdir}/%{name}/libmail*.html
190 %{_docdir}/%{name}/mail-*.html
191 %{_docdir}/%{name}/mimestruct.html
192 %{_docdir}/%{name}/misc.html
193 %{_docdir}/%{name}/native.html
194 %{_docdir}/%{name}/synchronous.html
195
196 %files -n leaf
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/leaf
199 %{_mandir}/man1/leaf.1*
200 %dir %{_docdir}/%{name}
201 %{_docdir}/%{name}/leaf.html
This page took 0.084406 seconds and 4 git commands to generate.