]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- disable tests (require working valgrind)
[packages/cone.git] / cone.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" (requires operational valgrind, i.e. with glibc-debuginfo)
4 %bcond_with     gnutls  # GnuTLS instead of OpenSSL
5 %bcond_with     socks   # (Courier) Socks support
6
7 Summary:        CONE - Console Newsreader and Emailer
8 Summary(pl.UTF-8):      CONE - tekstowy klient poczty i czytnik newsów
9 Name:           cone
10 Version:        1.8
11 Release:        1
12 License:        GPL v3 with OpenSSL exception
13 Group:          Applications/Mail
14 Source0:        https://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15 # Source0-md5:  3b5c398c693d6aa60ea90f4d19f0ac39
16 Patch0:         %{name}-maildir.patch
17 Patch1:         %{name}-curses.patch
18 URL:            http://www.courier-mta.org/cone/
19 BuildRequires:  aspell-devel
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 %{?with_socks:BuildRequires:    courier-sox-devel}
23 BuildRequires:  courier-unicode-devel >= 2.1
24 BuildRequires:  gettext-tools
25 # or gnupg2 --with-gpg2, will use the same at runtime
26 BuildRequires:  gnupg
27 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0}
28 %{?with_gnutls:BuildRequires:   libgcrypt-devel}
29 %{?with_gnutls:BuildRequires:   libgpg-error-devel}
30 BuildRequires:  libidn2-devel >= 0.0.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  libxml2-devel >= 2.0
34 BuildRequires:  ncurses-devel >= 5
35 BuildRequires:  openldap-devel
36 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
37 BuildRequires:  pcre2-8-devel
38 BuildRequires:  perl-base
39 BuildRequires:  pkgconfig
40 BuildRequires:  procps
41 BuildRequires:  sysconftool
42 %{?with_tests:BuildRequires:    valgrind}
43 BuildRequires:  zlib-devel
44 Requires:       ca-certificates
45 Suggests:       gnupg
46 Conflicts:      courier-imap < 5
47 Conflicts:      courier-imapd < 1
48 Conflicts:      maildrop < 3
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 CONE is a simple, text-based E-mail reader and writer, and a simple
53 newsreader.
54
55 %description -l pl.UTF-8
56 CONE jest prostym, tekstowym klientem pocztowym, a także prostym
57 czytnikiem newsów.
58
59 %package devel
60 Summary:        Header files and static LibMAIL library
61 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna LibMAIL
62 Group:          Development/Libraries
63 Requires:       courier-unicode-devel >= 2.0
64 %{?with_gnutls:Requires:        gnutls-devel >= 3.0}
65 Requires:       libidn2-devel >= 0.0.0
66 Requires:       libstdc++-devel
67 %{!?with_gnutls:Requires:       openssl-devel >= 0.9.7d}
68 Obsoletes:      cone-static < 0.96
69
70 %description devel
71 This package includes the header files and static library for
72 developing applications using LibMAIL - a high level, C++ OO library
73 for mail clients.
74
75 %description devel -l pl.UTF-8
76 Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
77 tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
78 zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
79
80 %package -n leaf
81 Summary:        Console text file editor
82 Summary(pl.UTF-8):      Konsolowy edytor plików tekstowych
83 Group:          Applications/Editors
84
85 %description -n leaf
86 Leaf is a simple console text file editor, with paragraph
87 word-wrapping and spell checking. Leaf is based on the text editor in
88 the Cone mail reader and composer.
89
90 %description -n leaf -l pl.UTF-8
91 Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
92 wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
93 używanym w czytniku poczty Cone.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
102         if [ -d "$d" ]; then
103                 cd $d
104                 %{__aclocal}
105                 %{__autoconf}
106                 if grep -q AC_CONFIG_HEADER configure.ac ; then
107                         %{__autoheader}
108                 fi
109                 %{__automake}
110                 cd -
111         fi
112 done
113
114 %configure \
115         SENDMAIL=/usr/lib/sendmail \
116         --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
117         --with-devel \
118         %{?with_gnutls:--with-gnutls} \
119         --with-notice=unicode
120
121 %{__make}
122
123 %if %{with tests}
124 %{__make} check
125 %endif
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
134
135 # move docs to more specific location
136 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
137 %{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %triggerpostun -- %{name} < 1
143 %banner -e cone-unicode <<EOF
144 WARNING: you have to convert any existing maildirs to Unicode naming scheme.
145 See INSTALL file for details.
146 EOF
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS COPYING ChangeLog NEWS README
151 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
152 %attr(755,root,root) %{_bindir}/cone
153 %attr(755,root,root) %{_bindir}/mailtool
154 %attr(755,root,root) %{_libexecdir}/cone
155 %{_datadir}/cone
156 %{_mandir}/man1/cone.1*
157 %{_mandir}/man1/mailtool.1*
158 %dir %{_docdir}/%{name}
159 %{_docdir}/%{name}/FAQ.html
160 %{_docdir}/%{name}/INSTALL.html
161 %{_docdir}/%{name}/README.html
162 %{_docdir}/%{name}/add.html
163 %{_docdir}/%{name}/attributes.html
164 %{_docdir}/%{name}/bk01-toc.html
165 %{_docdir}/%{name}/cone*.html
166 %{_docdir}/%{name}/conn.html
167 %{_docdir}/%{name}/index.html
168 %{_docdir}/%{name}/maillist.html
169 %{_docdir}/%{name}/mailtool.html
170 %{_docdir}/%{name}/manpage.css
171 %{_docdir}/%{name}/moredocs.html
172 %{_docdir}/%{name}/search.html
173 %{_docdir}/%{name}/smap*.html
174 %{_docdir}/%{name}/store.html
175
176 %files devel
177 %defattr(644,root,root,755)
178 %{_libdir}/libmail.a
179 %{_libdir}/libmail.la
180 %{_includedir}/libmail
181 %{_mandir}/man3/mail::*.3x*
182 %dir %{_docdir}/%{name}
183 %{_docdir}/%{name}/account-*.html
184 %{_docdir}/%{name}/address.html
185 %{_docdir}/%{name}/cppnamespace.html
186 %{_docdir}/%{name}/emailaddress.html
187 %{_docdir}/%{name}/envelope.html
188 %{_docdir}/%{name}/folder-*.html
189 %{_docdir}/%{name}/header-*.html
190 %{_docdir}/%{name}/libmail*.html
191 %{_docdir}/%{name}/mail-*.html
192 %{_docdir}/%{name}/mimestruct.html
193 %{_docdir}/%{name}/misc.html
194 %{_docdir}/%{name}/native.html
195 %{_docdir}/%{name}/synchronous.html
196
197 %files -n leaf
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/leaf
200 %{_mandir}/man1/leaf.1*
201 %dir %{_docdir}/%{name}
202 %{_docdir}/%{name}/leaf.html
This page took 0.076231 seconds and 4 git commands to generate.