]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- up to 1.2
[packages/cone.git] / cone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # "make check"
4 %bcond_with     gnutls  # GnuTLS instead of OpenSSL
5 %bcond_with     socks   # (Courier) Socks support
6
7 Summary:        CONE - Console Newsreader and Emailer
8 Summary(pl.UTF-8):      CONE - tekstowy klient poczty i czytnik newsów
9 Name:           cone
10 Version:        1.2
11 Release:        1
12 License:        GPL v3 with OpenSSL exception
13 Group:          Applications/Mail
14 Source0:        http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15 # Source0-md5:  a845692b6d50fc8b58df2f1b99344623
16 Patch0:         %{name}-maildir.patch
17 Patch1:         %{name}-curses.patch
18 URL:            http://www.courier-mta.org/cone/
19 BuildRequires:  aspell-devel
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 %{?with_socks:BuildRequires:    courier-sox-devel}
23 BuildRequires:  courier-unicode-devel >= 2.1
24 # or gnupg2 --with-gpg2, will use the same at runtime
25 BuildRequires:  gnupg
26 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0}
27 %{?with_gnutls:BuildRequires:   libgcrypt-devel}
28 %{?with_gnutls:BuildRequires:   libgpg-error-devel}
29 BuildRequires:  libidn-devel >= 0.0.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  libxml2-devel >= 2.0
33 BuildRequires:  ncurses-devel >= 5
34 BuildRequires:  openldap-devel
35 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
36 BuildRequires:  pcre-devel
37 BuildRequires:  perl-base
38 BuildRequires:  pkgconfig
39 BuildRequires:  procps
40 BuildRequires:  sysconftool
41 BuildRequires:  zlib-devel
42 Requires:       ca-certificates
43 Suggests:       gnupg
44 Conflicts:      courier-imap < 5
45 Conflicts:      courier-imapd < 1
46 Conflicts:      maildrop < 3
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 CONE is a simple, text-based E-mail reader and writer, and a simple
51 newsreader.
52
53 %description -l pl.UTF-8
54 CONE jest prostym, tekstowym klientem pocztowym, a także prostym
55 czytnikiem newsów.
56
57 %package devel
58 Summary:        Header files and static LibMAIL library
59 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna LibMAIL
60 Group:          Development/Libraries
61 Requires:       courier-unicode-devel >= 2.0
62 %{?with_gnutls:Requires:        gnutls-devel >= 3.0}
63 Requires:       libidn-devel >= 0.0.0
64 Requires:       libstdc++-devel
65 %{!?with_gnutls:Requires:       openssl-devel >= 0.9.7d}
66 Obsoletes:      cone-static < 0.96
67
68 %description devel
69 This package includes the header files and static library for
70 developing applications using LibMAIL - a high level, C++ OO library
71 for mail clients.
72
73 %description devel -l pl.UTF-8
74 Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
75 tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
76 zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
77
78 %package -n leaf
79 Summary:        Console text file editor
80 Summary(pl.UTF-8):      Konsolowy edytor plików tekstowych
81 Group:          Applications/Editors
82
83 %description -n leaf
84 Leaf is a simple console text file editor, with paragraph
85 word-wrapping and spell checking. Leaf is based on the text editor in
86 the Cone mail reader and composer.
87
88 %description -n leaf -l pl.UTF-8
89 Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
90 wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
91 używanym w czytniku poczty Cone.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 %{__libtoolize}
99 for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
100         if [ -d "$d" ]; then
101                 cd $d
102                 %{__aclocal}
103                 %{__autoconf}
104                 if grep -q AC_CONFIG_HEADER configure.ac ; then
105                         %{__autoheader}
106                 fi
107                 %{__automake}
108                 cd -
109         fi
110 done
111
112 %configure \
113         SENDMAIL=/usr/lib/sendmail \
114         --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
115         --with-devel \
116         %{?with_gnutls:--with-gnutls} \
117         --with-notice=unicode
118
119 %{__make}
120
121 %if %{with tests}
122 %{__make} check
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
132
133 # move docs to more specific location
134 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
135 %{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %triggerpostun -- %{name} < 1
141 %banner -e cone-unicode <<EOF
142 WARNING: you have to convert any existing maildirs to Unicode naming scheme.
143 See INSTALL file for details.
144 EOF
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS COPYING ChangeLog NEWS README
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
150 %attr(755,root,root) %{_bindir}/cone
151 %attr(755,root,root) %{_bindir}/mailtool
152 %attr(755,root,root) %{_libexecdir}/cone
153 %{_datadir}/cone
154 %{_mandir}/man1/cone.1*
155 %{_mandir}/man1/mailtool.1*
156 %dir %{_docdir}/%{name}
157 %{_docdir}/%{name}/FAQ.html
158 %{_docdir}/%{name}/INSTALL.html
159 %{_docdir}/%{name}/README.html
160 %{_docdir}/%{name}/add.html
161 %{_docdir}/%{name}/attributes.html
162 %{_docdir}/%{name}/bk01-toc.html
163 %{_docdir}/%{name}/cone*.html
164 %{_docdir}/%{name}/conn.html
165 %{_docdir}/%{name}/index.html
166 %{_docdir}/%{name}/maillist.html
167 %{_docdir}/%{name}/mailtool.html
168 %{_docdir}/%{name}/manpage.css
169 %{_docdir}/%{name}/moredocs.html
170 %{_docdir}/%{name}/search.html
171 %{_docdir}/%{name}/smap*.html
172 %{_docdir}/%{name}/store.html
173
174 %files devel
175 %defattr(644,root,root,755)
176 %{_libdir}/libmail.a
177 %{_libdir}/libmail.la
178 %{_includedir}/libmail
179 %{_mandir}/man3/mail::*.3x*
180 %dir %{_docdir}/%{name}
181 %{_docdir}/%{name}/account-*.html
182 %{_docdir}/%{name}/address.html
183 %{_docdir}/%{name}/cppnamespace.html
184 %{_docdir}/%{name}/emailaddress.html
185 %{_docdir}/%{name}/envelope.html
186 %{_docdir}/%{name}/folder-*.html
187 %{_docdir}/%{name}/header-*.html
188 %{_docdir}/%{name}/libmail*.html
189 %{_docdir}/%{name}/mail-*.html
190 %{_docdir}/%{name}/mimestruct.html
191 %{_docdir}/%{name}/misc.html
192 %{_docdir}/%{name}/native.html
193 %{_docdir}/%{name}/synchronous.html
194
195 %files -n leaf
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/leaf
198 %{_mandir}/man1/leaf.1*
199 %dir %{_docdir}/%{name}
200 %{_docdir}/%{name}/leaf.html
This page took 0.046307 seconds and 4 git commands to generate.