]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- adapterized
[packages/cone.git] / cone.spec
1 #
2 # TODO:
3 #   - review devel doc files
4 #
5 Summary:        CONE - Console Newsreader and Emailer
6 Summary(pl.UTF-8):      CONE - tekstowy klient poczty i czytnik newsów
7 Name:           cone
8 Version:        0.89
9 Release:        1
10 License:        GPL
11 Group:          Applications/Mail
12 Source0:        http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7ee8b8c0fe89d96bca3e93a2b82adfb9
14 Patch0:         %{name}-maildir.patch
15 URL:            http://www.courier-mta.org/cone/
16 BuildRequires:  aspell-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  fam-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel
23 BuildRequires:  ncurses-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  openssl-tools-perl
26 BuildRequires:  perl-base
27 BuildRequires:  sysconftool
28 BuildRequires:  zlib-devel
29 Requires:       ca-certificates
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 CONE is a simple, text-based E-mail reader and writer, and a simple
34 newsreader.
35
36 %description -l pl.UTF-8
37 CONE jest prostym, tekstowym klientem pocztowym, a także prostym
38 czytnikiem newsów.
39
40 %package devel
41 Summary:        Header files for LibMAIL
42 Summary(pl.UTF-8):      Pliki nagłówkowe LibMAIL
43 Group:          Development/Languages
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 This package includes the header files for developing applications
48 using LibMAIL - a high level, C++ OO library for mail clients.
49
50 %description devel -l pl.UTF-8
51 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji z
52 użyciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo
53 biblioteki C++ dla klientów pocztowych.
54
55 %package static
56 Summary:        Static LibMAIL library
57 Summary(pl.UTF-8):      Biblioteka statyczna LibMAIL
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 This package contains static library for developing application using
63 LibMAIL - a high level, C++ OO library for mail clients.
64
65 %description static -l pl.UTF-8
66 Ten pakiet zawiera statyczną bibliotekę do tworzenia aplikacji z
67 użyciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo
68 biblioteki C++ dla klientów pocztowych.
69
70 %package -n leaf
71 Summary:        Console text file editor
72 Summary(pl.UTF-8):      Konsolowy edytor plików tekstowych
73 Group:          Applications/Editors
74
75 %description -n leaf
76 Leaf is a simple console text file editor, with paragraph
77 word-wrapping and spell checking. Leaf is based on the text editor in
78 the Cone mail reader and composer.
79
80 %description -n leaf -l pl.UTF-8
81 Leaf jest prostym konsolowym edytorem plików tekstowych. Jest oparty
82 na edytorze używanym w czytniku poczty Cone.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 #%{__libtoolize}
90 #%{__aclocal}
91 #%{__autoconf}
92 #%{__automake}
93
94 #cd cone
95 #%{__aclocal}
96 #%{__autoconf}
97 #%{__automake}
98
99 #cd ../libmail
100 #%{__aclocal}
101 #%{__autoconf}
102 #%{__automake}
103
104 #cd ../maildir
105 #%{__aclocal}
106 #%{__autoconf}
107 #%{__automake}
108 #cd ..
109
110
111 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
112 LDFLAGS="%{rpmldflags} -ltinfow"
113 PATH=$PATH:%{_prefix}/%{_lib}/openssl; export PATH
114 %configure \
115         --with-devel \
116         --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
117         SENDMAIL=%{_sbindir}/sendmail
118
119 %{__make}
120
121 #%{__make} check
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 # start cone directly
130 #mv -f $RPM_BUILD_ROOT%{_libdir}/cone $RPM_BUILD_ROOT%{_bindir}
131 cp cone.sh $RPM_BUILD_ROOT%{_bindir}/cone
132 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
133
134 # move devel docs from datadir
135 mkdir devel
136 for file in account-* address.html e*.html folder-* \
137 header* libmail*.html mail-* mimestruct* misc* native* synchronous.html; do
138 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/$file devel
139 done
140
141 # leaf doc
142 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/leaf.html .
143
144 # rest *.html will go to primary docs
145 mkdir docs
146 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/*.html docs
147 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/manpage.css docs
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog README NEWS docs/
155 %config(noreplace)  %verify(not md5 mtime size) %{_sysconfdir}/cone
156 %attr(755,root,root) %{_bindir}/cone
157 %attr(755,root,root) %{_bindir}/mailtool
158 %attr(755,root,root) %{_libdir}/cone
159 %{_datadir}/cone
160 %{_mandir}/man1/cone*
161 %{_mandir}/man1/mailtool*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %doc devel/*
166 %{_libdir}/libmail.la
167 %{_includedir}/libmail
168 %{_mandir}/man3/*
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libmail.a
173
174 %files -n leaf
175 %defattr(644,root,root,755)
176 %doc leaf.html
177 %attr(755,root,root) %{_bindir}/leaf
178 %{_mandir}/man1/leaf*
This page took 0.077429 seconds and 4 git commands to generate.