]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- remaining pl, cleanups/fixes/unifications
[packages/cone.git] / cone.spec
1 #
2 # TODO:
3 #       - maybe split leaf editor ??
4 #       - look at html files
5 #
6 Summary:        CONE - COnsole Newsreader and Emailer
7 Summary(pl):    CONE - tekstowy klient poczty i czytnik newsów
8 Name:           cone
9 Version:        0.60
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/Mail
13 Source0:        http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b2ae0cb3808e5485d566474c8bf251f9
15 URL:            http://www.courier-mta.org/cone/
16 BuildRequires:  aspell-devel
17 BuildRequires:  autoconf
18 BuildRequires:  fam-devel
19 BuildRequires:  ncurses-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  openssl-tools-perl
25 BuildRequires:  perl-base
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 CONE is a simple, text-based E-mail reader and writer, and a simple
31 newsreader.
32
33 %description -l pl
34 CONE jest prostym, tekstowym klientem pocztowym, a tak¿e prostym
35 czytnikiem newsów.
36
37 %package devel
38 Summary:        Header files for LibMAIL
39 Summary(pl):    Pliki nag³ówkowe LibMAIL
40 Group:          Development/Languages
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 This package includes the header files for developing applications
45 using LibMAIL - a high level, C++ OO library for mail clients.
46
47 %description devel -l pl
48 Ten pakiet zawiera pliki nag³ówkowe do tworzenia aplikacji z u¿yciem
49 LibMAIL - wysokopoziomowej, zorientowanej obiektowo biblioteki C++ dla
50 klientów pocztowych.
51
52 %package static
53 Summary:        Static LibMAIL library
54 Summary(pl):    Biblioteka statyczna LibMAIL
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 This package contains static library for developing application using
60 LibMAIL - a high level, C++ OO library for mail clients.
61
62 %description static -l pl
63 Ten pakiet zawiera statyczn± bibliotekê do tworzenia aplikacji z
64 u¿yciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo biblioteki
65 C++ dla klientów pocztowych.
66
67 %prep
68 %setup -q
69
70 %build
71 CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
72 PATH=$PATH:/usr/%{_lib}/openssl; export PATH
73 %configure \
74         --with-devel
75
76 %{__make}
77
78 %{__make} check
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # start cone directly
87 mv -f $RPM_BUILD_ROOT%{_libdir}/cone $RPM_BUILD_ROOT%{_bindir}
88 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
89
90 # move devel docs from datadir
91 mkdir devel
92 for file in account-* address.html book.html c2*.html e*.html folder-* \
93 mail-* mimestruct* native* r11* r8* synchronous.html; do
94 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/$file devel
95 done
96
97 # rest *.html will go to primary docs
98 mkdir docs
99 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/*.html docs
100
101 # install missing files
102 install libmail/mailtool $RPM_BUILD_ROOT%{_bindir}/mailtool
103 install help.txt $RPM_BUILD_ROOT%{_datadir}/cone
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ABOUT-NLS ChangeLog README NEWS AUTHORS docs/
111 %config(noreplace)  %verify(not size mtime md5) %{_sysconfdir}/cone
112 %attr(755,root,root) %{_bindir}/cone
113 %attr(755,root,root) %{_bindir}/leaf
114 %attr(755,root,root) %{_bindir}/mailtool
115 %{_datadir}/cone
116 %{_mandir}/man1/*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %doc devel/
121 %{_includedir}/libmail
122 %{_mandir}/man[35]/*
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libmail.a
This page took 0.488109 seconds and 3 git commands to generate.