]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- 0.86
[packages/cone.git] / cone.spec
1 #
2 # TODO:
3 #   - review devel doc files
4 #
5 Summary:        CONE - Console Newsreader and Emailer
6 Summary(pl.UTF-8):      CONE - tekstowy klient poczty i czytnik newsów
7 Name:           cone
8 Version:        0.86
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/Mail
12 Source0:        http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
13 # Source0-md5:  adca3a228526361e9ef4eb4dcd273306
14 Patch0:         %{name}-maildir.patch
15 URL:            http://www.courier-mta.org/cone/
16 BuildRequires:  aspell-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  fam-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel
23 BuildRequires:  ncurses-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  openssl-tools-perl
26 BuildRequires:  perl-base
27 BuildRequires:  sysconftool
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 CONE is a simple, text-based E-mail reader and writer, and a simple
33 newsreader.
34
35 %description -l pl.UTF-8
36 CONE jest prostym, tekstowym klientem pocztowym, a także prostym
37 czytnikiem newsów.
38
39 %package devel
40 Summary:        Header files for LibMAIL
41 Summary(pl.UTF-8):      Pliki nagłówkowe LibMAIL
42 Group:          Development/Languages
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 This package includes the header files for developing applications
47 using LibMAIL - a high level, C++ OO library for mail clients.
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji z użyciem
51 LibMAIL - wysokopoziomowej, zorientowanej obiektowo biblioteki C++ dla
52 klientów pocztowych.
53
54 %package static
55 Summary:        Static LibMAIL library
56 Summary(pl.UTF-8):      Biblioteka statyczna LibMAIL
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 This package contains static library for developing application using
62 LibMAIL - a high level, C++ OO library for mail clients.
63
64 %description static -l pl.UTF-8
65 Ten pakiet zawiera statyczną bibliotekę do tworzenia aplikacji z
66 użyciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo biblioteki
67 C++ dla klientów pocztowych.
68
69 %package -n leaf
70 Summary:        Console text file editor
71 Summary(pl.UTF-8):      Konsolowy edytor plików tekstowych
72 Group:          Applications/Editors
73
74 %description -n leaf
75 Leaf is a simple console text file editor, with paragraph
76 word-wrapping and spell checking. Leaf is based on the text editor in
77 the Cone mail reader and composer.
78
79 %description -n leaf -l pl.UTF-8
80 Leaf jest prostym konsolowym edytorem plików tekstowych. Jest oparty
81 na edytorze używanym w czytniku poczty Cone.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92
93 cd cone
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97
98 cd ../libmail
99 %{__aclocal}
100 %{__autoconf}
101 %{__automake}
102
103 cd ../maildir
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 cd ..
108
109 CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
110 PATH=$PATH:/usr/%{_lib}/openssl; export PATH
111 %configure \
112         --with-devel \
113         SENDMAIL=%{_sbindir}/sendmail
114
115 %{__make}
116
117 %{__make} check
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 # start cone directly
126 mv -f $RPM_BUILD_ROOT%{_libdir}/cone $RPM_BUILD_ROOT%{_bindir}
127 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
128
129 # move devel docs from datadir
130 mkdir devel
131 for file in account-* address.html e*.html folder-* \
132 header* libmail*.html mail-* mimestruct* misc* native* synchronous.html; do
133 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/$file devel
134 done
135
136 # leaf doc
137 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/leaf.html .
138
139 # rest *.html will go to primary docs
140 mkdir docs
141 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/*.html docs
142 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/manpage.css docs
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog README NEWS docs/
150 %config(noreplace)  %verify(not md5 mtime size) %{_sysconfdir}/cone
151 %attr(755,root,root) %{_bindir}/cone
152 %attr(755,root,root) %{_bindir}/mailtool
153 %{_datadir}/cone
154 %{_mandir}/man1/cone*
155 %{_mandir}/man1/mailtool*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc devel/*
160 %{_libdir}/libmail.la
161 %{_includedir}/libmail
162 %{_mandir}/man3/*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libmail.a
167
168 %files -n leaf
169 %defattr(644,root,root,755)
170 %doc leaf.html
171 %attr(755,root,root) %{_bindir}/leaf
172 %{_mandir}/man1/leaf*
This page took 0.07335 seconds and 3 git commands to generate.