]> git.pld-linux.org Git - packages/cone.git/blob - cone.spec
- adapterized
[packages/cone.git] / cone.spec
1 #
2 # TODO:
3 #       - pl description
4 #       - maybe split leaf editor ??
5 #       - look at html files
6 #
7 Summary:        CONE mail reader
8 Summary(pl):    Czytnik poczty
9 Name:           cone
10 Version:        0.60
11 Release:        0.1
12 License:        GPL
13 Group:          Applications/Mail
14 Source0:        http://dl.sourceforge.net/sourceforge/courier/%{name}-%{version}.tar.bz2
15 # Source0-md5:  b2ae0cb3808e5485d566474c8bf251f9
16 URL:            http://www.courier-mta.org/cone
17 BuildRequires:  aspell-devel
18 BuildRequires:  autoconf
19 BuildRequires:  fam-devel
20 BuildRequires:  gcc-c++
21 BuildRequires:  ncurses-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  perl
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 CONE is a simple, text-based E-mail reader and writer.
32
33 %description -l pl
34 CONE jest prostym, tekstowym klientem pocztowym.
35
36 %package        devel
37 Group:          Development/Languages
38 Summary:        Header files for LibMAIL
39 Summary(pl):    Pliki nag³ówkowe LibMAIL
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 This package includes the header files for developing application
44 using LibMAIL - a high level, C++ OO library for mail clients.
45
46 %description devel -l pl
47 pusty
48
49 %package        static
50 Group:          Development/Libraries
51 Summary:        Static libraries for LibMAIL
52 Summary(pl):    Biblioteki statyczne LibMAIL
53 Requires:       %{name} = %{version}-%{release}
54
55 %description static
56 This package includes static files for developing application using
57 LibMAIL - a high level, C++ OO library for mail clients.
58
59 %description static -l pl
60 pusty
61
62 %prep
63 %setup -q
64
65 %build
66 CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
67 %configure \
68     --with-devel
69
70 %{__make}
71
72 %{__make} check
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 # start cone directly
81 mv -f $RPM_BUILD_ROOT%{_libdir}/cone $RPM_BUILD_ROOT%{_bindir}/
82 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
83
84 # move devel docs from datadir
85 mkdir devel
86 for file in account-* address.html book.html c2*.html e*.html folder-* \
87 mail-* mimestruct* native* r11* r8* synchronous.html; do
88 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/$file devel
89 done
90
91 # rest *.html will go to primary docs
92 mkdir docs
93 mv -f $RPM_BUILD_ROOT%{_datadir}/cone/*.html docs
94
95 # install missing files
96 install libmail/mailtool $RPM_BUILD_ROOT%{_bindir}/mailtool
97 install help.txt $RPM_BUILD_ROOT%{_datadir}/cone/
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ABOUT-NLS ChangeLog README NEWS AUTHORS docs/
105 %attr(0644,root,root) %config(noreplace)  %verify(not size mtime md5) %{_sysconfdir}/cone
106 %attr(0755,root,root) %{_bindir}/cone
107 %attr(0755,root,root) %{_bindir}/leaf
108 %attr(0755,root,root) %{_bindir}/mailtool
109 %{_datadir}/cone
110 %{_mandir}/man1/*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc devel/
115 %{_mandir}/man[35]/*
116 %{_includedir}/libmail
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libmail.a
This page took 1.301048 seconds and 3 git commands to generate.