]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
- updated to 0.1.16
[packages/colord.git] / colord.spec
1 # TODO: systemd units (--with-systemdsystemunitdir=...)
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # do not build and package API docs
5 %bcond_without  static_libs     # don't build static libraries
6 %bcond_without  vala            # don't build Vala API
7 #
8 Summary:        Color daemon - system daemon for managing color devices
9 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
10 Name:           colord
11 Version:        0.1.16
12 Release:        1
13 License:        GPL v2+ and LGPL v2+
14 Group:          Daemons
15 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
16 # Source0-md5:  cb73ffdcebe4c06852c48355e83a4bc4
17 URL:            http://www.freedesktop.org/software/colord/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  dbus-devel
21 BuildRequires:  gettext-devel >= 0.17
22 BuildRequires:  glib2-devel >= 1:2.28.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.8
24 BuildRequires:  gtk-doc >= 1.9
25 BuildRequires:  intltool >= 0.40.0
26 BuildRequires:  lcms2-devel >= 2.2
27 BuildRequires:  libgusb-devel >= 0.1.1
28 BuildRequires:  libtool
29 BuildRequires:  libusb-devel >= 1.0.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  polkit-devel >= 0.103
32 BuildRequires:  sane-backends-devel >= 1.0.20-3
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  udev-glib-devel
35 %{?with_vala:BuildRequires:     vala}
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       polkit-libs >= 0.103
38 Suggests:       shared-color-profiles
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 colord is a low level system activated daemon that maps color devices
43 to color profiles in the system context.
44
45 %description -l pl.UTF-8
46 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
47 obsługujące kolory na profile kolorów w kontekście systemu.
48
49 %package libs
50 Summary:        colord library
51 Summary(pl.UTF-8):      Biblioteka colord
52 Group:          Libraries
53 Requires:       glib2 >= 1:2.28.0
54 Suggests:       %{name} = %{version}-%{release}
55 Conflicts:      colord < 0.1.12-4
56
57 %description libs
58 colord library.
59
60 %description libs -l pl.UTF-8
61 Biblioteka colord.
62
63 %package devel
64 Summary:        Header files for colord library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       dbus-devel
69 Requires:       glib2-devel >= 1:2.28.0
70
71 %description devel
72 Header files for colord library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki colord.
76
77 %package static
78 Summary:        Static colord library
79 Summary(pl.UTF-8):      Statyczna biblioteka colord
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static colord library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka colord.
88
89 %package apidocs
90 Summary:        colord API documentation
91 Summary(pl.UTF-8):      Dokumentacja API colord
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 colord API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API colord.
100
101 %package -n vala-colord
102 Summary:        colord API for Vala language
103 Summary(pl.UTF-8):      API colord dla języka Vala
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description -n vala-colord
108 colord API for Vala language.
109
110 %description -n vala-colord -l pl.UTF-8
111 API colord dla języka Vala.
112
113 %prep
114 %setup -q
115
116 %build
117 %{__intltoolize}
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --disable-silent-rules \
125         %{__enable_disable apidocs gtk-doc} \
126         %{__enable_disable static_libs static} \
127         --with-html-dir=%{_gtkdocdir}
128 # doc build is broken with -j
129 %{__make} -j1
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
140
141 # the same as it locale
142 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/it_IT
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   libs -p /sbin/ldconfig
150 %postun libs -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README TODO
155 %attr(755,root,root) %{_bindir}/cd-create-profile
156 %attr(755,root,root) %{_bindir}/cd-fix-profile
157 %attr(755,root,root) %{_bindir}/colormgr
158 %attr(755,root,root) %{_libexecdir}/colord
159 %dir %{_libdir}/colord-sensors
160 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_colorhug.so
161 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
162 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
163 # disabled for now
164 #%attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
165 %dir %{_datadir}/color/icc/colord
166 %{_datadir}/color/icc/colord/*.icc
167 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
168 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
169 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
170 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
171 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
172 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
173 %{_mandir}/man1/cd-create-profile.1*
174 %{_mandir}/man1/cd-fix-profile.1*
175 %{_mandir}/man1/colormgr.1*
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
177 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
178 /lib/udev/rules.d/69-cd-sensors.rules
179 /lib/udev/rules.d/95-cd-devices.rules
180 %dir /var/lib/colord
181
182 %files libs
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
186 %{_libdir}/girepository-1.0/Colord-1.0.typelib
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libcolord.so
191 %{_includedir}/colord-1
192 %{_pkgconfigdir}/colord.pc
193 %{_datadir}/gir-1.0/Colord-1.0.gir
194
195 %if %{with static_libs}
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libcolord.a
199 %endif
200
201 %if %{with apidocs}
202 %files apidocs
203 %defattr(644,root,root,755)
204 %{_gtkdocdir}/colord
205 %endif
206
207 %if %{with vala}
208 %files -n vala-colord
209 %defattr(644,root,root,755)
210 %{_datadir}/vala/vapi/colord.vapi
211 %endif
This page took 0.039113 seconds and 3 git commands to generate.