]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
noarch apidocs
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 %bcond_without  gles1           # OpenGL-ES 1.1 support
6 %bcond_without  gles2           # OpenGL-ES 2.0 support
7 %bcond_without  kms             # KMS EGL support
8 %bcond_without  gstreamer       # GStreamer support
9 %bcond_without  wayland         # Wayland EGL support
10
11 Summary:        A library for using 3D graphics hardware to draw pretty pictures
12 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
13 Name:           cogl
14 Version:        1.18.0
15 Release:        2
16 License:        LGPL v2+
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.18/%{name}-%{version}.tar.xz
19 # Source0-md5:  994a29f5c02768367b6f035bfe456ba6
20 Patch0:         %{name}-link.patch
21 URL:            http://www.clutter-project.org/
22 %{?with_wayland:BuildRequires:  EGL-devel}
23 %{?with_kms:BuildRequires:      Mesa-libgbm-devel}
24 %{?with_wayland:BuildRequires:  Mesa-libwayland-egl-devel >= 1.0.0}
25 BuildRequires:  OpenGL-GLX-devel
26 %{?with_gles1:BuildRequires:    OpenGLESv1-devel >= 1.1}
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.11
29 BuildRequires:  cairo-devel >= 1.10
30 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
31 BuildRequires:  gettext-devel >= 0.18.1
32 BuildRequires:  glib2-devel >= 1:2.32.0
33 BuildRequires:  gobject-introspection-devel >= 0.9.5
34 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
35 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
36 BuildRequires:  gtk-doc >= 1.13
37 BuildRequires:  libdrm-devel
38 BuildRequires:  libtool >= 2:2.2.6
39 BuildRequires:  pango-devel >= 1:1.20
40 BuildRequires:  pkgconfig
41 BuildRequires:  tar >= 1:1.22
42 # wayland-client >= 1.0.0, wayland-server >= 1.1.90
43 %{?with_wayland:BuildRequires:  wayland-devel >= 1.2.0}
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXfixes-devel >= 3
49 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
50 BuildRequires:  xz
51 Requires:       cairo >= 1.10
52 Requires:       glib2 >= 1:2.32.0
53 Requires:       pango >= 1:1.20
54 %{?with_wayland:Requires:       wayland >= 1.2.0}
55 Requires:       xorg-lib-libXcomposite >= 0.4
56 Requires:       xorg-lib-libXfixes >= 3
57 Requires:       xorg-lib-libXrandr >= 1.2
58 Suggests:       OpenGL
59 %{?with_gles1:Provides: cogl(gles1) = %{version}-%{release}}
60 %{?with_gles2:Provides: cogl(gles2) = %{version}-%{release}}
61 %{?with_kms:Provides:   cogl(kms) = %{version}-%{release}}
62 %{?with_wayland:Provides:       cogl(wayland) = %{version}-%{release}}
63 Conflicts:      clutter < 1.8.0
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Cogl is a small open source library for using 3D graphics hardware to
68 draw pretty pictures. The API departs from the flat state machine
69 style of OpenGL and is designed to make it easy to write orthogonal
70 components that can render without stepping on each others toes.
71
72 %description -l pl.UTF-8
73 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
74 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
75 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
76 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
77 przeszkadzania sobie nawzajem.
78
79 %package devel
80 Summary:        Header files for cogl library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 %{?with_wayland:Requires:       EGL-devel}
85 %{?with_kms:Requires:   Mesa-libgbm-devel}
86 %{?with_wayland:Requires:       Mesa-libwayland-egl-devel >= 1.0.0}
87 Requires:       cairo-devel >= 1.10
88 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
89 Requires:       glib2-devel >= 1:2.32.0
90 Requires:       gobject-introspection-devel >= 0.9.5
91 Requires:       libdrm-devel
92 Requires:       pango-devel >= 1:1.20
93 %{?with_wayland:Requires:       wayland-devel >= 1.2.0}
94 Requires:       xorg-lib-libXcomposite-devel >= 0.4
95 Requires:       xorg-lib-libXdamage-devel
96 Requires:       xorg-lib-libXext-devel
97 Requires:       xorg-lib-libXfixes-devel >= 3
98 Requires:       xorg-lib-libXrandr-devel >= 1.2
99 %{?with_gles1:Provides: cogl-devel(gles1) = %{version}-%{release}}
100 %{?with_gles2:Provides: cogl-devel(gles2) = %{version}-%{release}}
101 %{?with_kms:Provides:   cogl-devel(kms) = %{version}-%{release}}
102 %{?with_wayland:Provides:       cogl-devel(wayland) = %{version}-%{release}}
103 Conflicts:      clutter-devel < 1.8.0
104
105 %description devel
106 Header files for building and developing applications with cogl.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
110
111 %package static
112 Summary:        Static cogl libraries
113 Summary(pl.UTF-8):      Statyczne biblioteki cogl
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116 %{?with_gles1:Provides: cogl-static(gles1) = %{version}-%{release}}
117 %{?with_gles2:Provides: cogl-static(gles2) = %{version}-%{release}}
118 %{?with_kms:Provides:   cogl-static(kms) = %{version}-%{release}}
119 %{?with_wayland:Provides:       cogl-static(wayland) = %{version}-%{release}}
120 Conflicts:      clutter-static < 1.8.0
121
122 %description static
123 Static cogl libraries.
124
125 %description static -l pl.UTF-8
126 Statyczne biblioteki cogl.
127
128 %package doc
129 Summary:        API documentation for cogl
130 Summary(pl.UTF-8):      Dokumentacja API cogl
131 Group:          Documentation
132
133 %description doc
134 This package contains API documentation for cogl.
135
136 %description doc -l pl.UTF-8
137 Ten pakiet zawiera dokumentację API cogl.
138
139 %package gles2
140 Summary:        Cogl frontend library for OpenGL-ES 2.0
141 Summary(pl.UTF-8):      Biblioteka frontendowa Cogl dla OpenGL-ES 2.0
142 Group:          Libraries
143 Requires:       %{name}(gles2) = %{version}-%{release}
144
145 %description gles2
146 Cogl frontend library for OpenGL-ES 2.0.
147
148 %description gles2 -l pl.UTF-8
149 Biblioteka frontendowa Cogl dla OpenGL-ES 2.0.
150
151 %package gles2-devel
152 Summary:        Header files for cogl-gles2 library
153 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gles2
154 Group:          Development/Libraries
155 Requires:       %{name}-devel(gles2) = %{version}-%{release}
156 Requires:       %{name}-gles2 = %{version}-%{release}
157
158 %description gles2-devel
159 Header files for cogl-gles2 library.
160
161 %description gles2-devel -l pl.UTF-8
162 Pliki nagłówkowe biblioteki cogl-gles2.
163
164 %package gles2-static
165 Summary:        Static cogl-gles2 library
166 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gles2
167 Group:          Development/Libraries
168 Requires:       %{name}-gles2-devel = %{version}-%{release}
169
170 %description gles2-static
171 Static cogl-gles2 library.
172
173 %description gles2-static -l pl.UTF-8
174 Statyczna biblioteka cogl-gles2.
175
176 %package gst
177 Summary:        GStreamer integration library for Cogl
178 Summary(pl.UTF-8):      Biblioteka integrująca GStreamera z Cogl
179 Group:          Libraries
180 Requires:       %{name} = %{version}-%{release}
181
182 %description gst
183 GStreamer integration library for Cogl.
184
185 %description gst -l pl.UTF-8
186 Biblioteka integrująca GStreamera z Cogl.
187
188 %package gst-devel
189 Summary:        Header files for cogl-gst library
190 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gst
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193 Requires:       %{name}-gst = %{version}-%{release}
194 Requires:       gstreamer-devel >= 1.0
195 Requires:       gstreamer-plugins-base-devel >= 1.0
196
197 %description gst-devel
198 Header files for cogl-gst library.
199
200 %description gst-devel -l pl.UTF-8
201 Pliki nagłówkowe biblioteki cogl-gst.
202
203 %package gst-static
204 Summary:        Static cogl-gst library
205 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gst
206 Group:          Development/Libraries
207 Requires:       %{name}-gst-devel = %{version}-%{release}
208
209 %description gst-static
210 Static cogl-gst library.
211
212 %description gst-static -l pl.UTF-8
213 Statyczna biblioteka cogl-gst.
214
215 %package gst-apidocs
216 Summary:        API documentation for cogl-gst library
217 Summary(pl.UTF-8):      Dokumentacja API biblioteki cogl-gst
218 Group:          Documentation
219 %if "%{_rpmversion}" >= "5"
220 BuildArch:      noarch
221 %endif
222
223 %description gst-apidocs
224 API documentation for cogl-gst library.
225
226 %description gst-apidocs -l pl.UTF-8
227 Dokumentacja API biblioteki cogl-gst.
228
229 %prep
230 %setup -q
231 %patch0 -p1
232
233 %build
234 %{__gettextize}
235 %{__libtoolize}
236 %{__aclocal} -I build/autotools
237 %{__autoconf}
238 %{__autoheader}
239 %{__automake}
240 %configure \
241         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
242         --disable-silent-rules \
243         --enable-cairo \
244         %{?with_gstreamer:--enable-cogl-gst} \
245         --enable-cogl-pango \
246         %{?with_gles1:--enable-gles1 --with-gles1-libname=libGLESv1_CM.so.1} \
247         %{?with_gles2:--enable-gles2 --with-gles2-libname=libGLESv2.so.2} \
248         --enable-glx \
249         --enable-gtk-doc \
250         --enable-introspection \
251         --enable-kms-egl-platform \
252         %{?with_static_libs:--enable-static} \
253         %{?with_wayland:--enable-wayland-egl-platform} \
254         %{?with_wayland:--enable-wayland-egl-server} \
255         --enable-xlib-egl-platform \
256         --with-html-dir=%{_gtkdocdir}
257 %{__make}
258
259 %install
260 rm -rf $RPM_BUILD_ROOT
261
262 %{__make} -j1 install \
263         DESTDIR=$RPM_BUILD_ROOT
264
265 %if %{with gstreamer}
266 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.la
267 %if %{with static_libs}
268 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.a
269 %endif
270 %endif
271 # obsoleted by pkg-config
272 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl*.la
273
274 %find_lang %{name}
275
276 %clean
277 rm -rf $RPM_BUILD_ROOT
278
279 %post   -p /sbin/ldconfig
280 %postun -p /sbin/ldconfig
281
282 %post   gles2 -p /sbin/ldconfig
283 %postun gles2 -p /sbin/ldconfig
284
285 %post   gst -p /sbin/ldconfig
286 %postun gst -p /sbin/ldconfig
287
288 %files -f %{name}.lang
289 %defattr(644,root,root,755)
290 %doc ChangeLog NEWS README
291 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
292 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.20
293 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
294 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.20
295 %attr(755,root,root) %{_libdir}/libcogl-path.so.*.*.*
296 %attr(755,root,root) %ghost %{_libdir}/libcogl-path.so.20
297 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
298 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
299 %{_libdir}/girepository-1.0/Cogl-2.0.typelib
300 %{_libdir}/girepository-1.0/CoglPango-2.0.typelib
301
302 %files devel
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/libcogl.so
305 %attr(755,root,root) %{_libdir}/libcogl-pango.so
306 %attr(755,root,root) %{_libdir}/libcogl-path.so
307 %dir %{_includedir}/cogl
308 %{_includedir}/cogl/cogl
309 %{_includedir}/cogl/cogl-pango
310 %{_includedir}/cogl/cogl-path
311 %{_pkgconfigdir}/cogl-1.0.pc
312 %{_pkgconfigdir}/cogl-2.0-experimental.pc
313 %{_pkgconfigdir}/cogl-gl-1.0.pc
314 %{_pkgconfigdir}/cogl-pango-1.0.pc
315 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
316 %{_pkgconfigdir}/cogl-path-1.0.pc
317 %{_pkgconfigdir}/cogl-path-2.0-experimental.pc
318 %{_datadir}/gir-1.0/Cogl-1.0.gir
319 %{_datadir}/gir-1.0/CoglPango-1.0.gir
320 %{_datadir}/gir-1.0/Cogl-2.0.gir
321 %{_datadir}/gir-1.0/CoglPango-2.0.gir
322
323 %if %{with static_libs}
324 %files static
325 %defattr(644,root,root,755)
326 %{_libdir}/libcogl.a
327 %{_libdir}/libcogl-pango.a
328 %{_libdir}/libcogl-path.a
329 %endif
330
331 %files doc
332 %defattr(644,root,root,755)
333 %{_gtkdocdir}/cogl
334 %{_gtkdocdir}/cogl-2.0-experimental
335
336 %if %{with gles2}
337 %files gles2
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/libcogl-gles2.so.*.*.*
340 %attr(755,root,root) %ghost %{_libdir}/libcogl-gles2.so.20
341
342 %files gles2-devel
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/libcogl-gles2.so
345 %{_includedir}/cogl/cogl-gles2
346 %{_pkgconfigdir}/cogl-gles2-1.0.pc
347 %{_pkgconfigdir}/cogl-gles2-2.0-experimental.pc
348
349 %if %{with static_libs}
350 %files gles2-static
351 %defattr(644,root,root,755)
352 %{_libdir}/libcogl-gles2.a
353 %endif
354 %endif
355
356 %if %{with gstreamer}
357 %files gst
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/libcogl-gst.so.*.*.*
360 %attr(755,root,root) %ghost %{_libdir}/libcogl-gst.so.20
361 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstcogl.so
362 %{_libdir}/girepository-1.0/CoglGst-2.0.typelib
363
364 %files gst-devel
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_libdir}/libcogl-gst.so
367 %{_includedir}/cogl/cogl-gst
368 %{_pkgconfigdir}/cogl-gst-1.0.pc
369 %{_pkgconfigdir}/cogl-gst-2.0-experimental.pc
370 %{_datadir}/gir-1.0/CoglGst-2.0.gir
371
372 %if %{with static_libs}
373 %files gst-static
374 %defattr(644,root,root,755)
375 %{_libdir}/libcogl-gst.a
376 %endif
377
378 %files gst-apidocs
379 %defattr(644,root,root,755)
380 %{_gtkdocdir}/cogl-gst
381 %endif
This page took 0.083231 seconds and 3 git commands to generate.