]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
Fixes docs build
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        A library for using 3D graphics hardware to draw pretty pictures
6 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
7 Name:           cogl
8 Version:        1.11.2
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.11/%{name}-%{version}.tar.xz
13 # Source0-md5:  dc325e01a47297a7087436b0af770414
14 URL:            http://www.clutter-project.org/
15 BuildRequires:  OpenGL-GLX-devel
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  cairo-devel >= 1.10
19 BuildRequires:  gdk-pixbuf2-devel
20 BuildRequires:  gettext-devel >= 0.18.1
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.5
23 BuildRequires:  gtk-doc >= 1.13
24 BuildRequires:  libdrm-devel
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  pango-devel >= 1:1.20
27 BuildRequires:  pkgconfig
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
31 BuildRequires:  xorg-lib-libXdamage-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXfixes-devel >= 3
34 BuildRequires:  xz
35 Requires:       cairo >= 1.10
36 Requires:       glib2 >= 1:2.28.0
37 Requires:       pango >= 1:1.20
38 Requires:       xorg-lib-libXcomposite >= 0.4
39 Requires:       xorg-lib-libXfixes >= 3
40 Suggests:       OpenGL
41 Conflicts:      clutter < 1.8.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Cogl is a small open source library for using 3D graphics hardware to
46 draw pretty pictures. The API departs from the flat state machine
47 style of OpenGL and is designed to make it easy to write orthogonal
48 components that can render without stepping on each others toes.
49
50 %description -l pl.UTF-8
51 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
52 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
53 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
54 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
55 przeszkadzania sobie nawzajem.
56
57 %package devel
58 Summary:        Header files for cogl library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       cairo-devel >= 1.10
63 Requires:       glib2-devel >= 1:2.28.0
64 Requires:       gobject-introspection-devel >= 0.9.5
65 Requires:       libdrm-devel
66 Requires:       pango-devel >= 1:1.20
67 Requires:       xorg-lib-libXcomposite-devel >= 0.4
68 Requires:       xorg-lib-libXdamage-devel
69 Requires:       xorg-lib-libXext-devel
70 Requires:       xorg-lib-libXfixes-devel >= 3
71 Conflicts:      clutter-devel < 1.8.0
72
73 %description devel
74 Header files for building and developing applications with cogl.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
78
79 %package static
80 Summary:        Static cogl libraries
81 Summary(pl.UTF-8):      Statyczne biblioteki cogl
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Conflicts:      clutter-static < 1.8.0
85
86 %description static
87 Static cogl libraries.
88
89 %description static -l pl.UTF-8
90 Statyczne biblioteki cogl.
91
92 %package doc
93 Summary:        API documentation for cogl
94 Summary(pl.UTF-8):      Dokumentacja API cogl
95 Group:          Documentation
96
97 %description doc
98 This package contains API documentation for cogl.
99
100 %description doc -l pl.UTF-8
101 Ten pakiet zawiera dokumentację API cogl.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__gettextize}
108 %{__libtoolize}
109 %{__aclocal} -I build/autotools
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-gdk-pixbuf \
115         --disable-silent-rules \
116         --enable-cairo \
117         --enable-cogl-pango \
118         --enable-glx \
119         --enable-gtk-doc \
120         --enable-introspection \
121         %{?with_static_libs:--enable-static} \
122         --with-html-dir=%{_gtkdocdir}
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl.la
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.la
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc ChangeLog NEWS README
146 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.11
148 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.0
150 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
151 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libcogl.so
156 %attr(755,root,root) %{_libdir}/libcogl-pango.so
157 %{_includedir}/cogl
158 %{_includedir}/cogl2
159 %{_pkgconfigdir}/cogl-1.0.pc
160 %{_pkgconfigdir}/cogl-2.0-experimental.pc
161 %{_pkgconfigdir}/cogl-gl-1.0.pc
162 %{_pkgconfigdir}/cogl-pango-1.0.pc
163 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
164 %{_datadir}/gir-1.0/Cogl-1.0.gir
165 %{_datadir}/gir-1.0/CoglPango-1.0.gir
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libcogl.a
171 %{_libdir}/libcogl-pango.a
172 %endif
173
174 %files doc
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/cogl
177 %{_gtkdocdir}/cogl-2.0-experimental
This page took 0.076667 seconds and 3 git commands to generate.