]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
- install is racy, use -j1
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 %bcond_without  gles1           # OpenGL-ES 1.1 support
6 %bcond_without  gles2           # OpenGL-ES 2.0 support
7 %bcond_without  kms             # KMS EGL support
8 %bcond_without  gstreamer       # GStreamer support
9 %bcond_without  wayland         # Wayland EGL support
10 #
11 Summary:        A library for using 3D graphics hardware to draw pretty pictures
12 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
13 Name:           cogl
14 Version:        1.16.2
15 Release:        1
16 License:        LGPL v2+
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.16/%{name}-%{version}.tar.xz
19 # Source0-md5:  aaf32bde135cf3815aa3221726bad71e
20 Patch0:         %{name}-link.patch
21 URL:            http://www.clutter-project.org/
22 %{?with_wayland:BuildRequires:  EGL-devel}
23 %{?with_kms:BuildRequires:      Mesa-libgbm-devel}
24 %{?with_wayland:BuildRequires:  Mesa-libwayland-egl-devel >= 1.0.0}
25 %{?with_gles1:BuildRequires:    OpenGLESv1-devel >= 1.1}
26 BuildRequires:  OpenGL-GLX-devel
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.11
29 BuildRequires:  cairo-devel >= 1.10
30 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
31 BuildRequires:  gettext-devel >= 0.18.1
32 BuildRequires:  glib2-devel >= 1:2.32.0
33 BuildRequires:  gobject-introspection-devel >= 0.9.5
34 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
35 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
36 BuildRequires:  gtk-doc >= 1.13
37 BuildRequires:  libdrm-devel
38 BuildRequires:  libtool >= 2:2.2.6
39 BuildRequires:  pango-devel >= 1:1.20
40 BuildRequires:  pkgconfig
41 BuildRequires:  tar >= 1:1.22
42 # wayland-client >= 1.0.0, wayland-server >= 1.1.90
43 %{?with_wayland:BuildRequires:  wayland-devel >= 1.2.0}
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
46 BuildRequires:  xorg-lib-libXdamage-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXfixes-devel >= 3
49 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
50 BuildRequires:  xz
51 Requires:       cairo >= 1.10
52 Requires:       glib2 >= 1:2.32.0
53 Requires:       pango >= 1:1.20
54 %{?with_wayland:Requires:       wayland >= 1.2.0}
55 Requires:       xorg-lib-libXcomposite >= 0.4
56 Requires:       xorg-lib-libXfixes >= 3
57 Requires:       xorg-lib-libXrandr >= 1.2
58 Suggests:       OpenGL
59 %{?with_gles1:Provides: cogl(gles1) = %{version}-%{release}}
60 %{?with_gles2:Provides: cogl(gles2) = %{version}-%{release}}
61 %{?with_kms:Provides:   cogl(kms) = %{version}-%{release}}
62 %{?with_wayland:Provides:       cogl(wayland) = %{version}-%{release}}
63 Conflicts:      clutter < 1.8.0
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Cogl is a small open source library for using 3D graphics hardware to
68 draw pretty pictures. The API departs from the flat state machine
69 style of OpenGL and is designed to make it easy to write orthogonal
70 components that can render without stepping on each others toes.
71
72 %description -l pl.UTF-8
73 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
74 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
75 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
76 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
77 przeszkadzania sobie nawzajem.
78
79 %package devel
80 Summary:        Header files for cogl library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 %{?with_wayland:Requires:       EGL-devel}
85 %{?with_kms:Requires:   Mesa-libgbm-devel}
86 %{?with_wayland:Requires:       Mesa-libwayland-egl-devel >= 1.0.0}
87 Requires:       cairo-devel >= 1.10
88 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
89 Requires:       glib2-devel >= 1:2.32.0
90 Requires:       gobject-introspection-devel >= 0.9.5
91 Requires:       libdrm-devel
92 Requires:       pango-devel >= 1:1.20
93 %{?with_wayland:Requires:       wayland-devel >= 1.2.0}
94 Requires:       xorg-lib-libXcomposite-devel >= 0.4
95 Requires:       xorg-lib-libXdamage-devel
96 Requires:       xorg-lib-libXext-devel
97 Requires:       xorg-lib-libXfixes-devel >= 3
98 Requires:       xorg-lib-libXrandr-devel >= 1.2
99 %{?with_gles1:Provides: cogl-devel(gles1) = %{version}-%{release}}
100 %{?with_gles2:Provides: cogl-devel(gles2) = %{version}-%{release}}
101 %{?with_kms:Provides:   cogl-devel(kms) = %{version}-%{release}}
102 %{?with_wayland:Provides:       cogl-devel(wayland) = %{version}-%{release}}
103 Conflicts:      clutter-devel < 1.8.0
104
105 %description devel
106 Header files for building and developing applications with cogl.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
110
111 %package static
112 Summary:        Static cogl libraries
113 Summary(pl.UTF-8):      Statyczne biblioteki cogl
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116 %{?with_gles1:Provides: cogl-static(gles1) = %{version}-%{release}}
117 %{?with_gles2:Provides: cogl-static(gles2) = %{version}-%{release}}
118 %{?with_kms:Provides:   cogl-static(kms) = %{version}-%{release}}
119 %{?with_wayland:Provides:       cogl-static(wayland) = %{version}-%{release}}
120 Conflicts:      clutter-static < 1.8.0
121
122 %description static
123 Static cogl libraries.
124
125 %description static -l pl.UTF-8
126 Statyczne biblioteki cogl.
127
128 %package doc
129 Summary:        API documentation for cogl
130 Summary(pl.UTF-8):      Dokumentacja API cogl
131 Group:          Documentation
132
133 %description doc
134 This package contains API documentation for cogl.
135
136 %description doc -l pl.UTF-8
137 Ten pakiet zawiera dokumentację API cogl.
138
139 %package gles2
140 Summary:        Cogl frontend library for OpenGL-ES 2.0
141 Summary(pl.UTF-8):      Biblioteka frontendowa Cogl dla OpenGL-ES 2.0
142 Group:          Libraries
143 Requires:       %{name}(gles2) = %{version}-%{release}
144
145 %description gles2
146 Cogl frontend library for OpenGL-ES 2.0.
147
148 %description gles2 -l pl.UTF-8
149 Biblioteka frontendowa Cogl dla OpenGL-ES 2.0.
150
151 %package gles2-devel
152 Summary:        Header files for cogl-gles2 library
153 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gles2
154 Group:          Development/Libraries
155 Requires:       %{name}-devel(gles2) = %{version}-%{release}
156 Requires:       %{name}-gles2 = %{version}-%{release}
157
158 %description gles2-devel
159 Header files for cogl-gles2 library.
160
161 %description gles2-devel -l pl.UTF-8
162 Pliki nagłówkowe biblioteki cogl-gles2.
163
164 %package gles2-static
165 Summary:        Static cogl-gles2 library
166 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gles2
167 Group:          Development/Libraries
168 Requires:       %{name}-gles2-devel = %{version}-%{release}
169
170 %description gles2-static
171 Static cogl-gles2 library.
172
173 %description gles2-static -l pl.UTF-8
174 Statyczna biblioteka cogl-gles2.
175
176 %package gst
177 Summary:        GStreamer integration library for Cogl
178 Summary(pl.UTF-8):      Biblioteka integrująca GStreamera z Cogl
179 Group:          Libraries
180 Requires:       %{name} = %{version}-%{release}
181
182 %description gst
183 GStreamer integration library for Cogl.
184
185 %description gst -l pl.UTF-8
186 Biblioteka integrująca GStreamera z Cogl.
187
188 %package gst-devel
189 Summary:        Header files for cogl-gst library
190 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gst
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193 Requires:       %{name}-gst = %{version}-%{release}
194 Requires:       gstreamer-devel >= 1.0
195 Requires:       gstreamer-plugins-base-devel >= 1.0
196
197 %description gst-devel
198 Header files for cogl-gst library.
199
200 %description gst-devel -l pl.UTF-8
201 Pliki nagłówkowe biblioteki cogl-gst.
202
203 %package gst-static
204 Summary:        Static cogl-gst library
205 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gst
206 Group:          Development/Libraries
207 Requires:       %{name}-gst-devel = %{version}-%{release}
208
209 %description gst-static
210 Static cogl-gst library.
211
212 %description gst-static -l pl.UTF-8
213 Statyczna biblioteka cogl-gst.
214
215 %package gst-apidocs
216 Summary:        API documentation for cogl-gst library
217 Summary(pl.UTF-8):      Dokumentacja API biblioteki cogl-gst
218 Group:          Documentation
219
220 %description gst-apidocs
221 API documentation for cogl-gst library.
222
223 %description gst-apidocs -l pl.UTF-8
224 Dokumentacja API biblioteki cogl-gst.
225
226 %prep
227 %setup -q
228 %patch0 -p1
229
230 %build
231 %{__gettextize}
232 %{__libtoolize}
233 %{__aclocal} -I build/autotools
234 %{__autoconf}
235 %{__autoheader}
236 %{__automake}
237 %configure \
238         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
239         --disable-silent-rules \
240         --enable-cairo \
241         %{?with_gstreamer:--enable-cogl-gst} \
242         --enable-cogl-pango \
243         %{?with_gles1:--enable-gles1 --with-gles1-libname=libGLESv1_CM.so.1} \
244         %{?with_gles2:--enable-gles2 --with-gles2-libname=libGLESv2.so.2} \
245         --enable-glx \
246         --enable-gtk-doc \
247         --enable-introspection \
248         --enable-kms-egl-platform \
249         %{?with_static_libs:--enable-static} \
250         %{?with_wayland:--enable-wayland-egl-platform} \
251         %{?with_wayland:--enable-wayland-egl-server} \
252         --enable-xlib-egl-platform \
253         --with-html-dir=%{_gtkdocdir}
254 %{__make}
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258
259 %{__make} -j1 install \
260         DESTDIR=$RPM_BUILD_ROOT
261
262 %if %{with gstreamer}
263 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.la
264 %if %{with static_libs}
265 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.a
266 %endif
267 %endif
268 # obsoleted by pkg-config
269 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl*.la
270
271 %find_lang %{name}
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %post   -p /sbin/ldconfig
277 %postun -p /sbin/ldconfig
278
279 %post   gles2 -p /sbin/ldconfig
280 %postun gles2 -p /sbin/ldconfig
281
282 %post   gst -p /sbin/ldconfig
283 %postun gst -p /sbin/ldconfig
284
285 %files -f %{name}.lang
286 %defattr(644,root,root,755)
287 %doc ChangeLog NEWS README
288 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
289 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.15
290 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
291 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.15
292 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
293 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
294
295 %files devel
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/libcogl.so
298 %attr(755,root,root) %{_libdir}/libcogl-pango.so
299 %dir %{_includedir}/cogl
300 %{_includedir}/cogl/cogl
301 %{_includedir}/cogl/cogl-pango
302 %{_includedir}/cogl/cogl-path
303 %{_pkgconfigdir}/cogl-1.0.pc
304 %{_pkgconfigdir}/cogl-2.0-experimental.pc
305 %{_pkgconfigdir}/cogl-gl-1.0.pc
306 %{_pkgconfigdir}/cogl-pango-1.0.pc
307 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
308 %{_datadir}/gir-1.0/Cogl-1.0.gir
309 %{_datadir}/gir-1.0/CoglPango-1.0.gir
310
311 %if %{with static_libs}
312 %files static
313 %defattr(644,root,root,755)
314 %{_libdir}/libcogl.a
315 %{_libdir}/libcogl-pango.a
316 %endif
317
318 %files doc
319 %defattr(644,root,root,755)
320 %{_gtkdocdir}/cogl
321 %{_gtkdocdir}/cogl-2.0-experimental
322
323 %if %{with gles2}
324 %files gles2
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/libcogl-gles2.so.*.*.*
327 %attr(755,root,root) %ghost %{_libdir}/libcogl-gles2.so.15
328
329 %files gles2-devel
330 %defattr(644,root,root,755)
331 %attr(755,root,root) %{_libdir}/libcogl-gles2.so
332 %{_includedir}/cogl/cogl-gles2
333 %{_pkgconfigdir}/cogl-gles2-experimental.pc
334
335 %if %{with static_libs}
336 %files gles2-static
337 %defattr(644,root,root,755)
338 %{_libdir}/libcogl-gles2.a
339 %endif
340 %endif
341
342 %if %{with gstreamer}
343 %files gst
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/libcogl-gst.so.*.*.*
346 %attr(755,root,root) %ghost %{_libdir}/libcogl-gst.so.15
347 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstcogl.so
348
349 %files gst-devel
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/libcogl-gst.so
352 %{_includedir}/cogl/cogl-gst
353 %{_pkgconfigdir}/cogl-gst.pc
354
355 %if %{with static_libs}
356 %files gst-static
357 %defattr(644,root,root,755)
358 %{_libdir}/libcogl-gst.a
359 %endif
360
361 %files gst-apidocs
362 %defattr(644,root,root,755)
363 %{_gtkdocdir}/cogl-gst
364 %endif
This page took 0.289616 seconds and 3 git commands to generate.