]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- updated to 3.0.2
[packages/cmake.git] / cmake.spec
index 9a6121f43caaf4a71d3471e4d0c05ae6b1b751d7..273392e38438ba9d253504ea489d452db4f523c7 100644 (file)
@@ -7,18 +7,23 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
+%bcond_without tests           # do not perform "make test"
 
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.10.1
+Version:       3.0.2
 Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: aabf16d8e957f99921a0095885381373
+Source0:       http://www.cmake.org/files/v3.0/%{name}-%{version}.tar.gz
+# Source0-md5: db4c687a31444a929d2fdc36c4dfb95f
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
+Patch2:                %{name}-findruby.patch
+Patch3:                %{name}-tests.patch
+Patch5:                %{name}-findruby2.patch
+Patch6:                %{name}-findpython.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -27,6 +32,7 @@ BuildRequires:        ncurses-devel > 5.9-3
 %{?with_gui:BuildRequires:     qt4-build}
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
+BuildRequires: sphinx-pdg
 %{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
 Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -49,6 +55,17 @@ dość wyrafinowany: może obsłużyć złożone środowiska wymagające
 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
 dziedziczenie szablonów.
 
+%package doc-html
+Summary:       CMake documentation in HTML format
+Summary(pl.UTF-8):     Dokumentacja do pakietu CMake w formacie HTML
+Group:         Documentation
+
+%description doc-html
+CMake documentation in HTML format.
+
+%description doc-html -l pl.UTF-8
+Dokumentacja do pakietu CMake w formacie HTML.
+
 %package gui
 Summary:       Qt GUI for CMake
 Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
@@ -78,6 +95,10 @@ Summary:     bash-completion for cmake
 Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion >= 2.0
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-%{name}
 bash-completion for cmake.
@@ -91,6 +112,10 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch0 -p1
 %endif
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch5 -p1
+%patch6 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -98,6 +123,9 @@ SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
 SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
 EOF
 
+# cleanup backups after patching, modules are copied as-is
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
 %build
 export CC="%{__cc}"
 export CXX="%{__cxx}"
@@ -112,13 +140,16 @@ export LDFLAGS="%{rpmldflags}"
        %{!?with_bootstrap:--system-libs} \
        %{?with_gui:--qt-gui} \
        --qt-qmake=/usr/bin/qmake-qt4 \
+       --sphinx-html \
+       --sphinx-man \
        --verbose
 
 %{__make} VERBOSE=1
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -129,21 +160,28 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
+%doc Copyright.txt README.rst *.gif
 %attr(755,root,root) %{_bindir}/ccmake
 %attr(755,root,root) %{_bindir}/cmake
 %attr(755,root,root) %{_bindir}/cpack
 %attr(755,root,root) %{_bindir}/ctest
 %{_mandir}/man1/ccmake.1*
 %{_mandir}/man1/cmake.1*
-%{_mandir}/man1/cmakecommands.1*
-%{_mandir}/man1/cmakecompat.1*
-%{_mandir}/man1/cmakemodules.1*
-%{_mandir}/man1/cmakepolicies.1*
-%{_mandir}/man1/cmakeprops.1*
-%{_mandir}/man1/cmakevars.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
+%{_mandir}/man7/cmake-buildsystem.7*
+%{_mandir}/man7/cmake-commands.7*
+%{_mandir}/man7/cmake-developer.7*
+%{_mandir}/man7/cmake-generator-expressions.7*
+%{_mandir}/man7/cmake-generators.7*
+%{_mandir}/man7/cmake-language.7*
+%{_mandir}/man7/cmake-modules.7*
+%{_mandir}/man7/cmake-packages.7*
+%{_mandir}/man7/cmake-policies.7*
+%{_mandir}/man7/cmake-properties.7*
+%{_mandir}/man7/cmake-qt.7*
+%{_mandir}/man7/cmake-toolchains.7*
+%{_mandir}/man7/cmake-variables.7*
 # top cmake/Modules dirs belong to filesystem
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
@@ -152,10 +190,15 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/include
 %{_aclocaldir}/cmake.m4
 
+%files doc-html
+%defattr(644,root,root,755)
+%doc Utilities/Sphinx/html/*
+
 %if %{with gui}
 %files gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cmake-gui
+%{_datadir}/cmake/Help
 %{_datadir}/mime/packages/cmakecache.xml
 %{_desktopdir}/CMake.desktop
 %{_pixmapsdir}/CMakeSetup32.png
@@ -168,6 +211,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-%{name}
 %defattr(644,root,root,755)
-/etc/bash_completion.d/cmake
-/etc/bash_completion.d/cpack
-/etc/bash_completion.d/ctest
+%{_datadir}/bash-completion/completions/cmake
+%{_datadir}/bash-completion/completions/cpack
+%{_datadir}/bash-completion/completions/ctest
This page took 0.112276 seconds and 4 git commands to generate.