]> git.pld-linux.org Git - packages/cmake.git/commitdiff
- updated to 3.0.2 auto/th/cmake-3.0.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Oct 2014 18:14:50 +0000 (20:14 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Oct 2014 18:14:50 +0000 (20:14 +0200)
- updated helpers,findpython patches
- removed obsolete freetype2 patch

cmake-findpython.patch
cmake-freetype2.patch [deleted file]
cmake-helpers.patch
cmake.spec

index 92be82a44fcadd231210ee3f2d919a0944efa93a..f0b929ae123f27e1fe01793f063b747224a710f9 100644 (file)
@@ -1,10 +1,10 @@
---- cmake-2.8.12.2/Modules/FindPythonLibs.cmake~       2014-01-16 18:15:08.000000000 +0100
-+++ cmake-2.8.12.2/Modules/FindPythonLibs.cmake        2014-10-21 11:59:07.048973118 +0200
+--- cmake-3.0.2/Modules/FindPythonLibs.cmake~  2014-01-16 18:15:08.000000000 +0100
++++ cmake-3.0.2/Modules/FindPythonLibs.cmake   2014-10-21 11:59:07.048973118 +0200
 @@ -38,7 +38,7 @@
  
  set(_PYTHON1_VERSIONS 1.6 1.5)
  set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
--set(_PYTHON3_VERSIONS 3.3 3.2 3.1 3.0)
+-set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
 +set(_PYTHON3_VERSIONS 3.5 3.4 3.3 3.2 3.1 3.0)
  
  if(PythonLibs_FIND_VERSION)
diff --git a/cmake-freetype2.patch b/cmake-freetype2.patch
deleted file mode 100644 (file)
index af96e33..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- cmake-2.8.12.1/Modules/FindFreetype.cmake.orig     2013-11-05 20:07:22.000000000 +0100
-+++ cmake-2.8.12.1/Modules/FindFreetype.cmake  2013-12-06 19:50:19.371935997 +0100
-@@ -56,7 +56,7 @@
-   PATH_SUFFIXES include/freetype2 include
- )
--find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
-+find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
-   HINTS
-     ENV FREETYPE_DIR
-   PATHS
-@@ -67,7 +67,7 @@
-     ENV GTKMM_BASEPATH
-     [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
-     [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
--  PATH_SUFFIXES include/freetype2 include
-+  PATH_SUFFIXES include/freetype2/freetype include/freetype2 include
- )
- find_library(FREETYPE_LIBRARY
-@@ -87,12 +87,12 @@
- # set the user variables
- if(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)
--  set(FREETYPE_INCLUDE_DIRS "${FREETYPE_INCLUDE_DIR_ft2build};${FREETYPE_INCLUDE_DIR_freetype2}")
-+  set(FREETYPE_INCLUDE_DIRS "${FREETYPE_INCLUDE_DIR_ft2build}")
- endif()
- set(FREETYPE_LIBRARIES "${FREETYPE_LIBRARY}")
--if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h")
--    file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h" freetype_version_str
-+if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h")
-+    file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h" freetype_version_str
-          REGEX "^#[\t ]*define[\t ]+FREETYPE_(MAJOR|MINOR|PATCH)[\t ]+[0-9]+$")
-     unset(FREETYPE_VERSION_STRING)
index dd7b5caa4d09c0125ca572a4594b3213dd83205e..6284b808f8e81404c9d1729e95fd80eb5fdd4730 100644 (file)
@@ -1,13 +1,13 @@
---- cmake-2.8.12/Docs/bash-completion/CMakeLists.txt.orig      2013-10-07 17:31:00.000000000 +0200
-+++ cmake-2.8.12/Docs/bash-completion/CMakeLists.txt   2013-10-20 17:12:23.756481217 +0200
+--- cmake-3.0.2/Auxiliary/bash-completion/CMakeLists.txt.orig  2013-10-07 17:31:00.000000000 +0200
++++ cmake-3.0.2/Auxiliary/bash-completion/CMakeLists.txt       2013-10-20 17:12:23.756481217 +0200
 @@ -5,4 +5,4 @@
  # add symlinks to the files in appropriate places
  #  /etc/bash_completion.d/
  #  DATADIR/completions (may be /usr/share/<package>/completions
 -install(FILES cmake cpack ctest DESTINATION ${CMAKE_DATA_DIR}/completions)
 +install(FILES cmake cpack ctest DESTINATION ${CMAKE_INSTALL_DATADIR}/bash-completion/completions)
---- cmake-2.8.12/Docs/CMakeLists.txt.orig      2013-10-20 17:07:32.733160096 +0200
-+++ cmake-2.8.12/Docs/CMakeLists.txt   2013-10-20 17:13:38.969811394 +0200
+--- cmake-3.0.2/Auxiliary/CMakeLists.txt.orig  2013-10-20 17:07:32.733160096 +0200
++++ cmake-3.0.2/Auxiliary/CMakeLists.txt       2013-10-20 17:13:38.969811394 +0200
 @@ -1,3 +1,3 @@
  install(FILES cmake-help.vim cmake-indent.vim cmake-syntax.vim DESTINATION ${CMAKE_DATA_DIR}/editors/vim)
 -install(FILES cmake-mode.el DESTINATION ${CMAKE_DATA_DIR}/editors/emacs)
index 3631f581a9bd54b43c1628b8c141835866027d69..273392e38438ba9d253504ea489d452db4f523c7 100644 (file)
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.12.2
-Release:       3
+Version:       3.0.2
+Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: 17c6513483d23590cbce6957ec6d1e66
+Source0:       http://www.cmake.org/files/v3.0/%{name}-%{version}.tar.gz
+# Source0-md5: db4c687a31444a929d2fdc36c4dfb95f
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
 Patch2:                %{name}-findruby.patch
 Patch3:                %{name}-tests.patch
-Patch4:                %{name}-freetype2.patch
 Patch5:                %{name}-findruby2.patch
 Patch6:                %{name}-findpython.patch
 URL:           http://www.cmake.org/
@@ -33,6 +32,7 @@ BuildRequires:        ncurses-devel > 5.9-3
 %{?with_gui:BuildRequires:     qt4-build}
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
+BuildRequires: sphinx-pdg
 %{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
 Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -55,6 +55,17 @@ dość wyrafinowany: może obsłużyć złożone środowiska wymagające
 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
 dziedziczenie szablonów.
 
+%package doc-html
+Summary:       CMake documentation in HTML format
+Summary(pl.UTF-8):     Dokumentacja do pakietu CMake w formacie HTML
+Group:         Documentation
+
+%description doc-html
+CMake documentation in HTML format.
+
+%description doc-html -l pl.UTF-8
+Dokumentacja do pakietu CMake w formacie HTML.
+
 %package gui
 Summary:       Qt GUI for CMake
 Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
@@ -103,7 +114,6 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 
@@ -130,6 +140,8 @@ export LDFLAGS="%{rpmldflags}"
        %{!?with_bootstrap:--system-libs} \
        %{?with_gui:--qt-gui} \
        --qt-qmake=/usr/bin/qmake-qt4 \
+       --sphinx-html \
+       --sphinx-man \
        --verbose
 
 %{__make} VERBOSE=1
@@ -148,21 +160,28 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
+%doc Copyright.txt README.rst *.gif
 %attr(755,root,root) %{_bindir}/ccmake
 %attr(755,root,root) %{_bindir}/cmake
 %attr(755,root,root) %{_bindir}/cpack
 %attr(755,root,root) %{_bindir}/ctest
 %{_mandir}/man1/ccmake.1*
 %{_mandir}/man1/cmake.1*
-%{_mandir}/man1/cmakecommands.1*
-%{_mandir}/man1/cmakecompat.1*
-%{_mandir}/man1/cmakemodules.1*
-%{_mandir}/man1/cmakepolicies.1*
-%{_mandir}/man1/cmakeprops.1*
-%{_mandir}/man1/cmakevars.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
+%{_mandir}/man7/cmake-buildsystem.7*
+%{_mandir}/man7/cmake-commands.7*
+%{_mandir}/man7/cmake-developer.7*
+%{_mandir}/man7/cmake-generator-expressions.7*
+%{_mandir}/man7/cmake-generators.7*
+%{_mandir}/man7/cmake-language.7*
+%{_mandir}/man7/cmake-modules.7*
+%{_mandir}/man7/cmake-packages.7*
+%{_mandir}/man7/cmake-policies.7*
+%{_mandir}/man7/cmake-properties.7*
+%{_mandir}/man7/cmake-qt.7*
+%{_mandir}/man7/cmake-toolchains.7*
+%{_mandir}/man7/cmake-variables.7*
 # top cmake/Modules dirs belong to filesystem
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
@@ -171,10 +190,15 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/include
 %{_aclocaldir}/cmake.m4
 
+%files doc-html
+%defattr(644,root,root,755)
+%doc Utilities/Sphinx/html/*
+
 %if %{with gui}
 %files gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cmake-gui
+%{_datadir}/cmake/Help
 %{_datadir}/mime/packages/cmakecache.xml
 %{_desktopdir}/CMake.desktop
 %{_pixmapsdir}/CMakeSetup32.png
This page took 0.084824 seconds and 4 git commands to generate.