]> git.pld-linux.org Git - packages/cmake.git/blob - cmake.spec
- even more :/
[packages/cmake.git] / cmake.spec
1 # TODO:
2 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3 #   (and default non-verbose makefiles are hiding it!)
4 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5 #   (is there any standard way???)
6 #
7 # Conditional build:
8 %bcond_with     bootstrap # use internal versions of some libraries
9 #
10 Summary:        Cross-platform, open-source make system
11 Summary(pl.UTF-8):      Wieloplatformowy system make o otwartych źródłach
12 Name:           cmake
13 Version:        2.6.0
14 Release:        0.1
15 License:        BSD
16 Group:          Development/Building
17 Source0:        http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
18 # Source0-md5:  e95ae003672dfc6c8151a1ee49a0d4a6
19 Patch1:         %{name}-lib64.patch
20 URL:            http://www.cmake.org/HTML/Index.html
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  ncurses-devel
23 BuildRequires:  rpmbuild(macros) >= 1.167
24 %{!?with_bootstrap:BuildRequires:       xmlrpc-c-devel}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 CMake is used to control the software compilation process using simple
29 platform and compiler independent configuration files. CMake generates
30 native makefiles and workspaces that can be used in the compiler
31 environment of your choice. CMake is quite sophisticated: it is
32 possible to support complex environments requiring system
33 configuration, pre-processor generation, code generation, and template
34 instantiation.
35
36 %description -l pl.UTF-8
37 CMake służy do sterowania procesem kompilacji oprogramowania przy
38 użyciu prostych plików konfiguracyjnych niezależnych od platformy i
39 kompilatora. CMake generuje natywne pliki makefile i workspace,
40 których można używać w wybranym środowisku kompilatora. CMake jest
41 dość przemyślany: może obsłużyć złożone środowiska wymagające
42 konfiguracji systemu, generowanie preprocesora, generowanie kodu i
43 dziedziczenie szablonów.
44
45 %prep
46 %setup -q
47 %if "%{_lib}" == "lib64"
48 %patch1 -p1
49 %endif
50
51 cat > "init.cmake" <<EOF
52 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
53 SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
54 EOF
55
56 %build
57 export CC="%{__cc}"
58 export CXX="%{__cxx}"
59 export CFLAGS="%{rpmcflags}"
60 export CXXFLAGS="%{rpmcxxflags}"
61 export LDFLAGS="%{rpmldflags}"
62 ./bootstrap \
63         --prefix=%{_prefix} \
64         --mandir=/share/man \
65         --datadir=/share/cmake \
66         --init=init.cmake \
67         %{!?with_bootstrap:--system-libs} \
68         --verbose
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
86 %attr(755,root,root) %{_bindir}/ccmake
87 %attr(755,root,root) %{_bindir}/cmake
88 %attr(755,root,root) %{_bindir}/cpack
89 %attr(755,root,root) %{_bindir}/ctest
90 %{_mandir}/man1/*.1*
91 %{_datadir}/cmake
This page took 0.029297 seconds and 4 git commands to generate.