]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- added some bconds; handle tslib (doesn't build) and evdev (builds) input support...
[packages/clutter.git] / clutter.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL framebuffer backend
4 %bcond_without  wayland # Wayland backend
5 %bcond_with     evdev   # evdev support for input events
6 %bcond_with     tslib   # TSLib support for input events (outdated?)
7 #
8 Summary:        Library for rich GUIs
9 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
10 Name:           clutter
11 Version:        1.16.0
12 Release:        1
13 License:        LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/clutter/1.16/%{name}-%{version}.tar.xz
16 # Source0-md5:  873c97b825c366e13e1f281e8e1f549b
17 Patch0:         gtkdoc.patch
18 Patch1:         missing.patch
19 URL:            http://www.clutter-project.org/
20 BuildRequires:  OpenGL-GLX-devel
21 BuildRequires:  atk-devel >= 1:2.5.3
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  cairo-devel >= 1.10
25 BuildRequires:  cairo-gobject-devel >= 1.10
26 BuildRequires:  cogl-devel >= 1.15.9
27 %{?with_wayland:BuildRequires:  cogl-devel(wayland) >= 1.15.9}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  gdk-pixbuf2-devel >= 2.0
30 BuildRequires:  gettext-devel >= 0.17
31 BuildRequires:  glib2-devel >= 1:2.37.3
32 BuildRequires:  gobject-introspection-devel >= 0.10.0
33 BuildRequires:  gtk+3-devel >= 3.4.0
34 BuildRequires:  gtk-doc >= 1.15
35 BuildRequires:  json-glib-devel >= 0.12.0
36 %{?with_evdev:BuildRequires:    libevdev-devel}
37 BuildRequires:  libtool >= 2:2.2.6
38 BuildRequires:  libxslt-progs
39 BuildRequires:  pango-devel >= 1:1.30
40 BuildRequires:  pkgconfig >= 1:0.16
41 BuildRequires:  python-modules
42 BuildRequires:  tar >= 1:1.22
43 %{?with_tslib:BuildRequires:    tslib-devel >= 1.1}
44 %{?with_evdev:BuildRequires:    udev-glib-devel}
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
47 BuildRequires:  xorg-lib-libXdamage-devel
48 BuildRequires:  xorg-lib-libXext-devel
49 BuildRequires:  xorg-lib-libXfixes-devel >= 4
50 BuildRequires:  xorg-lib-libXi-devel
51 %if %{with evdev} || %{with wayland}
52 BuildRequires:  xorg-lib-libxkbcommon-devel
53 %endif
54 BuildRequires:  xz
55 # wayland-client wayland-cursor (for client), wayland-server (for compositor)
56 %{?with_wayland:BuildRequires:  wayland-devel}
57 BuildRequires:  xorg-lib-libxkbcommon-devel
58 Requires:       atk >= 1:2.5.3
59 Requires:       cairo-gobject >= 1.10
60 Requires:       cogl >= 1.15.9
61 %{?with_wayland:Requires:       cogl(wayland) >= 1.15.9}
62 Requires:       glib2 >= 1:2.37.3
63 Requires:       gtk+3 >= 3.4.0
64 Requires:       json-glib >= 0.12.0
65 Requires:       pango >= 1:1.30
66 Obsoletes:      clutter-cairo < 1.0
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Clutter is an open source software library for creating fast, visually
71 rich graphical user interfaces. The most obvious example of potential
72 usage is in media center type applications. We hope however it can be
73 used for a lot more.
74
75 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
76 with an API which hides the underlying GL complexity from the
77 developer. The Clutter API is intended to be easy to use, efficient
78 and flexible.
79
80 %description -l pl.UTF-8
81 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
82 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
83 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
84 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
85 więcej zastosowań.
86
87 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
88 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
89 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
90
91 %package devel
92 Summary:        Header files for clutter library
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       OpenGL-GLX-devel
97 Requires:       atk-devel >= 1:2.5.3
98 Requires:       cairo-gobject-devel >= 1.10
99 Requires:       cogl-devel >= 1.15.9
100 %{?with_wayland:Requires:       cogl-devel(wayland) >= 1.15.9}
101 Requires:       gdk-pixbuf2-devel >= 2.0
102 Requires:       glib2-devel >= 1:2.37.3
103 Requires:       gtk+3-devel >= 3.4.0
104 Requires:       json-glib-devel >= 0.12.0
105 Requires:       pango-devel >= 1:1.30
106 Requires:       xorg-lib-libX11-devel
107 Requires:       xorg-lib-libXcomposite-devel >= 0.4
108 Requires:       xorg-lib-libXdamage-devel
109 Requires:       xorg-lib-libXext-devel
110 Requires:       xorg-lib-libXfixes-devel >= 4
111 Obsoletes:      clutter-cairo-devel < 1.0
112
113 %description devel
114 Header files for clutter library.
115
116 %description devel -l pl.UTF-8
117 Pliki nagłówkowe biblioteki clutter.
118
119 %package static
120 Summary:        Static clutter library
121 Summary(pl.UTF-8):      Statyczna biblioteka clutter
122 Group:          Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124 Obsoletes:      clutter-cairo-static < 1.0
125
126 %description static
127 Static clutter library.
128
129 %description static -l pl.UTF-8
130 Statyczna biblioteka clutter.
131
132 %package apidocs
133 Summary:        clutter API documentation
134 Summary(pl.UTF-8):      Dokumentacja API clutter
135 Group:          Documentation
136 Requires:       gtk-doc-common
137
138 %description apidocs
139 clutter API documentation.
140
141 %description apidocs -l pl.UTF-8
142 Dokumentacja API clutter.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147 %patch1 -p1
148
149 %build
150 %{__gtkdocize}
151 %{__libtoolize}
152 %{__aclocal} -I build/autotools
153 %{__autoconf}
154 %{__autoheader}
155 %{__automake}
156 %configure \
157         --disable-silent-rules \
158         --enable-docs \
159         %{?with_egl:--enable-egl-backend} \
160         %{?with_evdev:--enable-evdev-input} \
161         --enable-gdk-backend \
162         --enable-gtk-doc \
163         --enable-static \
164         %{?with_tslib:--enable-tslib-input} \
165 %if %{with wayland}
166         --enable-wayland-backend \
167         --enable-wayland-compositor \
168 %endif
169         --enable-xinput \
170         --with-html-dir=%{_gtkdocdir}
171 %{__make}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclutter-1.0.la
180
181 # move to %{_examplesdir} and package in -examples?
182 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/clutter-1.0/cookbook/examples
183
184 %find_lang clutter-1.0
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -p /sbin/ldconfig
190 %postun -p /sbin/ldconfig
191
192 %files -f clutter-1.0.lang
193 %defattr(644,root,root,755)
194 %doc ChangeLog NEWS README
195 %attr(755,root,root) %{_libdir}/libclutter-1.0.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libclutter-1.0.so.0
197 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.0
198 %{_libdir}/girepository-1.0/Cally-1.0.typelib
199 %{_libdir}/girepository-1.0/Clutter-1.0.typelib
200 %{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
201 %{_libdir}/girepository-1.0/ClutterX11-1.0.typelib
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libclutter-1.0.so
206 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
207 %{_includedir}/clutter-1.0
208 %{_datadir}/gir-1.0/Cally-1.0.gir
209 %{_datadir}/gir-1.0/Clutter-1.0.gir
210 %{_datadir}/gir-1.0/ClutterGdk-1.0.gir
211 %{_datadir}/gir-1.0/ClutterX11-1.0.gir
212 %{_pkgconfigdir}/cally-1.0.pc
213 %{_pkgconfigdir}/clutter-1.0.pc
214 %{_pkgconfigdir}/clutter-cogl-1.0.pc
215 %{_pkgconfigdir}/clutter-gdk-1.0.pc
216 %{_pkgconfigdir}/clutter-glx-1.0.pc
217 %{_pkgconfigdir}/clutter-x11-1.0.pc
218 %{_pkgconfigdir}/clutter-egl-1.0.pc
219 %{_pkgconfigdir}/clutter-wayland-1.0.pc
220 %{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
221
222 %files static
223 %defattr(644,root,root,755)
224 %{_libdir}/libclutter-1.0.a
225
226 %files apidocs
227 %defattr(644,root,root,755)
228 %{_gtkdocdir}/cally
229 %{_gtkdocdir}/clutter
230 %{_gtkdocdir}/clutter-cookbook
This page took 0.077082 seconds and 4 git commands to generate.