]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- release 2 (by relup.sh)
[packages/clutter.git] / clutter.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL framebuffer backend
4 %bcond_without  wayland # Wayland backend
5 %bcond_without  evdev   # evdev support for input events
6 %bcond_with     tslib   # TSLib support for input events (outdated?)
7
8 Summary:        Library for rich GUIs
9 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
10 Name:           clutter
11 Version:        1.22.0
12 Release:        2
13 License:        LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/clutter/1.22/%{name}-%{version}.tar.xz
16 # Source0-md5:  788c488d795103e4c201fae1b032cb89
17 Patch0:         gtkdoc.patch
18 Patch1:         missing.patch
19 URL:            http://www.clutter-project.org/
20 BuildRequires:  OpenGL-GLX-devel
21 BuildRequires:  atk-devel >= 1:2.5.3
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  cairo-devel >= 1.14.0
25 BuildRequires:  cairo-gobject-devel >= 1.14.0
26 BuildRequires:  cogl-devel >= 1.20.0
27 %{?with_wayland:BuildRequires:  cogl-devel(wayland) >= 1.20.0}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  gdk-pixbuf2-devel >= 2.0
30 BuildRequires:  gettext-tools >= 0.17
31 BuildRequires:  glib2-devel >= 1:2.39.0
32 BuildRequires:  gobject-introspection-devel >= 1.39.0
33 BuildRequires:  gtk+3-devel >= 3.4.0
34 BuildRequires:  gtk-doc >= 1.20
35 BuildRequires:  json-glib-devel >= 0.12.0
36 %{?with_evdev:BuildRequires:    libevdev-devel}
37 %{?with_evdev:BuildRequires:    libinput-devel >= 0.8.0}
38 BuildRequires:  libtool >= 2:2.2.6
39 BuildRequires:  libxslt-progs
40 BuildRequires:  pango-devel >= 1:1.30
41 BuildRequires:  pkgconfig >= 1:0.16
42 BuildRequires:  python-modules
43 BuildRequires:  tar >= 1:1.22
44 %{?with_tslib:BuildRequires:    tslib-devel >= 1.1}
45 %{?with_evdev:BuildRequires:    udev-devel >= 1:136}
46 %{?with_evdev:BuildRequires:    udev-glib-devel}
47 # wayland-client wayland-cursor (for client), wayland-server (for compositor)
48 %{?with_wayland:BuildRequires:  wayland-devel}
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXext-devel
53 BuildRequires:  xorg-lib-libXfixes-devel >= 4
54 BuildRequires:  xorg-lib-libXi-devel
55 %if %{with evdev} || %{with wayland}
56 BuildRequires:  xorg-lib-libxkbcommon-devel
57 %endif
58 BuildRequires:  xz
59 Requires:       atk >= 1:2.5.3
60 Requires:       cairo-gobject >= 1.14.0
61 Requires:       cogl >= 1.20.0
62 %{?with_wayland:Requires:       cogl(wayland) >= 1.20.0}
63 Requires:       glib2 >= 1:2.39.0
64 Requires:       gtk+3 >= 3.4.0
65 Requires:       json-glib >= 0.12.0
66 %{?with_evdev:Requires: libinput >= 0.8.0}
67 Requires:       pango >= 1:1.30
68 %{?with_evdev:Requires: udev-libs >= 1:136}
69 %{?with_evdev:Provides: clutter(evdev) = %{version}-%{release}}
70 Obsoletes:      clutter-cairo < 1.0
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 Clutter is an open source software library for creating fast, visually
75 rich graphical user interfaces. The most obvious example of potential
76 usage is in media center type applications. We hope however it can be
77 used for a lot more.
78
79 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
80 with an API which hides the underlying GL complexity from the
81 developer. The Clutter API is intended to be easy to use, efficient
82 and flexible.
83
84 %description -l pl.UTF-8
85 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
86 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
87 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
88 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
89 więcej zastosowań.
90
91 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
92 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
93 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
94
95 %package devel
96 Summary:        Header files for clutter library
97 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       OpenGL-GLX-devel
101 Requires:       atk-devel >= 1:2.5.3
102 Requires:       cairo-gobject-devel >= 1.14.0
103 Requires:       cogl-devel >= 1.20.0
104 %{?with_wayland:Requires:       cogl-devel(wayland) >= 1.20.0}
105 Requires:       gdk-pixbuf2-devel >= 2.0
106 Requires:       glib2-devel >= 1:2.39.0
107 Requires:       gtk+3-devel >= 3.4.0
108 Requires:       json-glib-devel >= 0.12.0
109 %{?with_evdev:Requires: libinput-devel >= 0.8.0}
110 Requires:       pango-devel >= 1:1.30
111 %{?with_evdev:Requires: udev-devel >= 1:136}
112 %{?with_wayland:Requires: wayland-devel}
113 Requires:       xorg-lib-libX11-devel
114 Requires:       xorg-lib-libXcomposite-devel >= 0.4
115 Requires:       xorg-lib-libXdamage-devel
116 Requires:       xorg-lib-libXext-devel
117 Requires:       xorg-lib-libXfixes-devel >= 4
118 %if %{with evdev} || %{with wayland}
119 Requires:       xorg-lib-libxkbcommon-devel
120 %endif
121 %{?with_evdev:Provides: clutter-devel(evdev) = %{version}-%{release}}
122 Obsoletes:      clutter-cairo-devel < 1.0
123
124 %description devel
125 Header files for clutter library.
126
127 %description devel -l pl.UTF-8
128 Pliki nagłówkowe biblioteki clutter.
129
130 %package static
131 Summary:        Static clutter library
132 Summary(pl.UTF-8):      Statyczna biblioteka clutter
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135 %{?with_evdev:Provides: clutter-static(evdev) = %{version}-%{release}}
136 Obsoletes:      clutter-cairo-static < 1.0
137
138 %description static
139 Static clutter library.
140
141 %description static -l pl.UTF-8
142 Statyczna biblioteka clutter.
143
144 %package apidocs
145 Summary:        clutter API documentation
146 Summary(pl.UTF-8):      Dokumentacja API clutter
147 Group:          Documentation
148 Requires:       gtk-doc-common
149 %if "%{_rpmversion}" >= "5"
150 BuildArch:      noarch
151 %endif
152
153 %description apidocs
154 clutter API documentation.
155
156 %description apidocs -l pl.UTF-8
157 Dokumentacja API clutter.
158
159 %prep
160 %setup -q
161 %patch0 -p1
162 %patch1 -p1
163
164 %build
165 %{__gtkdocize}
166 %{__libtoolize}
167 %{__aclocal} -I build/autotools
168 %{__autoconf}
169 %{__autoheader}
170 %{__automake}
171 %configure \
172         --disable-silent-rules \
173         --enable-docs \
174         %{?with_egl:--enable-egl-backend} \
175         %{?with_evdev:--enable-evdev-input} \
176         --enable-gdk-backend \
177         --enable-gtk-doc \
178         --enable-static \
179         %{?with_tslib:--enable-tslib-input} \
180 %if %{with wayland}
181         --enable-wayland-backend \
182         --enable-wayland-compositor \
183 %endif
184         --enable-xinput \
185         --with-html-dir=%{_gtkdocdir}
186 %{__make}
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclutter-1.0.la
195
196 # move to %{_examplesdir} and package in -examples?
197 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/clutter-1.0/cookbook/examples
198
199 %find_lang clutter-1.0
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post   -p /sbin/ldconfig
205 %postun -p /sbin/ldconfig
206
207 %files -f clutter-1.0.lang
208 %defattr(644,root,root,755)
209 %doc ChangeLog NEWS README
210 %attr(755,root,root) %{_libdir}/libclutter-1.0.so.*.*.*
211 %attr(755,root,root) %ghost %{_libdir}/libclutter-1.0.so.0
212 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.0
213 %{_libdir}/girepository-1.0/Cally-1.0.typelib
214 %{_libdir}/girepository-1.0/Clutter-1.0.typelib
215 %{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
216 %{_libdir}/girepository-1.0/ClutterX11-1.0.typelib
217
218 %files devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libclutter-1.0.so
221 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
222 %{_includedir}/clutter-1.0
223 %{_datadir}/gir-1.0/Cally-1.0.gir
224 %{_datadir}/gir-1.0/Clutter-1.0.gir
225 %{_datadir}/gir-1.0/ClutterGdk-1.0.gir
226 %{_datadir}/gir-1.0/ClutterX11-1.0.gir
227 %{_pkgconfigdir}/cally-1.0.pc
228 %{_pkgconfigdir}/clutter-1.0.pc
229 %{_pkgconfigdir}/clutter-cogl-1.0.pc
230 %{_pkgconfigdir}/clutter-gdk-1.0.pc
231 %{_pkgconfigdir}/clutter-glx-1.0.pc
232 %{_pkgconfigdir}/clutter-x11-1.0.pc
233 %{_pkgconfigdir}/clutter-egl-1.0.pc
234 %{_pkgconfigdir}/clutter-wayland-1.0.pc
235 %{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libclutter-1.0.a
240
241 %files apidocs
242 %defattr(644,root,root,755)
243 %{_gtkdocdir}/cally
244 %{_gtkdocdir}/clutter
245 %{_gtkdocdir}/clutter-cookbook
This page took 0.058176 seconds and 3 git commands to generate.