]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- Up to 1.4.2
[packages/clutter.git] / clutter.spec
1 # TODO:
2 # - Fix unpackaged language files, %find_lang doesn't seem to work here
3 #
4 Summary:        Library for rich GUIs
5 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
6 Name:           clutter
7 Version:        1.4.2
8 Release:        1
9 License:        LGPL v2+
10 Group:          Libraries
11 Source0:        http://www.clutter-project.org/sources/clutter/1.4/%{name}-%{version}.tar.bz2
12 # Source0-md5:  5a3c6d8414d4e286aba0a936f344c9b1
13 URL:            http://www.clutter-project.org/
14 BuildRequires:  OpenGL-GLX-devel
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.10
17 BuildRequires:  cairo-devel >= 1.6
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.16.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.5
21 BuildRequires:  gtk+2-devel >= 1:2.0
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  json-glib-devel >= 0.10.4-3
24 BuildRequires:  libtool
25 BuildRequires:  pango-devel >= 1:1.20
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-modules
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXfixes-devel >= 4
30 Obsoletes:      clutter-cairo < 1.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Clutter is an open source software library for creating fast, visually
35 rich graphical user interfaces. The most obvious example of potential
36 usage is in media center type applications. We hope however it can be
37 used for a lot more.
38
39 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
40 with an API which hides the underlying GL complexity from the
41 developer. The Clutter API is intended to be easy to use, efficient
42 and flexible.
43
44 %description -l pl.UTF-8
45 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
46 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
47 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
48 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
49 więcej zastosowań.
50
51 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
52 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
53 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
54
55 %package devel
56 Summary:        Header files for clutter library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       OpenGL-GLX-devel
61 Requires:       glib2-devel >= 1:2.16
62 Requires:       gtk+2-devel >= 1:2.0
63 Requires:       json-glib-devel >= 0.8.0
64 Requires:       xorg-lib-libX11-devel
65 Requires:       xorg-lib-libXfixes-devel >= 4
66 Obsoletes:      clutter-cairo-devel < 1.0
67
68 %description devel
69 Header files for clutter library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki clutter.
73
74 %package static
75 Summary:        Static clutter library
76 Summary(pl.UTF-8):      Statyczna biblioteka clutter
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79 Obsoletes:      clutter-cairo-static < 1.0
80
81 %description static
82 Static clutter library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka clutter.
86
87 %package apidocs
88 Summary:        clutter API documentation
89 Summary(pl.UTF-8):      Dokumentacja API clutter
90 Group:          Documentation
91 Requires:       gtk-doc-common
92
93 %description apidocs
94 clutter API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API clutter.
98
99 %prep
100 %setup -q
101
102 %build
103 %{__gtkdocize}
104 %{__libtoolize}
105 %{__aclocal} -I build/autotools
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         --with-json=system \
112         --enable-gtk-doc \
113         --enable-static \
114         --with-html-dir=%{_gtkdocdir}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README TODO
132 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libclutter-glx-1.0.so.0
134 %{_libdir}/girepository-1.0/*.typelib
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
139 %{_libdir}/libclutter-glx-1.0.la
140 %{_includedir}/clutter-1.0
141 %{_datadir}/gir-1.0/*.gir
142 %{_pkgconfigdir}/cally-1.0.pc
143 %{_pkgconfigdir}/clutter-1.0.pc
144 %{_pkgconfigdir}/clutter-glx-1.0.pc
145 %{_pkgconfigdir}/clutter-x11-1.0.pc
146 %{_pkgconfigdir}/cogl-1.0.pc
147 %{_pkgconfigdir}/cogl-gl-1.0.pc
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libclutter-glx-1.0.a
152
153 %files apidocs
154 %defattr(644,root,root,755)
155 %{_gtkdocdir}/cally
156 %{_gtkdocdir}/clutter
157 %{_gtkdocdir}/cogl
This page took 0.068672 seconds and 3 git commands to generate.