]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- added mir bcond
[packages/clutter.git] / clutter.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL framebuffer backend
4 %bcond_with     mir     # Mir backend (requires cogl support for Mir, which in turn conflicts with wayland)
5 %bcond_without  wayland # Wayland backend and compositor
6 %bcond_without  evdev   # evdev support for input events
7 %bcond_with     tslib   # TSLib support for input events (outdated?)
8
9 Summary:        Library for rich GUIs
10 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
11 Name:           clutter
12 Version:        1.22.0
13 Release:        2
14 License:        LGPL v2+
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/clutter/1.22/%{name}-%{version}.tar.xz
17 # Source0-md5:  788c488d795103e4c201fae1b032cb89
18 Patch0:         gtkdoc.patch
19 Patch1:         missing.patch
20 URL:            http://www.clutter-project.org/
21 BuildRequires:  OpenGL-GLX-devel
22 BuildRequires:  atk-devel >= 1:2.5.3
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  cairo-devel >= 1.14.0
26 BuildRequires:  cairo-gobject-devel >= 1.14.0
27 BuildRequires:  cogl-devel >= 1.20.0
28 %{?with_wayland:BuildRequires:  cogl-devel(wayland) >= 1.20.0}
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.0
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.39.0
33 BuildRequires:  gobject-introspection-devel >= 1.39.0
34 BuildRequires:  gtk+3-devel >= 3.4.0
35 BuildRequires:  gtk-doc >= 1.20
36 BuildRequires:  json-glib-devel >= 0.12.0
37 %{?with_evdev:BuildRequires:    libevdev-devel}
38 %{?with_evdev:BuildRequires:    libinput-devel >= 0.8.0}
39 BuildRequires:  libtool >= 2:2.2.6
40 BuildRequires:  libxslt-progs
41 %{?with_mir:BuildRequires:      mir-devel}
42 BuildRequires:  pango-devel >= 1:1.30
43 BuildRequires:  pkgconfig >= 1:0.16
44 BuildRequires:  python-modules
45 BuildRequires:  tar >= 1:1.22
46 %{?with_tslib:BuildRequires:    tslib-devel >= 1.1}
47 %{?with_evdev:BuildRequires:    udev-devel >= 1:136}
48 %{?with_evdev:BuildRequires:    udev-glib-devel}
49 # wayland-client wayland-cursor (for client), wayland-server (for compositor)
50 %{?with_wayland:BuildRequires:  wayland-devel}
51 BuildRequires:  xorg-lib-libX11-devel
52 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
53 BuildRequires:  xorg-lib-libXdamage-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXfixes-devel >= 4
56 BuildRequires:  xorg-lib-libXi-devel
57 %if %{with evdev} || %{with wayland}
58 BuildRequires:  xorg-lib-libxkbcommon-devel
59 %endif
60 BuildRequires:  xz
61 Requires:       atk >= 1:2.5.3
62 Requires:       cairo-gobject >= 1.14.0
63 Requires:       cogl >= 1.20.0
64 %{?with_wayland:Requires:       cogl(wayland) >= 1.20.0}
65 Requires:       glib2 >= 1:2.39.0
66 Requires:       gtk+3 >= 3.4.0
67 Requires:       json-glib >= 0.12.0
68 %{?with_evdev:Requires: libinput >= 0.8.0}
69 Requires:       pango >= 1:1.30
70 %{?with_evdev:Requires: udev-libs >= 1:136}
71 %{?with_evdev:Provides: clutter(evdev) = %{version}-%{release}}
72 Obsoletes:      clutter-cairo < 1.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Clutter is an open source software library for creating fast, visually
77 rich graphical user interfaces. The most obvious example of potential
78 usage is in media center type applications. We hope however it can be
79 used for a lot more.
80
81 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
82 with an API which hides the underlying GL complexity from the
83 developer. The Clutter API is intended to be easy to use, efficient
84 and flexible.
85
86 %description -l pl.UTF-8
87 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
88 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
89 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
90 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
91 więcej zastosowań.
92
93 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
94 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
95 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
96
97 %package devel
98 Summary:        Header files for clutter library
99 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       OpenGL-GLX-devel
103 Requires:       atk-devel >= 1:2.5.3
104 Requires:       cairo-gobject-devel >= 1.14.0
105 Requires:       cogl-devel >= 1.20.0
106 %{?with_wayland:Requires:       cogl-devel(wayland) >= 1.20.0}
107 Requires:       gdk-pixbuf2-devel >= 2.0
108 Requires:       glib2-devel >= 1:2.39.0
109 Requires:       gtk+3-devel >= 3.4.0
110 Requires:       json-glib-devel >= 0.12.0
111 %{?with_evdev:Requires: libinput-devel >= 0.8.0}
112 Requires:       pango-devel >= 1:1.30
113 %{?with_evdev:Requires: udev-devel >= 1:136}
114 %{?with_wayland:Requires: wayland-devel}
115 Requires:       xorg-lib-libX11-devel
116 Requires:       xorg-lib-libXcomposite-devel >= 0.4
117 Requires:       xorg-lib-libXdamage-devel
118 Requires:       xorg-lib-libXext-devel
119 Requires:       xorg-lib-libXfixes-devel >= 4
120 %if %{with evdev} || %{with wayland}
121 Requires:       xorg-lib-libxkbcommon-devel
122 %endif
123 %{?with_evdev:Provides: clutter-devel(evdev) = %{version}-%{release}}
124 Obsoletes:      clutter-cairo-devel < 1.0
125
126 %description devel
127 Header files for clutter library.
128
129 %description devel -l pl.UTF-8
130 Pliki nagłówkowe biblioteki clutter.
131
132 %package static
133 Summary:        Static clutter library
134 Summary(pl.UTF-8):      Statyczna biblioteka clutter
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137 %{?with_evdev:Provides: clutter-static(evdev) = %{version}-%{release}}
138 Obsoletes:      clutter-cairo-static < 1.0
139
140 %description static
141 Static clutter library.
142
143 %description static -l pl.UTF-8
144 Statyczna biblioteka clutter.
145
146 %package apidocs
147 Summary:        clutter API documentation
148 Summary(pl.UTF-8):      Dokumentacja API clutter
149 Group:          Documentation
150 Requires:       gtk-doc-common
151 %if "%{_rpmversion}" >= "5"
152 BuildArch:      noarch
153 %endif
154
155 %description apidocs
156 clutter API documentation.
157
158 %description apidocs -l pl.UTF-8
159 Dokumentacja API clutter.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p1
165
166 %build
167 %{__gtkdocize}
168 %{__libtoolize}
169 %{__aclocal} -I build/autotools
170 %{__autoconf}
171 %{__autoheader}
172 %{__automake}
173 %configure \
174         --disable-silent-rules \
175         --enable-docs \
176         %{?with_egl:--enable-egl-backend} \
177         %{?with_evdev:--enable-evdev-input} \
178         --enable-gdk-backend \
179         --enable-gtk-doc \
180         %{?with_mir:--enable-mir-backend} \
181         --enable-static \
182         %{?with_tslib:--enable-tslib-input} \
183 %if %{with wayland}
184         --enable-wayland-backend \
185         --enable-wayland-compositor \
186 %endif
187         --enable-xinput \
188         --with-html-dir=%{_gtkdocdir}
189 %{__make}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193
194 %{__make} install \
195         DESTDIR=$RPM_BUILD_ROOT
196
197 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclutter-1.0.la
198
199 # move to %{_examplesdir} and package in -examples?
200 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/clutter-1.0/cookbook/examples
201
202 %find_lang clutter-1.0
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post   -p /sbin/ldconfig
208 %postun -p /sbin/ldconfig
209
210 %files -f clutter-1.0.lang
211 %defattr(644,root,root,755)
212 %doc ChangeLog NEWS README
213 %attr(755,root,root) %{_libdir}/libclutter-1.0.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libclutter-1.0.so.0
215 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.0
216 %{_libdir}/girepository-1.0/Cally-1.0.typelib
217 %{_libdir}/girepository-1.0/Clutter-1.0.typelib
218 %{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
219 %{_libdir}/girepository-1.0/ClutterX11-1.0.typelib
220
221 %files devel
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/libclutter-1.0.so
224 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
225 %{_includedir}/clutter-1.0
226 %{_datadir}/gir-1.0/Cally-1.0.gir
227 %{_datadir}/gir-1.0/Clutter-1.0.gir
228 %{_datadir}/gir-1.0/ClutterGdk-1.0.gir
229 %{_datadir}/gir-1.0/ClutterX11-1.0.gir
230 %{_pkgconfigdir}/cally-1.0.pc
231 %{_pkgconfigdir}/clutter-1.0.pc
232 %{_pkgconfigdir}/clutter-cogl-1.0.pc
233 %{_pkgconfigdir}/clutter-gdk-1.0.pc
234 %{_pkgconfigdir}/clutter-glx-1.0.pc
235 %{_pkgconfigdir}/clutter-x11-1.0.pc
236 %{_pkgconfigdir}/clutter-egl-1.0.pc
237 %{?with_mir:%{_pkgconfigdir}/clutter-mir-1.0.pc}
238 %{_pkgconfigdir}/clutter-wayland-1.0.pc
239 %{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
240
241 %files static
242 %defattr(644,root,root,755)
243 %{_libdir}/libclutter-1.0.a
244
245 %files apidocs
246 %defattr(644,root,root,755)
247 %{_gtkdocdir}/cally
248 %{_gtkdocdir}/clutter
249 %{_gtkdocdir}/clutter-cookbook
This page took 0.155107 seconds and 3 git commands to generate.