]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- added libinput patch (update for libinput 0.8.x from Fedora)
[packages/clutter.git] / clutter.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL framebuffer backend
4 %bcond_without  wayland # Wayland backend
5 %bcond_without  evdev   # evdev support for input events
6 %bcond_with     tslib   # TSLib support for input events (outdated?)
7
8 Summary:        Library for rich GUIs
9 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
10 Name:           clutter
11 Version:        1.20.0
12 Release:        2
13 License:        LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/clutter/1.20/%{name}-%{version}.tar.xz
16 # Source0-md5:  a8a33a57a944c6d7c7c013ce9aa3222b
17 Patch0:         gtkdoc.patch
18 Patch1:         missing.patch
19 Patch2:         %{name}-libinput.patch
20 URL:            http://www.clutter-project.org/
21 BuildRequires:  OpenGL-GLX-devel
22 BuildRequires:  atk-devel >= 1:2.5.3
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  cairo-devel >= 1.12.0
26 BuildRequires:  cairo-gobject-devel >= 1.12.0
27 BuildRequires:  cogl-devel >= 1.18.0
28 %{?with_wayland:BuildRequires:  cogl-devel(wayland) >= 1.18.0}
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.0
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.37.3
33 BuildRequires:  gobject-introspection-devel >= 0.10.0
34 BuildRequires:  gtk+3-devel >= 3.4.0
35 BuildRequires:  gtk-doc >= 1.20
36 BuildRequires:  json-glib-devel >= 0.12.0
37 %{?with_evdev:BuildRequires:    libevdev-devel}
38 %{?with_evdev:BuildRequires:    libinput-devel >= 0.8.0}
39 BuildRequires:  libtool >= 2:2.2.6
40 BuildRequires:  libxslt-progs
41 BuildRequires:  pango-devel >= 1:1.30
42 BuildRequires:  pkgconfig >= 1:0.16
43 BuildRequires:  python-modules
44 BuildRequires:  tar >= 1:1.22
45 %{?with_tslib:BuildRequires:    tslib-devel >= 1.1}
46 %{?with_evdev:BuildRequires:    udev-devel >= 1:136}
47 %{?with_evdev:BuildRequires:    udev-glib-devel}
48 # wayland-client wayland-cursor (for client), wayland-server (for compositor)
49 %{?with_wayland:BuildRequires:  wayland-devel}
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
52 BuildRequires:  xorg-lib-libXdamage-devel
53 BuildRequires:  xorg-lib-libXext-devel
54 BuildRequires:  xorg-lib-libXfixes-devel >= 4
55 BuildRequires:  xorg-lib-libXi-devel
56 %if %{with evdev} || %{with wayland}
57 BuildRequires:  xorg-lib-libxkbcommon-devel
58 %endif
59 BuildRequires:  xz
60 Requires:       atk >= 1:2.5.3
61 Requires:       cairo-gobject >= 1.12.0
62 Requires:       cogl >= 1.18.0
63 %{?with_wayland:Requires:       cogl(wayland) >= 1.18.0}
64 Requires:       glib2 >= 1:2.37.3
65 Requires:       gtk+3 >= 3.4.0
66 Requires:       json-glib >= 0.12.0
67 %{?with_evdev:Requires: libinput >= 0.8.0}
68 Requires:       pango >= 1:1.30
69 %{?with_evdev:Requires: udev-libs >= 1:136}
70 %{?with_evdev:Provides: clutter(evdev) = %{version}-%{release}}
71 Obsoletes:      clutter-cairo < 1.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Clutter is an open source software library for creating fast, visually
76 rich graphical user interfaces. The most obvious example of potential
77 usage is in media center type applications. We hope however it can be
78 used for a lot more.
79
80 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
81 with an API which hides the underlying GL complexity from the
82 developer. The Clutter API is intended to be easy to use, efficient
83 and flexible.
84
85 %description -l pl.UTF-8
86 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
87 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
88 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
89 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
90 więcej zastosowań.
91
92 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
93 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
94 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
95
96 %package devel
97 Summary:        Header files for clutter library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       OpenGL-GLX-devel
102 Requires:       atk-devel >= 1:2.5.3
103 Requires:       cairo-gobject-devel >= 1.12.0
104 Requires:       cogl-devel >= 1.18.0
105 %{?with_wayland:Requires:       cogl-devel(wayland) >= 1.18.0}
106 Requires:       gdk-pixbuf2-devel >= 2.0
107 Requires:       glib2-devel >= 1:2.37.3
108 Requires:       gtk+3-devel >= 3.4.0
109 Requires:       json-glib-devel >= 0.12.0
110 %{?with_evdev:Requires: libinput-devel >= 0.8.0}
111 Requires:       pango-devel >= 1:1.30
112 %{?with_evdev:Requires: udev-devel >= 1:136}
113 %{?with_wayland:Requires: wayland-devel}
114 Requires:       xorg-lib-libX11-devel
115 Requires:       xorg-lib-libXcomposite-devel >= 0.4
116 Requires:       xorg-lib-libXdamage-devel
117 Requires:       xorg-lib-libXext-devel
118 Requires:       xorg-lib-libXfixes-devel >= 4
119 %if %{with evdev} || %{with wayland}
120 Requires:       xorg-lib-libxkbcommon-devel
121 %endif
122 %{?with_evdev:Provides: clutter-devel(evdev) = %{version}-%{release}}
123 Obsoletes:      clutter-cairo-devel < 1.0
124
125 %description devel
126 Header files for clutter library.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe biblioteki clutter.
130
131 %package static
132 Summary:        Static clutter library
133 Summary(pl.UTF-8):      Statyczna biblioteka clutter
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136 %{?with_evdev:Provides: clutter-static(evdev) = %{version}-%{release}}
137 Obsoletes:      clutter-cairo-static < 1.0
138
139 %description static
140 Static clutter library.
141
142 %description static -l pl.UTF-8
143 Statyczna biblioteka clutter.
144
145 %package apidocs
146 Summary:        clutter API documentation
147 Summary(pl.UTF-8):      Dokumentacja API clutter
148 Group:          Documentation
149 Requires:       gtk-doc-common
150 %if "%{_rpmversion}" >= "5"
151 BuildArch:      noarch
152 %endif
153
154 %description apidocs
155 clutter API documentation.
156
157 %description apidocs -l pl.UTF-8
158 Dokumentacja API clutter.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165
166 %build
167 %{__gtkdocize}
168 %{__libtoolize}
169 %{__aclocal} -I build/autotools
170 %{__autoconf}
171 %{__autoheader}
172 %{__automake}
173 %configure \
174         --disable-silent-rules \
175         --enable-docs \
176         %{?with_egl:--enable-egl-backend} \
177         %{?with_evdev:--enable-evdev-input} \
178         --enable-gdk-backend \
179         --enable-gtk-doc \
180         --enable-static \
181         %{?with_tslib:--enable-tslib-input} \
182 %if %{with wayland}
183         --enable-wayland-backend \
184         --enable-wayland-compositor \
185 %endif
186         --enable-xinput \
187         --with-html-dir=%{_gtkdocdir}
188 %{__make}
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT
195
196 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclutter-1.0.la
197
198 # move to %{_examplesdir} and package in -examples?
199 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/clutter-1.0/cookbook/examples
200
201 %find_lang clutter-1.0
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %files -f clutter-1.0.lang
210 %defattr(644,root,root,755)
211 %doc ChangeLog NEWS README
212 %attr(755,root,root) %{_libdir}/libclutter-1.0.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libclutter-1.0.so.0
214 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.0
215 %{_libdir}/girepository-1.0/Cally-1.0.typelib
216 %{_libdir}/girepository-1.0/Clutter-1.0.typelib
217 %{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
218 %{_libdir}/girepository-1.0/ClutterX11-1.0.typelib
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libclutter-1.0.so
223 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
224 %{_includedir}/clutter-1.0
225 %{_datadir}/gir-1.0/Cally-1.0.gir
226 %{_datadir}/gir-1.0/Clutter-1.0.gir
227 %{_datadir}/gir-1.0/ClutterGdk-1.0.gir
228 %{_datadir}/gir-1.0/ClutterX11-1.0.gir
229 %{_pkgconfigdir}/cally-1.0.pc
230 %{_pkgconfigdir}/clutter-1.0.pc
231 %{_pkgconfigdir}/clutter-cogl-1.0.pc
232 %{_pkgconfigdir}/clutter-gdk-1.0.pc
233 %{_pkgconfigdir}/clutter-glx-1.0.pc
234 %{_pkgconfigdir}/clutter-x11-1.0.pc
235 %{_pkgconfigdir}/clutter-egl-1.0.pc
236 %{_pkgconfigdir}/clutter-wayland-1.0.pc
237 %{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libclutter-1.0.a
242
243 %files apidocs
244 %defattr(644,root,root,755)
245 %{_gtkdocdir}/cally
246 %{_gtkdocdir}/clutter
247 %{_gtkdocdir}/clutter-cookbook
This page took 0.066638 seconds and 3 git commands to generate.