]> git.pld-linux.org Git - packages/closure-compiler.git/commitdiff
up to v20130722 (July 22, 2013) auto/th/closure-compiler-20130722-1
authorElan Ruusamäe <glen@delfi.ee>
Sun, 18 Aug 2013 21:37:34 +0000 (00:37 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 18 Aug 2013 21:37:34 +0000 (00:37 +0300)
- Stricter missing-property checks for structs.
- Improved type inference for assignments to the prototype property.
- Fix incompatibility between removeUnusedClassProperties and Object.seal, and add the pass to advanced optimizations.
- Open source the code-coverage instrumentation pass.
- Allow constructors with a declared return type to be called without new.
- Bugfixes for goog.inherits used with generic types.
- Better detection of block comments that contain jsdoc tags.
- In ES5 mode, don't quote object literal keys when they're ES3 keywords.
- In ES3 mode, allow ES3 keywords as property names but quote them.
- New jsdoc tag @disposes for use with CheckEventfulDisposal pass to specify particular arguments of a function to be disposed.
- Updated externs for angular, jquery and maps api.
- Fix issue 1017, issue 1020, issue 1021, issue 1023, issue 1030, issue 1033, issue 1035, issue 1042, issue 1043.

https://code.google.com/p/closure-compiler/wiki/Releases

closure-compiler.spec

index c2e2792dae39df63ac92b365b56991406a04bff6..9b36031d803a7254bd2f6832a8d3a50a4d182001 100644 (file)
@@ -6,13 +6,13 @@
 %include       /usr/lib/rpm/macros.java
 Summary:       Closure Compiler - JavaScript compressor
 Name:          closure-compiler
-Version:       20130603
+Version:       20130722
 Release:       1
 License:       Apache v2.0
 Group:         Applications/WWW
 # Source0Download: https://code.google.com/p/closure-compiler/downloads/list
 Source0:       http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
-# Source0-md5: 88dcfc777323b5768be4d7d5167b3a91
+# Source0-md5: 8d8f3f3d429742ca7fd7bfa9e164d8b5
 Source1:       %{name}.sh
 Source2:       get-source.sh
 Source4:       Changes
This page took 0.104657 seconds and 4 git commands to generate.