]> git.pld-linux.org Git - packages/closure-compiler.git/blob - closure-compiler.spec
- keep startup wrapper in separate source control
[packages/closure-compiler.git] / closure-compiler.spec
1 # TODO
2 # - build from source
3 # - NOTE: build-data.properties is included twice in .jar
4
5 %include        /usr/lib/rpm/macros.java
6 Summary:        Closure Compiler - JavaScript compressor
7 Name:           closure-compiler
8 Version:        20100201
9 Release:        0.1
10 License:        Apache v2.0
11 Group:          Applications/WWW
12 Source0:        http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
13 # Source0-md5:  71bb4f8975ffc81fd0b9a82e18318a49
14 Source1:        %{name}.sh
15 URL:            http://closure-compiler.appspot.com/
16 BuildRequires:  rpm-javaprov
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Closure Compiler is a JavaScript optimizing compiler. It parses your
23 JavaScript, analyzes it, removes dead code and rewrites and minimizes
24 what's left. It also checks syntax, variable references, and types,
25 and warns about common JavaScript pitfalls. It is used in many of
26 Google's JavaScript apps, including Gmail, Google Web Search, Google
27 Maps, and Google Docs.
28
29 %prep
30 %setup -qc
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
35 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
36
37 # jars
38 cp -a compiler.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
39 ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README
47 %attr(755,root,root) %{_bindir}/%{name}
48 %{_javadir}/*.jar
This page took 0.058748 seconds and 4 git commands to generate.