]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- enabled osl (OpenScop) support
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 Summary:        The Chunky Loop Generator
6 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
7 Name:           cloog-isl
8 Version:        0.18.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Development/Tools
12 Source0:        http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
13 # Source0-md5:  be78a47bd82523250eb3e91646db5b3d
14 URL:            http://www.cloog.org/
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 BuildRequires:  gmp-devel >= 5.0.2
18 BuildRequires:  gmp-c++-devel >= 5.0.2
19 BuildRequires:  isl-devel >= 0.08
20 BuildRequires:  libtool
21 %{?with_osl:BuildRequires:      osl-devel}
22 BuildRequires:  texinfo-texi2dvi
23 Requires:       %{name}-libs = %{version}-%{release}
24 Provides:       cloog = %{version}
25 Obsoletes:      cloog
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 CLooG is a software which generates loops for scanning Z-polyhedra.
30 That is, CLooG finds the code or pseudo-code where each integral point
31 of one or more parametrized polyhedron or parametrized polyhedra union
32 is reached. CLooG is designed to avoid control overhead and to produce
33 a very efficient code.
34
35 This version is based on isl.
36
37 %description -l pl.UTF-8
38 CLooG to oprogramowanie generujące pętle do przeszukiwania
39 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
40 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
41 sparametryzowanych wielościanów lub sum sparametryzowanych
42 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
43 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
44
45 Ta wersja jest oparta na bibliotece isl.
46
47 %package libs
48 Summary:        Chunky Loop Generator shared library - isl based version
49 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
50 Group:          Libraries
51 Requires:       isl >= 0.08
52
53 %description libs
54 Chunky Loop Generator shared library - isl based version.
55
56 %description libs -l pl.UTF-8
57 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
58 isl.
59
60 %package devel
61 Summary:        Header files for the isl based version of Chunky Loop Generator
62 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       gmp-devel >= 5.0.2
66 Requires:       gmp-c++-devel >= 5.0.2
67 Requires:       isl-devel >= 0.08
68 %{?with_osl:Requires:   osl-devel}
69 Provides:       cloog-devel = %{version}
70
71 %description devel
72 The header files for Chunky Loop Generator library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
76
77 %package static
78 Summary:        Static library of isl based version of Chunky Loop Generator
79 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static library of isl based version of Chunky Loop Generator.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
88
89 %prep
90 %setup -q -n cloog-%{version}
91
92 %build
93 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
94 %configure \
95         --disable-silent-rules \
96         --with-gmp-exec-prefix \
97         --with-isl=system \
98         %{?with_osl:--with-osl=system}
99
100 %{__make}
101
102 %{__make} -C doc cloog.pdf
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   libs -p /sbin/ldconfig
114 %postun libs -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/cloog
119
120 %files libs
121 %defattr(644,root,root,755)
122 %doc ChangeLog README
123 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
125
126 %files devel
127 %defattr(644,root,root,755)
128 %doc doc/cloog.pdf
129 %attr(755,root,root) %{_libdir}/libcloog-isl.so
130 %{_libdir}/libcloog-isl.la
131 %dir %{_includedir}/cloog
132 %{_includedir}/cloog/*.h
133 %{_includedir}/cloog/isl
134 %{_includedir}/cloog/matrix
135 %{_pkgconfigdir}/cloog-isl.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libcloog-isl.a
This page took 0.164007 seconds and 3 git commands to generate.