]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- updated to 0.21.1; isl 0.26, osl 0.9.7
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.19
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.19.0
10 Release:        2
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 # older?
14 #Source0:       http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
15 #Source0Download: https://github.com/periscop/cloog/releases
16 Source0:        https://github.com/periscop/cloog/releases/download/cloog-%{version}/cloog-%{version}.tar.gz
17 # Source0-md5:  e3a6f4dcc25d88cb0bfff1a477ee7f43
18 URL:            http://www.cloog.org/
19 BuildRequires:  autoconf >= 2.53
20 BuildRequires:  automake
21 BuildRequires:  gmp-devel >= 5.0.2
22 BuildRequires:  gmp-c++-devel >= 5.0.2
23 BuildRequires:  isl-devel >= %{isl_ver}
24 BuildRequires:  libtool
25 %{?with_osl:BuildRequires:      osl-devel >= 0.9.2}
26 BuildRequires:  texinfo-texi2dvi
27 Requires:       %{name}-libs = %{version}-%{release}
28 Provides:       cloog = %{version}
29 Obsoletes:      cloog
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 CLooG is a software which generates loops for scanning Z-polyhedra.
34 That is, CLooG finds the code or pseudo-code where each integral point
35 of one or more parametrized polyhedron or parametrized polyhedra union
36 is reached. CLooG is designed to avoid control overhead and to produce
37 a very efficient code.
38
39 This version is based on isl.
40
41 %description -l pl.UTF-8
42 CLooG to oprogramowanie generujące pętle do przeszukiwania
43 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
44 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
45 sparametryzowanych wielościanów lub sum sparametryzowanych
46 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
47 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
48
49 Ta wersja jest oparta na bibliotece isl.
50
51 %package libs
52 Summary:        Chunky Loop Generator shared library - isl based version
53 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
54 Group:          Libraries
55 Requires:       isl >= %{isl_ver}
56 %{?with_osl:Requires:   osl >= 0.9.2}
57
58 %description libs
59 Chunky Loop Generator shared library - isl based version.
60
61 %description libs -l pl.UTF-8
62 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
63 isl.
64
65 %package devel
66 Summary:        Header files for the isl based version of Chunky Loop Generator
67 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       gmp-devel >= 5.0.2
71 Requires:       gmp-c++-devel >= 5.0.2
72 Requires:       isl-devel >= %{isl_ver}
73 %{?with_osl:Requires:   osl-devel >= 0.9.2}
74 Provides:       cloog-devel = %{version}
75 Conflicts:      cloog-polylib-devel
76 Conflicts:      cloog-ppl-devel
77
78 %description devel
79 The header files for Chunky Loop Generator library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
83
84 %package static
85 Summary:        Static library of isl based version of Chunky Loop Generator
86 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static library of isl based version of Chunky Loop Generator.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
95
96 %prep
97 %setup -q -n cloog-%{version}
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__automake}
104 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
105 %configure \
106         --disable-silent-rules \
107         --with-gmp-exec-prefix \
108         --with-isl=system \
109         %{?with_osl:--with-osl=system}
110
111 %{__make}
112
113 %{__make} -C doc cloog.pdf
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # obsoleted by pkg-config
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcloog-isl.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/cloog
133
134 %files libs
135 %defattr(644,root,root,755)
136 %doc ChangeLog README
137 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc doc/cloog.pdf
143 %attr(755,root,root) %{_libdir}/libcloog-isl.so
144 %dir %{_includedir}/cloog
145 %{_includedir}/cloog/*.h
146 %{_includedir}/cloog/isl
147 %{_includedir}/cloog/matrix
148 %dir %{_libdir}/cloog-isl
149 %{_libdir}/cloog-isl/cloog-isl-config.cmake
150 %dir %{_libdir}/isl
151 %{_libdir}/isl/isl-config.cmake
152 %{_pkgconfigdir}/cloog-isl.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libcloog-isl.a
This page took 0.408999 seconds and 3 git commands to generate.