]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- rel 4 (now it builds on ppc too)
[packages/clisp.git] / clisp.spec
1 # TODO:
2 # - review alpha patch
3 #
4 # Conditional build:
5 %bcond_with     tests   # run test suite `make check' (uses network, won't pass on vserver)
6 #
7 Summary:        Common Lisp (ANSI CL) implementation
8 Summary(pl.UTF-8):      Implementacja Common Lisp (ANSI CL)
9 Summary(pt_BR.UTF-8):   Implementação do Common Lisp (ANSI CL)
10 Name:           clisp
11 Version:        2.47
12 Release:        4
13 License:        GPL
14 Group:          Development/Languages
15 Source0:        http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  8fa89bb13e865fc7c7150b82682f35af
17 Patch0:         %{name}-shell.patch
18 Patch1:         %{name}-alpha.patch
19 URL:            http://clisp.cons.org/
20 BuildRequires:  ffcall-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  libsigsegv >= 2.4
23 BuildRequires:  ncurses-devel
24 BuildRequires:  readline-devel
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRequires:  xorg-lib-libXpm-devel
27 BuildRequires:  xorg-proto-xextproto-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Common Lisp is a high-level, all-purpose programming language. CLISP
32 is a Common Lisp implementation by Bruno Haible of Karlsruhe
33 University and Michael Stoll of Munich University, both in Germany. It
34 mostly supports Common Lisp as described in the ANSI CL standard. It
35 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
36 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
37 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
38 needs only 2 MB of RAM.
39
40 It is free software and may be distributed under the terms of GNU GPL,
41 while it is possible to distribute commercial applications compiled
42 with CLISP.
43
44 The user interface comes in German, English, French and Spanish. CLISP
45 includes an interpreter, a compiler, a large subset of CLOS, a foreign
46 language interface and a socket interface. An X11 interface is
47 available through CLX and Garnet.
48
49 %description -l pl.UTF-8
50 Common Lisp to wysokopoziomowy język programowania ogólnego
51 przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
52 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
53 University (oba w Niemczech). W większości wspiera Common Lisp opisany
54 w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
55 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
56 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
57 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
58
59 To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
60 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
61
62 Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
63 i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
64 CLOS, interfejs do innych języków oraz interfejs do gniazdek.
65 Interfejs X11 jest dostępny poprzez CLX i Garnet.
66
67 %description -l pt_BR.UTF-8
68 Common Lisp é uma linguagem de programação de propósito geral de alto
69 nível. CLISP é uma implementação do Common Lisp feita por Bruno
70 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
71 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
72 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
73 software livre, distribuído sob os termos da GNU GPL.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 #%patch1 -p1
79
80 # changing default -O to optflags causes memory fault on amd64
81 # - so something is broken... code or compiler
82 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
83 # random crashes on sparc (which occur with default CFLAGS)
84 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
85
86 %build
87
88 %ifarch ppc ppc64
89 CFLAGS="%{rpmcflags} -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
90 ulimit -s unlimited
91 %endif
92
93 CC="%{__cc}" \
94 ./configure \
95         --prefix=%{_prefix}
96
97 cd src
98 ./makemake \
99         --prefix=%{_prefix} \
100         --with-readline \
101         --with-gettext \
102         --with-dynamic-ffi \
103         --fsstnd=redhat \
104         --with-module=wildcard \
105         --with-module=bindings/glibc \
106         --with-module=clx/new-clx \
107         >Makefile
108 %{__make} -j1 config.lisp \
109         TOPDIR=clisp
110 %{__make} -j1 \
111         libdir=%{_libdir} \
112         TOPDIR=clisp
113
114 %{?with_tests:%{__make} -j1 check}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} -j1 -C src install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         libdir=%{_libdir} \
122         lispdocdir=%{_docdir}/%{name}-%{version} \
123         mandir=%{_mandir} \
124         TOPDIR=clisp
125
126 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
127 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
128
129 %find_lang %{name} --all-name
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/clisp
137 %doc %{_docdir}/%{name}-%{version} 
138 %dir %{_libdir}/clisp
139 %dir %{_libdir}/clisp/base
140 %{_libdir}/clisp/base/*.[aho]
141 %{_libdir}/clisp/base/lispinit.mem
142 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
143 %{_libdir}/clisp/base/makevars
144 %{_libdir}/clisp/clisp-link
145 %{_libdir}/clisp/data
146 %dir %{_libdir}/clisp/full
147 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
148 %{_libdir}/clisp/full/*.[aho]
149 %{_libdir}/clisp/full/lispinit.mem
150 %{_libdir}/clisp/full/makevars
151 %{_libdir}/clisp/linkkit
152 %{_mandir}/man[13]/*
This page took 0.06503 seconds and 3 git commands to generate.