]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- rel 4 (now it builds on ppc too)
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
bfd7e11e 3#
79f0f74b 4# Conditional build:
cdd858ea 5%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 6#
59f7b327 7Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
8Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
9Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 10Name: clisp
38c3e49c 11Version: 2.47
6ba4ad61 12Release: 4
59f7b327 13License: GPL
14Group: Development/Languages
05dfe0ce 15Source0: http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
38c3e49c 16# Source0-md5: 8fa89bb13e865fc7c7150b82682f35af
59f7b327 17Patch0: %{name}-shell.patch
5a8ba3e7 18Patch1: %{name}-alpha.patch
59f7b327 19URL: http://clisp.cons.org/
3cd314f5 20BuildRequires: ffcall-devel
59f7b327 21BuildRequires: gettext-devel
afc85770 22BuildRequires: libsigsegv >= 2.4
10afc298 23BuildRequires: ncurses-devel
05dfe0ce 24BuildRequires: readline-devel
a84435bf
JB
25BuildRequires: xorg-lib-libX11-devel
26BuildRequires: xorg-lib-libXpm-devel
27BuildRequires: xorg-proto-xextproto-devel
59f7b327 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Common Lisp is a high-level, all-purpose programming language. CLISP
32is a Common Lisp implementation by Bruno Haible of Karlsruhe
33University and Michael Stoll of Munich University, both in Germany. It
34mostly supports Common Lisp as described in the ANSI CL standard. It
35runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
36500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
37Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
38needs only 2 MB of RAM.
39
40It is free software and may be distributed under the terms of GNU GPL,
41while it is possible to distribute commercial applications compiled
42with CLISP.
43
44The user interface comes in German, English, French and Spanish. CLISP
45includes an interpreter, a compiler, a large subset of CLOS, a foreign
46language interface and a socket interface. An X11 interface is
47available through CLX and Garnet.
48
9a5b73ba
JR
49%description -l pl.UTF-8
50Common Lisp to wysokopoziomowy język programowania ogólnego
51przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 52Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
53University (oba w Niemczech). W większości wspiera Common Lisp opisany
54w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
55NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
56uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
57AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
58
9a5b73ba 59To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
60jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
61
9a5b73ba
JR
62Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
63i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
64CLOS, interfejs do innych języków oraz interfejs do gniazdek.
65Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 66
9a5b73ba
JR
67%description -l pt_BR.UTF-8
68Common Lisp é uma linguagem de programação de propósito geral de alto
69nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 70Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
71Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
72o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
73software livre, distribuído sob os termos da GNU GPL.
3b8ff915 74
59f7b327 75%prep
76%setup -q
77%patch0 -p1
3cd314f5 78#%patch1 -p1
05dfe0ce
JB
79
80# changing default -O to optflags causes memory fault on amd64
81# - so something is broken... code or compiler
0c5f0ead
JB
82# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
83# random crashes on sparc (which occur with default CFLAGS)
84#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 85
86%build
fdf4594b 87
88%ifarch ppc ppc64
89CFLAGS="%{rpmcflags} -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
90ulimit -s unlimited
91%endif
92
79f0f74b
JB
93CC="%{__cc}" \
94./configure \
00fbe0f1 95 --prefix=%{_prefix}
f404e321 96
59f7b327 97cd src
98./makemake \
99 --prefix=%{_prefix} \
100 --with-readline \
101 --with-gettext \
102 --with-dynamic-ffi \
e4912e71 103 --fsstnd=redhat \
59f7b327 104 --with-module=wildcard \
5d55e2b8 105 --with-module=bindings/glibc \
e4912e71 106 --with-module=clx/new-clx \
59f7b327 107 >Makefile
a6fd4b7b 108%{__make} -j1 config.lisp \
3cd314f5 109 TOPDIR=clisp
a6fd4b7b 110%{__make} -j1 \
3cd314f5
ŁK
111 libdir=%{_libdir} \
112 TOPDIR=clisp
bfd7e11e 113
a6fd4b7b 114%{?with_tests:%{__make} -j1 check}
59f7b327 115
116%install
117rm -rf $RPM_BUILD_ROOT
05dfe0ce 118
a6fd4b7b 119%{__make} -j1 -C src install \
59f7b327 120 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 121 libdir=%{_libdir} \
59f7b327 122 lispdocdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
123 mandir=%{_mandir} \
124 TOPDIR=clisp
05dfe0ce
JB
125
126install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
66d98f1f 127install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
59f7b327 128
085d3d70 129%find_lang %{name} --all-name
130
59f7b327 131%clean
132rm -rf $RPM_BUILD_ROOT
133
085d3d70 134%files -f %{name}.lang
59f7b327 135%defattr(644,root,root,755)
136%attr(755,root,root) %{_bindir}/clisp
bb3deaa0 137%doc %{_docdir}/%{name}-%{version}
59f7b327 138%dir %{_libdir}/clisp
139%dir %{_libdir}/clisp/base
140%{_libdir}/clisp/base/*.[aho]
141%{_libdir}/clisp/base/lispinit.mem
142%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
143%{_libdir}/clisp/base/makevars
144%{_libdir}/clisp/clisp-link
145%{_libdir}/clisp/data
05dfe0ce
JB
146%dir %{_libdir}/clisp/full
147%attr(755,root,root) %{_libdir}/clisp/full/lisp.run
59f7b327 148%{_libdir}/clisp/full/*.[aho]
149%{_libdir}/clisp/full/lispinit.mem
59f7b327 150%{_libdir}/clisp/full/makevars
151%{_libdir}/clisp/linkkit
59f7b327 152%{_mandir}/man[13]/*
This page took 0.056895 seconds and 4 git commands to generate.