]> git.pld-linux.org Git - packages/clearsilver.git/blob - clearsilver.spec
- release 11 (by relup.sh)
[packages/clearsilver.git] / clearsilver.spec
1 Summary:        ClearSilver HTML template system
2 Summary(pl.UTF-8):      ClearSilver - system szablonów HTML
3 Name:           clearsilver
4 Version:        0.10.5
5 Release:        11
6 License:        Apache License style
7 Group:          Development/Libraries
8 Source0:        http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  b8c0c7fbe0ef5e06e0c935f134304d44
10 Patch0:         %{name}-pic.patch
11 Patch1:         format-security.patch
12 URL:            http://www.clearsilver.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  perl-ExtUtils-MakeMaker
16 BuildRequires:  perl-devel
17 BuildRequires:  python-devel
18 BuildRequires:  python-modules
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ClearSilver is a fast, powerful, and language-neutral HTML template
25 system. In both static content sites and dynamic HTML applications, it
26 provides a separation between presentation code and application logic
27 which makes working with your project easier.
28
29 %description -l pl.UTF-8
30 ClearSilver to szybki, potężny i niezależny od języka system szablonów
31 HTML. Zarówno w statycznych stronach HTML jak i dynamicznych
32 aplikacjach pomaga oddzielić kod prezentacyjny od logiki aplikacji, co
33 ułatwia pracę nad projektem.
34
35 %package devel
36 Summary:        ClearSilver development package
37 Summary(pl.UTF-8):      Pakiet programistyczny ClearSilver
38 Group:          Development/Libraries
39
40 %description devel
41 This package provides needed files to develop extension to
42 ClearSilver.
43
44 %description devel -l pl.UTF-8
45 Ten pakiet dostarcza pliki potrzebne do tworzenia rozszerzeń dla
46 ClearSilver.
47
48 %package -n python-clearsilver
49 Summary:        Neotonic ClearSilver Python Module
50 Summary(pl.UTF-8):      Moduł Pythona Neotonic ClearSilver
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description -n python-clearsilver
55 This package provides a Python interface to the ClearSilver CGI kit
56 and templating system.
57
58 %description -n python-clearsilver -l pl.UTF-8
59 Ten pakiet dostarcza interfejs Pythona do zestawu CGI i systemu
60 szablonów ClearSilver.
61
62 %package -n perl-ClearSilver
63 Summary:        Neotonic ClearSilver Perl Module
64 Summary(pl.UTF-8):      Moduł Perla Neotonic ClearSilver
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description -n perl-ClearSilver
69 This package provides a Perl interface to the ClearSilver templating
70 system.
71
72 %description -n perl-ClearSilver -l pl.UTF-8
73 Ten pakiet dostarcza interfejs Perla do systemu szablonów ClearSilver.
74
75 %package -n ruby-clearsilver
76 Summary:        Neotonic ClearSilver Ruby Module
77 Summary(pl.UTF-8):      Moduł Ruby'ego Neotonic ClearSilver
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description -n ruby-clearsilver
82 This package provides a ruby interface to the ClearSilver templating
83 system.
84
85 %description -n ruby-clearsilver -l pl.UTF-8
86 Ten pakiet dostarcza interfejs języka Ruby do systemu szablonów
87 ClearSilver.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93
94 find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g" 
95
96 %build
97 install /usr/share/automake/config.* .
98 %{__aclocal}
99 %{__autoconf}
100 %configure \
101         --disable-csharp \
102         --disable-java \
103         --disable-ruby \
104         --enable-apache \
105         --enable-perl \
106         --with-python=%{__python}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         INSTALLDIRS=vendor
116
117 %{__make} install -C python \
118         PYTHON_SITE=%{py_sitedir} \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__make} install -C perl \
122         DESTDIR=$RPM_BUILD_ROOT \
123         INSTALLDIRS=vendor
124
125 rm -rf $RPM_BUILD_ROOT%{perl_archlib} \
126         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
127
128 # what an ass putting it to lib32 dir
129 %if "%{_lib}" != "lib"
130 rm $RPM_BUILD_ROOT%{_prefix}/lib/python%{py_ver}/site-packages/neo_cgi.so
131 %endif
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
139 %attr(755,root,root) %{_bindir}/*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %{_libdir}/libneo_*.a
144 %{_includedir}/ClearSilver
145 %{_mandir}/man3/[!C]*.3*
146
147 %files -n python-clearsilver
148 %defattr(644,root,root,755)
149 %doc README.python
150 %attr(755,root,root) %{py_sitedir}/neo_cgi.so
151
152 %files -n perl-ClearSilver
153 %defattr(644,root,root,755)
154 %{perl_vendorarch}/ClearSilver.pm
155 %dir %{perl_vendorarch}/auto/ClearSilver
156 %attr(755,root,root) %{perl_vendorarch}/auto/ClearSilver/ClearSilver.so
157 %{_mandir}/man3/ClearSilver.3pm*
158
159 %if 0
160 %files -n ruby-clearsilver
161 %defattr(644,root,root,755)
162 %{ruby_sitepath}/%{ruby_version}/neo.rb
163 %attr(755,root,root) %{ruby_sitepath}/%{ruby_version}/%{ruby_arch}/hdf.so
164
165 %files -n apache-mod_ecs
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{apache_libexec}/mod_ecs.so
168 %endif
This page took 0.07692 seconds and 3 git commands to generate.