]> git.pld-linux.org Git - packages/clearsilver.git/blob - clearsilver.spec
- release 2
[packages/clearsilver.git] / clearsilver.spec
1 Summary:        ClearSilver HTML template system
2 Summary(pl.UTF-8):      ClearSilver - system szablonów HTML
3 Name:           clearsilver
4 Version:        0.10.5
5 Release:        2
6 License:        Apache License style
7 Group:          Development/Libraries
8 Source0:        http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  b8c0c7fbe0ef5e06e0c935f134304d44
10 Patch0:         %{name}-pic.patch
11 URL:            http://www.clearsilver.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  perl-ExtUtils-MakeMaker
15 BuildRequires:  perl-devel
16 BuildRequires:  python-devel
17 BuildRequires:  zlib-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ClearSilver is a fast, powerful, and language-neutral HTML template
22 system. In both static content sites and dynamic HTML applications, it
23 provides a separation between presentation code and application logic
24 which makes working with your project easier.
25
26 %description -l pl.UTF-8
27 ClearSilver to szybki, potężny i niezależny od języka system szablonów
28 HTML. Zarówno w statycznych stronach HTML jak i dynamicznych
29 aplikacjach pomaga oddzielić kod prezentacyjny od logiki aplikacji,
30 co ułatwia pracę nad projektem.
31
32 %package devel
33 Summary:        ClearSilver development package
34 Summary(pl.UTF-8):      Pakiet programistyczny ClearSilver
35 Group:          Development/Libraries
36
37 %description devel
38 This package provides needed files to develop extension to
39 ClearSilver.
40
41 %description devel -l pl.UTF-8
42 Ten pakiet dostarcza pliki potrzebne do tworzenia rozszerzeń dla
43 ClearSilver.
44
45 %package -n python-clearsilver
46 Summary:        Neotonic ClearSilver Python Module
47 Summary(pl.UTF-8):      Moduł Pythona Neotonic ClearSilver
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n python-clearsilver
52 This package provides a Python interface to the ClearSilver CGI kit
53 and templating system.
54
55 %description -n python-clearsilver -l pl.UTF-8
56 Ten pakiet dostarcza interfejs Pythona do zestawu CGI i systemu
57 szablonów ClearSilver.
58
59 %package -n perl-ClearSilver
60 Summary:        Neotonic ClearSilver Perl Module
61 Summary(pl.UTF-8):      Moduł Perla Neotonic ClearSilver
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description -n perl-ClearSilver
66 This package provides a Perl interface to the ClearSilver templating
67 system.
68
69 %description -n perl-ClearSilver -l pl.UTF-8
70 Ten pakiet dostarcza interfejs Perla do systemu szablonów ClearSilver.
71
72 %package -n ruby-clearsilver
73 Summary:        Neotonic ClearSilver Ruby Module
74 Summary(pl.UTF-8):      Moduł Ruby'ego Neotonic ClearSilver
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n ruby-clearsilver
79 This package provides a ruby interface to the ClearSilver templating
80 system.
81
82 %description -n ruby-clearsilver -l pl.UTF-8
83 Ten pakiet dostarcza interfejs języka Ruby do systemu szablonów
84 ClearSilver.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g" 
91
92 %build
93 install /usr/share/automake/config.* .
94 %{__aclocal}
95 %{__autoconf}
96 %configure \
97         --disable-csharp \
98         --disable-java \
99         --disable-ruby \
100         --enable-apache \
101         --enable-perl \
102         --with-python=%{_bindir}/python
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         INSTALLDIRS=vendor
112
113 %{__make} install -C python \
114         PYTHON_SITE=%{py_sitedir} \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__make} install -C perl \
118         DESTDIR=$RPM_BUILD_ROOT \
119         INSTALLDIRS=vendor
120
121 rm -rf $RPM_BUILD_ROOT%{perl_archlib} \
122         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
130 %attr(755,root,root) %{_bindir}/*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_libdir}/libneo_*.a
135 %{_includedir}/ClearSilver
136 %{_mandir}/man3/[!C]*.3*
137
138 %files -n python-clearsilver
139 %defattr(644,root,root,755)
140 %doc README.python
141 %attr(755,root,root) %{py_sitedir}/neo_cgi.so
142
143 %files -n perl-ClearSilver
144 %defattr(644,root,root,755)
145 %{perl_vendorarch}/ClearSilver.pm
146 %dir %{perl_vendorarch}/auto/ClearSilver
147 %{perl_vendorarch}/auto/ClearSilver/ClearSilver.bs
148 %attr(755,root,root) %{perl_vendorarch}/auto/ClearSilver/ClearSilver.so
149 %{_mandir}/man3/ClearSilver.3pm*
150
151 #%files -n ruby
152 #%defattr(644,root,root,755)
153 #{ruby_sitepath}/(ruby_version}/neo.rb
154 #%attr(755,root,root) {ruby_sitepath}/(ruby_version}/$(ruby_arch}/hdf.so
155
156 #%files -n mod_ecs
157 #%defattr(644,root,root,755)
158 #%attr(755,root,root) {apache_libexec}/mod_ecs.so
This page took 0.045338 seconds and 3 git commands to generate.