]> git.pld-linux.org Git - packages/clan.git/blob - clan.spec
- release 2 (rebuild without libosl.la)
[packages/clan.git] / clan.spec
1 Summary:        Clan - a Polyhedral Representation Extraction Tool for C-Based High Level Languages
2 Summary(pl.UTF-8):      Clan - narzędzie do tworzenia reprezentacji wielościanowej dla języków opartych na C
3 Name:           clan
4 Version:        0.8.1
5 Release:        2
6 License:        LGPL v3+
7 Group:          Libraries
8 ##Source0Download: http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
9 #Source0:       http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/%{name}-%{version}.tar.gz
10 #Source0Download: https://github.com/periscop/clan/releases
11 Source0:        https://github.com/periscop/clan/releases/download/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  bffd26cc8b1360e47245ef71cea78aa3
13 Patch0:         %{name}-info.patch
14 URL:            http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
15 BuildRequires:  autoconf >= 2.53
16 BuildRequires:  automake
17 BuildRequires:  bison >= 2.4
18 BuildRequires:  doxygen
19 BuildRequires:  flex >= 2.5.35
20 BuildRequires:  libtool
21 BuildRequires:  osl-devel >= 0.9.0
22 BuildRequires:  texinfo
23 BuildRequires:  texinfo-texi2dvi
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Clan is a free software and library which translates some particular
28 parts of high level programs written in C, C++, C# or Java into a
29 polyhedral representation called OpenScop. This representation may be
30 manipulated by other tools to, e.g., achieve complex analyses or
31 program restructurations (for optimization, parallelization or any
32 other kind of manipulation). It has been created to avoid tedious and
33 error-prone input file writing for polyhedral tools (such as CLooG,
34 LeTSeE, Clan etc.). Using Clan, the user has to deal with source
35 codes based on C grammar only (as C, C++, C# or Java).
36
37 %description -l pl.UTF-8
38 Clan to wolnodostępne oprogramowanie i biblioteka tłumacząca wybrane
39 części programów napisanych w językach wysokiego poziomu, takich jak
40 C, C++, C# lub Java na reprezentację wielościanową o nazwie OpenScop.
41 Reprezentacja ta może być przetwarzana przez inne narzędzia w celu np.
42 złożonych analiz lub restrukturyzacji programu (optymalizacji,
43 zrównoleglenia i innych). Powstało, aby zapobiec nudnemu i
44 błędogennemu tworzeniu plików wejściowych dla narzędzi wielościanowych
45 (takich jak CLooG, LeTSeE, Clan itp.). Przy użyciu narzędzia Clan
46 można obsłużyć tylko kody źródłowe oparte na gramatyce C (takie jak C,
47 C++, C# lub Java).
48
49 %package devel
50 Summary:        Header files for Clan library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Clan
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       osl-devel >= 0.9.0
55
56 %description devel
57 Header files for Clan library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki Clan.
61
62 %package static
63 Summary:        Static Clan library
64 Summary(pl.UTF-8):      Statyczna biblioteka Clan
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Clan library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka Clan.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --disable-silent-rules \
85         --with-osl=system
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %post   devel -p /sbin/postshell
102 -/usr/sbin/fix-info-dir -c %{_infodir}
103
104 %postun devel -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS ChangeLog README THANKS
110 %attr(755,root,root) %{_bindir}/clan
111 %attr(755,root,root) %{_libdir}/libclan.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libclan.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libclan.so
117 %{_libdir}/libclan.la
118 %dir %{_libdir}/clan
119 %{_libdir}/clan/clan-config.cmake
120 %{_includedir}/clan
121 %{_infodir}/clan.info*
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libclan.a
This page took 0.068987 seconds and 3 git commands to generate.