]> git.pld-linux.org Git - packages/clan.git/blob - clan.spec
- release 2 (rebuild without libosl.la)
[packages/clan.git] / clan.spec
1 Summary:        Clan - a Polyhedral Representation Extraction Tool for C-Based High Level Languages
2 Summary(pl.UTF-8):      Clan - narzędzie do tworzenia reprezentacji wielościanowej dla języków opartych na C
3 Name:           clan
4 Version:        0.8.0
5 Release:        3
6 License:        LGPL v3+
7 Group:          Libraries
8 #Source0Download: http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
9 Source0:        http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/%{name}-%{version}.tar.gz
10 # Source0-md5:  0dcba7f4bdf32159405f27ebce439d63
11 Patch0:         %{name}-info.patch
12 Patch1:         %{name}-osl.patch
13 URL:            http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
14 BuildRequires:  autoconf >= 2.53
15 BuildRequires:  automake
16 BuildRequires:  bison >= 2.4
17 BuildRequires:  doxygen
18 BuildRequires:  flex >= 2.5.35
19 BuildRequires:  libtool
20 BuildRequires:  osl-devel >= 0.9.0
21 BuildRequires:  texinfo
22 BuildRequires:  texinfo-texi2dvi
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Clan is a free software and library which translates some particular
27 parts of high level programs written in C, C++, C# or Java into a
28 polyhedral representation called OpenScop. This representation may be
29 manipulated by other tools to, e.g., achieve complex analyses or
30 program restructurations (for optimization, parallelization or any
31 other kind of manipulation). It has been created to avoid tedious and
32 error-prone input file writing for polyhedral tools (such as CLooG,
33 LeTSeE, Clan etc.). Using Clan, the user has to deal with source
34 codes based on C grammar only (as C, C++, C# or Java).
35
36 %description -l pl.UTF-8
37 Clan to wolnodostępne oprogramowanie i biblioteka tłumacząca wybrane
38 części programów napisanych w językach wysokiego poziomu, takich jak
39 C, C++, C# lub Java na reprezentację wielościanową o nazwie OpenScop.
40 Reprezentacja ta może być przetwarzana przez inne narzędzia w celu np.
41 złożonych analiz lub restrukturyzacji programu (optymalizacji,
42 zrównoleglenia i innych). Powstało, aby zapobiec nudnemu i
43 błędogennemu tworzeniu plików wejściowych dla narzędzi wielościanowych
44 (takich jak CLooG, LeTSeE, Clan itp.). Przy użyciu narzędzia Clan
45 można obsłużyć tylko kody źródłowe oparte na gramatyce C (takie jak C,
46 C++, C# lub Java).
47
48 %package devel
49 Summary:        Header files for Clan library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Clan
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       osl-devel >= 0.9.0
54
55 %description devel
56 Header files for Clan library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki Clan.
60
61 %package static
62 Summary:        Static Clan library
63 Summary(pl.UTF-8):      Statyczna biblioteka Clan
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static Clan library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka Clan.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --disable-silent-rules \
85         --with-osl=system
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %post   devel -p /sbin/postshell
102 -/usr/sbin/fix-info-dir -c %{_infodir}
103
104 %postun devel -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS ChangeLog README THANKS
110 %attr(755,root,root) %{_bindir}/clan
111 %attr(755,root,root) %{_libdir}/libclan.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libclan.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libclan.so
117 %{_libdir}/libclan.la
118 %{_includedir}/clan
119 %{_infodir}/clan.info*
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libclan.a
This page took 0.106961 seconds and 3 git commands to generate.