]> git.pld-linux.org Git - packages/clamav.git/blob - clamav.spec
- added clamav-post-updatedb cript - fix problem with overwriting with
[packages/clamav.git] / clamav.spec
1 # TODO:
2 #   Make freshclam (script and daemon)
3
4 Summary:        An anti-virus utility for Unix
5 Summary(pl):    Antywirusowe narzêdzie dla Uniksów
6 Name:           clamav
7 Version:        0.70
8 Release:        1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/clamav/%{name}-%{version}.tar.gz
12 # Source0-md5:  2599a2e6b06d1f8ca09fdef8bc17625c
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 Source4:        %{name}-cron-updatedb
16 Source5:        %{name}.logrotate
17 # Remember to update date on each rebuild!!
18 %define         database_version 20040420
19 Source6:        http://www.clamav.net/database/daily.cvd
20 # Source6-md5:  91fae748a9702545492d1a045db4c630
21 Source7:        http://www.clamav.net/database/main.cvd
22 # Source7-md5:  e85d9a1c57005458c3208bf94a888706
23 Source8:        %{name}-post-updatedb
24 Patch0:         %{name}-pld_config.patch
25 Patch1:         %{name}-no_auto_libwrap.patch
26 URL:            http://www.clamav.net/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  zlib-devel
30 BuildRequires:  gmp-devel
31 Requires(post,preun):   /sbin/chkconfig
32 Requires:       %{name}-libs = %{version}-%{release}
33 Requires:       bc
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
38 AMaViS, compressed files, uses the virus database from
39 OpenAntivirus.org, and includes a program for auto-updating. The
40 scanner is multithreaded, written in C, and POSIX compliant.
41
42 %description -l pl
43 Clam Antivirus jest potê¿nym skanerem antywirusowym dla systemów
44 uniksowych. Wspiera on AMaViSa, skompresowane pliki, u¿ywa bazy
45 wirusów z OpenAntivirus.org, i posiada system automatycznej
46 aktualizacji. Skaner jest wielow±tkowy, napisany w C i zgodny z
47 POSIXem.
48
49 %package libs
50 Summary:        Shared libraries for clamav
51 Summary(pl):    Biblioteki dzielone clamav
52 Group:          Libraries
53
54 %description libs
55 Shared libraries for clamav.
56
57 %description libs -l pl
58 Biblioteki dzielone clamav.
59
60 %package devel
61 Summary:        clamav - Development header files and libraries
62 Summary(pl):    clamav - Pliki nag³ówkowe i biblioteki dla programistów
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65
66 %description devel
67 This package contains the development header files and libraries
68 necessary to develop clamav client applications.
69
70 %description devel -l pl
71 Pliki nag³ówkowe i biblioteki konieczne do kompilacji aplikacji
72 klienckich clamav.
73
74 %package static
75 Summary:        clamav static libraris
76 Summary(pl):    Biblioteki statyczne clamav
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 clamav static libraries.
82
83 %description static -l pl
84 Biblioteki statyczne clamav.
85
86 %package database
87 Summary:        Virus database for clamav
88 Summary(pl):    Bazy wirusów dla clamav
89 Group:          Applications
90 Version:        %{version}.%{database_version}
91 PreReq:         %{name}
92
93 %description database
94 Virus database for clamav (updated %{database_version}).
95
96 %description database -l pl
97 Bazy wirusów dla clamav (aktualizowana %{database_version}).
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__automake}
108 %configure \
109         --disable-clamav \
110         --with-dbdir=/var/lib/%{name}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{rc.d/init.d,sysconfig,logrotate.d} \
116         $RPM_BUILD_ROOT{%{_sysconfdir}/cron.d,%{_var}/log}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/cron.d/%{name}
122 5 * * * *       root    %{_sbindir}/clamav-cron-updatedb
123 EOF
124
125
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/clamd
127 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/clamd
128 install %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}/clamav-cron-updatedb
129 install etc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/
130 install %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
131 install %{SOURCE6} $RPM_BUILD_ROOT/var/lib/%{name}/
132 install %{SOURCE7} $RPM_BUILD_ROOT/var/lib/%{name}/
133 install %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}
134
135 # NOTE: clamd uses sane rights to it's clamd.pid file
136 # So better keep it dir
137 # If it is fixed use of dir will be unecesary
138 install -d $RPM_BUILD_ROOT%{_var}/run/%{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %triggerin -- amavis-ng
144 AMAVIS=$(/usr/bin/getgid amavis)
145 RESULT=$?
146 if [ $RESULT -eq 0 ]; then
147         /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
148         echo "adding clamav to amavis group GID=$AMAVIS"
149 fi
150
151 %triggerin -- amavisd-new
152 AMAVIS=$(/usr/bin/getgid amavis)
153 RESULT=$?
154 if [ $RESULT -eq 0 ]; then
155         /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
156         echo "adding clamav to amavis group GID=$AMAVIS"
157 fi
158
159 %triggerin -- amavisd
160 AMAVIS=$(/usr/bin/getgid amavis)
161 RESULT=$?
162 if [ $RESULT -eq 0 ]; then
163         /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
164         echo "adding clamav to amavis group GID=$AMAVIS"
165 fi
166
167
168 %pre 
169 if [ -n "`getgid clamav`" ]; then
170         if [ "`getgid clamav`" != "43" ]; then
171                 echo "Warning: group clamav doesn't have gid=43. Correct this before installing clamav" 1>&2
172                 exit 1
173         fi
174 else
175         echo "Adding group clamav GID=43"
176         /usr/sbin/groupadd -g 43 -r -f clamav
177 fi
178 if [ -n "`id -u clamav 2>/dev/null`" ]; then
179         if [ "`id -u clamav`" != "43" ]; then
180                 echo "Warning: user clamav doesn't have uid=43. Correct this before installing clamav" 1>&2
181                 exit 1
182         fi
183 else
184         echo "Adding user clamav UID=43"
185         /usr/sbin/useradd -u 43 -r -d /tmp -s /bin/false -c "Clam Anti Virus Checker" -g clamav clamav 1>&2
186 fi
187
188 %post
189 /sbin/chkconfig --add clamd
190 if [ -f /var/lock/subsys/clamd ]; then
191         /etc/rc.d/init.d/clamd restart >&2
192 else
193         echo "Run \"/etc/rc.d/init.d/clamd start\" to start Clam Antivirus daemon." >&2
194 fi
195
196 %preun
197 if [ "$1" = "0" ]; then
198         if [ -f /var/lock/subsys/clamd ]; then
199                 /etc/rc.d/init.d/clamd stop
200         fi
201         /sbin/chkconfig --del clamd
202 fi
203
204 %postun
205 if [ "$1" = "0" ]; then
206         echo "Removing user clamav"
207         /usr/sbin/userdel clamav
208         echo "Removing group clamav"
209         /usr/sbin/groupdel clamav
210 fi
211
212 %post   libs -p /sbin/ldconfig
213 %postun libs -p /sbin/ldconfig
214
215 %post   database -p %{_sbindir}/%{name}-post-updatedb
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS ChangeLog FAQ NEWS README TODO docs/html/
220 %attr(755,root,root) %{_bindir}/*
221 %attr(755,root,root) %{_sbindir}/*
222 %attr(755,clamav,root) %dir /var/lib/%{name}
223 #%%attr(640,clamav,root) %ghost %{_var}/log/%{name}.log
224 %attr(750,clamav,clamav) %dir %{_var}/run/%{name}
225
226 %attr(640,root,root) %{_sysconfdir}/cron.d/%{name}
227 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/clamav.conf
228 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/freshclam.conf
229
230 %attr(754,root,root) /etc/rc.d/init.d/clamd
231 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/clamd
232 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/clamav
233 %{_mandir}/man?/*
234
235 %files libs
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/lib*.so.*.*
238
239 %files devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/lib*.so
242 %{_libdir}/lib*.la
243 %{_includedir}/*.h
244
245 %files static
246 %defattr(644,root,root,755)
247 %{_libdir}/*.a
248
249 %files database
250 %defattr(644,root,root,755)
251 %attr(644,clamav,root) %verify(not md5 size mtime) /var/lib/%{name}/*.cvd
This page took 0.047834 seconds and 3 git commands to generate.