]> git.pld-linux.org Git - packages/cjs.git/blob - cjs.spec
- up to 4.2.0
[packages/cjs.git] / cjs.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Javascript Bindings for Cinnamon
6 Name:           cjs
7 Version:        4.2.0
8 Release:        1
9 Group:          Libraries
10 # The following files contain code from Mozilla which
11 # is triple licensed under MPL1.1/LGPLv2+/GPLv2+:
12 # The console module (modules/console.c)
13 # Stack printer (gjs/stack.c)
14 License:        MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
15 Source0:        https://github.com/linuxmint/cjs/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  af9e59943aba0974359e76202abd89b8
17 URL:            http://cinnamon.linuxmint.com/
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake >= 1.7.2
20 BuildRequires:  cairo-gobject-devel
21 BuildRequires:  gnome-common
22 BuildRequires:  gobject-introspection-devel >= 1.38.0
23 BuildRequires:  gtk+3-devel
24 BuildRequires:  intltool
25 BuildRequires:  libtool
26 BuildRequires:  mozjs52-devel
27 BuildRequires:  pkgconfig >= 0.14.0
28 BuildRequires:  readline-devel
29 BuildRequires:  sed >= 4.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Cjs allows using Cinnamon libraries from Javascript. It's based on the
34 Spidermonkey Javascript engine from Mozilla and the GObject
35 introspection framework.
36
37 %package devel
38 Summary:        Development package for %{name}
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Files for development with %{name}.
44
45 %package tests
46 Summary:        Tests for the cjs package
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description tests
51 The cjs-tests package contains tests that can be used to verify the
52 functionality of the installed cjs package.
53
54 %prep
55 %setup -q
56 sed -i -e 's@{ACLOCAL_FLAGS}@{ACLOCAL_FLAGS} -I m4@g' Makefile.am
57 echo "AC_CONFIG_MACRO_DIR([m4])" >> configure.ac
58
59 %build
60 NOCONFIGURE=1 ./autogen.sh
61 %configure \
62         --disable-silent-rules \
63         --disable-static \
64         --enable-installed-tests \
65
66 %{__make}
67
68 %if %{with tests}
69 %{__make} check
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjs.la
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/cjs/lib*.la
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc COPYING COPYING.LGPL NEWS README
89 %attr(755,root,root) %{_bindir}/cjs
90 %attr(755,root,root) %{_bindir}/cjs-console
91 %attr(755,root,root) %{_libdir}/libcjs.so.*.*.*
92 %ghost %{_libdir}/libcjs.so.0
93 %dir %{_libdir}/cjs
94 %dir %{_libdir}/cjs/girepository-1.0
95 %{_libdir}/cjs/girepository-1.0/CjsPrivate-1.0.typelib
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc examples/*
100 %{_includedir}/cjs-1.0
101 %{_libdir}/libcjs.so
102 %{_pkgconfigdir}/cjs-1.0.pc
103 %attr(755,root,root) %{_libdir}/cjs/libgimarshallingtests.so
104 %attr(755,root,root) %{_libdir}/cjs/libregress.so
105 %attr(755,root,root) %{_libdir}/cjs/libwarnlib.so
106
107 %files tests
108 %defattr(644,root,root,755)
109 %dir %{_libexecdir}/cjs
110 %{_libexecdir}/cjs/installed-tests
111 %{_datadir}/installed-tests
This page took 0.124889 seconds and 3 git commands to generate.