]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- BR: ffmpeg-devel
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define snap    20061125
5 Summary:        Cinelerra - capturing, editing and production of audio/video material
6 Summary(pl):    Cinelerra - nagrywanie, obróbka i produkcja materia³u audio/video
7 Name:           cinelerra-cv
8 Version:        2.1
9 Release:        0.%{snap}.3
10 License:        GPL
11 Group:          X11/Applications
12 # svn://svn.skolelinux.org/cinelerra/trunk/hvirtual
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  89a039be86acab89ed392ce987dea2c8
15 Patch0:         %{name}-build.patch
16 URL:            http://cvs.cinelerra.org/
17 BuildRequires:  OpenEXR-devel >= 1.2.1
18 #BuildRequires: OpenGL-devel >= 2.0
19 BuildRequires:  alsa-lib-devel >= 1.0.8
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  esound-devel
23 BuildRequires:  ffmpeg-devel
24 BuildRequires:  freetype-devel >= 2.1.4
25 BuildRequires:  gettext-devel
26 BuildRequires:  lame-libs-devel >= 3.93.1
27 BuildRequires:  libavc1394-devel >= 0.5.1
28 BuildRequires:  libiec61883-devel >= 1.0.0
29 #BuildRequires: libmpeg3-devel >= 1.7
30 BuildRequires:  libraw1394-devel >= 1.2.0
31 BuildRequires:  libsndfile-devel >= 1.0.11
32 BuildRequires:  libstdc++-devel >= 5:3.2.2
33 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
34 BuildRequires:  libtiff-devel >= 3.5.7
35 BuildRequires:  libtool
36 BuildRequires:  libuuid-devel
37 %ifarch %{ix86}
38 BuildRequires:  nasm
39 %endif
40 #BuildRequires: quicktime4linux-devel >= 2.2
41 BuildRequires:  xorg-lib-libX11-devel
42 BuildRequires:  xorg-lib-libXext-devel
43 BuildRequires:  xorg-lib-libXv-devel
44 BuildRequires:  xorg-lib-libXxf86vm-devel
45 Requires:       OpenEXR-devel >= 1.2.1
46 Requires:       alsa-lib >= 1.0.8
47 Requires:       freetype >= 2.1.4
48 Requires:       libavc1394 >= 0.5.1
49 Requires:       libiec61883 >= 1.0.0
50 #Requires:      libmpeg3 >= 1.7
51 Requires:       libraw1394 >= 1.2.0
52 Requires:       libsndfile >= 1.0.11
53 Requires:       libtheora >= 1.0-0.alpha4
54 #Requires:      quicktime4linux >= 2.2
55 Obsoletes:      bcast
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _noautostrip    .*/microtheme.plugin
59
60 %description
61 There are two types of moviegoers: producers who create new content,
62 going back over their content at future points for further refinement,
63 and consumers who want to acquire the content and watch it. Cinelerra
64 is not intended for consumers. Cinelerra has many features for
65 uncompressed content, high resolution processing, and compositing,
66 with very few shortcuts. Producers need these features because of the
67 need to retouch many generations of footage with alterations to the
68 format, which makes Cinelerra very complex.
69
70 Cinelerra was meant to be a Broadcast 2000 replacement.
71
72 This is Community Version.
73
74 %description -l pl
75 S± dwa rodzaje u¿ytkowników zajmuj±cych siê filmami: producenci
76 tworz±cy nowe filmy, wracaj±cy do nich w przysz³o¶ci w celu dalszego
77 wyg³adzenia, oraz konsumenci, którzy chc± tylko zdobyæ film i go
78 obejrzeæ. Cinelerra nie jest dla konsumentów. Program ma wiele
79 mo¿liwo¶ci do edycji nieskompresowanej zawarto¶ci, obróbki w wysokiej
80 rozdzielczo¶ci oraz monta¿u, z bardzo ma³± liczb± skrótów. Producenci
81 potrzebuj± tych mo¿liwo¶ci ze wzglêdu na konieczno¶æ retuszowania oraz
82 modyfikacji formatu, co czyni program bardzo z³o¿onym.
83
84 Cinelerra by³a tworzona z my¶l± o zast±pieniu programu Broadcast 2000.
85
86 Wersja Spo³eczno¶ciowa.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 rm -f m4/*.m4 *.m4
94 touch config.rpath
95 %{__gettextize}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoheader}
99 %{__automake}
100 %{__autoconf}
101
102 %configure \
103 %ifarch ppc
104         --enable-altivec \
105 %endif
106 %ifarch %{ix86} %{x8664}
107         --enable-mmx \
108         --enable-3dnow \
109 %endif
110         --enable-freetype2 \
111         --with-external-ffmpeg \
112         --with-alsa-prefix=%{_prefix} \
113         --with-fontsdir=%{_fontsdir} \
114         --with-plugindir=%{_libdir}/cinelerra
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
125
126 %find_lang cinelerra
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f cinelerra.lang
135 %defattr(644,root,root,755)
136 %doc doc/* README* TODO
137 %attr(755,root,root) %{_bindir}/*
138 %dir %{_libdir}/cinelerra
139 %attr(755,root,root) %{_libdir}/cinelerra/*.so
140 %{_libdir}/cinelerra/*.la
141 %{_libdir}/cinelerra/shapewipe
142 %{_libdir}/cinelerra/fonts
143 %attr(755,root,root) %{_libdir}/lib*.so.*
144 %{_desktopdir}/*.desktop
145 %{_pixmapsdir}/*.*
This page took 0.047069 seconds and 3 git commands to generate.