]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 30.0.1599.66; builds without nacl and system libusb
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_with     system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_snappy   # system snappy
31 %bcond_without  system_speex    # system speex
32 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
34 %bcond_with             system_v8               # system v8
35 %bcond_without  system_libvpx   # system libvpx
36 %bcond_without  system_yasm             # system yasm
37 %bcond_without  system_zlib             # system zlib
38 %bcond_without  tcmalloc                # use tcmalloc
39 %bcond_without  verbose                 # verbose build (V=1)
40
41 %ifarch %{ix86}
42 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43 %undefine       with_system_mesa
44 %endif
45
46 # TODO
47 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48 # - use_system_skia
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_stlport (android specific)
51 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53 # NOTES:
54 # - mute BEEP mixer if you do not want to hear horrible system bell when
55 #   pressing home/end in url bar or more ^F search results on page.
56 # - space considerations:
57 #   - unpacked sources: ~490MiB
58 #   - built code: ~1.4GiB (x86_64/i686)
59 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60 # - to look for new tarball, use update-source.sh script
61
62 %define         branch          30.0.1599
63 %define         basever         66
64 #define         patchver        76
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 %if "%{?patchver}" != ""
69 Version:        %{branch}.%{patchver}
70 %else
71 Version:        %{branch}.%{basever}
72 %endif
73 Release:        1
74 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
77 # Source0-md5:  48e0806c4eab5dcc428fd59a826d0498
78 %if "%{?patchver}" != ""
79 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80 # Patch0-md5:   ffbb56731a752ce52caaf0448dd6e073
81 %endif
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 Patch1:         plugin-searchdirs.patch
91 Patch4:         path-libpdf.patch
92 Patch7:         dlopen_sonamed_gl.patch
93 Patch8:         chromium_useragent.patch.in
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch12:        system-ffmpeg.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch29:        system-icu.patch
107 URL:            http://www.chromium.org/Home
108 %{?with_gconf:BuildRequires:    GConf2-devel}
109 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
110 BuildRequires:  Mesa-libGLES-devel >= 9.1
111 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
112 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
113 BuildRequires:  alsa-lib-devel
114 BuildRequires:  atk-devel
115 BuildRequires:  bison
116 BuildRequires:  bzip2-devel
117 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
118 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
119 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
120 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
121 %{?with_cups:BuildRequires:     cups-devel}
122 BuildRequires:  elfutils-devel
123 BuildRequires:  expat-devel
124 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
125 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
126 BuildRequires:  fontconfig-devel
127 BuildRequires:  glib2-devel
128 BuildRequires:  gperf
129 %{?with_gps:BuildRequires:      gpsd-devel}
130 BuildRequires:  gtest-devel
131 BuildRequires:  gtk+2-devel
132 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
133 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
134 %{?with_kerberos:BuildRequires: heimdal-devel}
135 BuildRequires:  hicolor-icon-theme
136 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
137 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
138 BuildRequires:  libevent-devel
139 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
140 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
141 BuildRequires:  libicu-devel >= 4.6
142 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
143 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
144 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
145 BuildRequires:  libpng-devel
146 %{?with_selinux:BuildRequires:  libselinux-devel}
147 BuildRequires:  libstdc++-devel
148 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
149 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
150 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
151 BuildRequires:  libxml2-devel
152 BuildRequires:  libxslt-devel
153 BuildRequires:  man-db
154 %{?with_system_minizip:BuildRequires:   minizip-devel}
155 BuildRequires:  nspr-devel
156 BuildRequires:  nss-devel >= 1:3.12.3
157 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
158 BuildRequires:  pam-devel
159 BuildRequires:  pango-devel
160 BuildRequires:  pciutils-devel
161 BuildRequires:  perl-JSON
162 BuildRequires:  perl-modules
163 BuildRequires:  pkgconfig
164 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
165 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
166 BuildRequires:  python
167 #BuildRequires: python-gyp >= 1-%{gyp_rev}
168 BuildRequires:  python-jinja2
169 BuildRequires:  python-modules
170 BuildRequires:  python-ply
171 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
172 BuildRequires:  rpm >= 4.4.9-56
173 BuildRequires:  rpmbuild(macros) >= 1.453
174 %{?with_system_snappy:BuildRequires:    snappy-devel}
175 BuildRequires:  speech-dispatcher-devel >= 0.8
176 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
177 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
178 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
179 BuildRequires:  tar >= 1:1.22
180 BuildRequires:  udev-devel
181 BuildRequires:  usbutils
182 BuildRequires:  util-linux
183 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
184 BuildRequires:  which
185 BuildRequires:  xorg-lib-libXScrnSaver-devel
186 BuildRequires:  xorg-lib-libXtst-devel
187 BuildRequires:  xz
188 %{?with_system_yasm:BuildRequires:      yasm}
189 %{?with_system_zlib:BuildRequires:      zlib-devel}
190 Requires:       browser-plugins >= 2.0
191 Requires:       desktop-file-utils
192 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
193 # crashes if no fontconfig font present
194 Requires:       fonts-Type1-urw
195 Requires:       hicolor-icon-theme
196 Requires:       libevent >= 2.0.21
197 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
198 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
199 Requires:       lsb-release
200 %{?with_system_re2:Requires:    re2 >= 20130115-2}
201 Requires:       shared-mime-info
202 %{?with_system_sqlite:Requires: sqlite3(icu)}
203 Requires:       xdg-utils >= 1.0.2-4
204 Requires:       xorg-lib-libX11 >= 1.4.99.1
205 Provides:       wwwbrowser
206 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
207 Obsoletes:      chromium-browser-inspector < 15.0.863.0
208 ExclusiveArch:  %{ix86} %{x8664} arm
209 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
210
211 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
212 # Note: these are for PLD Linux use ONLY.
213 # For your own distribution, please get your own set of keys.
214 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
215 %define         google_default_client_id 724288223830.apps.googleusercontent.com
216 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
217
218 %define         find_lang       sh find-lang.sh %{buildroot}
219
220 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
221 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
222
223 %if %{without debuginfo}
224 %define         _enable_debug_packages  0
225 %endif
226
227 %description
228 Chromium is an open-source browser project that aims to build a safer,
229 faster, and more stable way for all Internet users to experience the
230 web.
231
232 Chromium serves as a base for Google Chrome, which is Chromium
233 rebranded (name and logo) with very few additions such as usage
234 tracking and an auto-updater system.
235
236 %package l10n
237 Summary:        chromium-browser language packages
238 Group:          I18n
239 Requires:       %{name} = %{version}-%{release}
240 %if "%{_rpmversion}" >= "5"
241 BuildArch:      noarch
242 %endif
243
244 %description l10n
245 Chromium is an open-source browser project that aims to build a safer,
246 faster, and more stable way for all Internet users to experience the
247 web.
248
249 This package contains language packages for 50 languages:
250
251 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
252 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
253 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
254 zh-TW
255
256 %prep
257 %setup -qc
258 %if "%{?patchver}" != ""
259 cd %{name}-%{branch}.%{basever}
260 %patch0 -p1
261 cd ..
262 %endif
263 mv %{name}-%{branch}.%{basever}/* .
264
265 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
266 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
267 . ./chrome/VERSION
268 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
269 test "$chrome" = %{version}
270
271 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
272 test "$gyp_rev" = %{gyp_rev} || :
273
274 . ./v8.sh
275 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
276
277 # add chromium and pld to useragent
278 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
279 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
280         -e 's/@BUILD_DIST_NAME@/PLD/g' \
281         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
282         < %{PATCH8} | %{__patch} -p1
283
284 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
285 ln -s %{SOURCE7} .
286
287 %patch1 -p1
288 %patch4 -p3
289 %patch7 -p1
290 %patch10 -p1
291 %patch15 -p2
292 %{!?with_libjpegturbo:%patch11 -p0}
293 %patch12 -p1
294 %patch16 -p1
295 %patch28 -p1
296 %patch25 -p2
297 %patch18 -p1
298 %patch24 -p2
299 %patch26 -p2
300 %patch29 -p0
301
302 exit 0
303 sh -x clean-source.sh \
304         %{!?with_nacl:nacl=0} \
305         %{!?with_system_libvpx:libvpx=0} \
306         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
307         %{!?with_system_mesa:mesa=0} \
308         %{!?with_system_protobuf:protobuf=0} \
309         %{!?with_system_re2:re2=0} \
310         %{!?with_system_snappy:snappy=0} \
311         %{!?with_system_sqlite:sqlite=0} \
312         %{!?with_system_v8:v8=0} \
313         %{!?with_system_zlib:zlib=0} \
314         %{nil}
315
316 %build
317 %if %{with nacl}
318 rm -rf native_client/toolchain/linux_x86_newlib
319 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
320 # Make symlinks for NaCL
321 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
322
323 cd native_client/toolchain/linux_x86_newlib
324 ln -s x86_64-nacl/bin bin
325 cd x86_64-nacl/bin
326 __cc='%{__cc}'
327 if [ "${__cc#ccache}" != "$__cc" ]; then
328         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
329         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
330         %{__sed} -i -e '1i#!/bin/sh' gcc g++
331         chmod +x gcc g++
332 else
333         ln -s %{_bindir}/x86_64-nacl-gcc gcc
334         ln -s %{_bindir}/x86_64-nacl-g++ g++
335 fi
336 ln -s gcc x86_64-nacl-gcc
337 ln -s g++ x86_64-nacl-g++
338 ln -s %{_bindir}/x86_64-nacl-ar .
339 ln -s %{_bindir}/x86_64-nacl-ar ar
340 ln -s %{_bindir}/x86_64-nacl-as as
341 ln -s %{_bindir}/x86_64-nacl-ranlib .
342 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
343 ln -s %{_bindir}/x86_64-nacl-strip .
344 ln -s %{_bindir}/x86_64-nacl-strip strip
345 ln -s %{_bindir}/x86_64-nacl-objcopy .
346 ln -s %{_prefix}/x86_64-nacl/lib ../lib
347 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
348 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
349 cd ../../../../..
350 fi
351 %endif
352
353 flags="
354 %ifarch %{ix86}
355         -Dtarget_arch=ia32 \
356 %endif
357 %ifarch %{x8664}
358         -Dtarget_arch=x64 \
359 %endif
360 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
361         -Dno_strict_aliasing=1 -Dgcc_version=44 \
362 %endif
363 %if %{with sandboxing}
364         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
365         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
366 %endif
367         %{!?debug:-Dwerror=} \
368         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
369         %{?with_shared_libs:-Dlibrary=shared_library} \
370         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
371         -Dinclude_tests=0 \
372 %if %{with nacl}
373         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
374         -Ddisable_glibc_untar=1 \
375         -Ddisable_newlib_untar=1 \
376         -Ddisable_glibc=1 \
377         -Ddisable_pnacl=1 \
378         -Dbuild_pnacl_newlib=0 \
379 %else
380         -Ddisable_pnacl_untar=1 \
381         -Ddisable_nacl=1 \
382 %endif
383         %{!?with_sse2:-Ddisable_sse2=1} \
384         %{?with_selinux:-Dselinux=1} \
385         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
386         -Dlinux_link_libpci=1 \
387         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
388         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
389         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
390         -Dlinux_use_gold_binary=0 \
391         -Dlinux_use_gold_flags=0 \
392         -Dlogging_like_official_build=1 \
393         -Dgoogle_api_key=%{google_api_key} \
394         -Dgoogle_default_client_id=%{google_default_client_id} \
395         -Dgoogle_default_client_secret=%{google_default_client_secret} \
396         %{gyp_with cups} \
397         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
398         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
399         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
400         %{gyp_with pulseaudio} \
401         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
402         %{gyp_with system_flac} \
403         %{gyp_with system_harfbuzz} \
404         %{gyp_with system_jsoncpp} \
405         %{gyp_with system_libexif} \
406         %{gyp_with system_libmtp} \
407         %{gyp_with system_libsrtp} \
408         %{gyp_with system_libusb} \
409         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
410         %{gyp_with system_libwebp} \
411         %{gyp_with system_libxnvctrl} \
412         %{gyp_with system_mesa} \
413         %{gyp_with system_minizip} \
414         %{gyp_with system_opus} \
415         %{gyp_with system_protobuf} \
416         %{gyp_with system_re2} \
417         %{gyp_with system_snappy} \
418         %{gyp_with system_speex} \
419         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
420         %{gyp_with system_v8} \
421         %{gyp_with system_yasm} \
422         %{gyp_with system_zlib} \
423         -Duse_system_bzip2=1 \
424         -Duse_system_expat=1 \
425         -Duse_system_icu=1 \
426         -Duse_system_libevent=1 \
427         -Duse_system_libjpeg=1 \
428         -Duse_system_libpng=1 \
429         -Duse_system_libxml=1 \
430         -Duse_system_libxslt=1 \
431         -Duse_system_nspr=1 \
432         -Duse_system_xdg_utils=1 \
433 "
434
435 build/linux/unbundle/replace_gyp_files.py $flags
436
437 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
438 test -e Makefile || \
439         CC="%{__cc}" \
440         CXX="%{__cxx}" \
441         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
442         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
443         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
444         CC_host="%{__cc}" \
445         CXX_host="%{__cxx}" \
446         LD_host="%{__cxx}" \
447 %{__python} build/gyp_chromium \
448         --format=make \
449         --depth=. \
450         build/all.gyp \
451         $flags
452
453 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
454 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
455         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
456         %{?with_verbose:V=1} \
457         CC.host="%{__cc}" \
458         CXX.host="%{__cxx}" \
459         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
460
461 cd out/%{!?debug:Release}%{?debug:Debug}
462 MANWIDTH=80 man ./chrome.1 > man.out
463 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
464
465 %install
466 rm -rf $RPM_BUILD_ROOT
467 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
468         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
469         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
470
471 cd out/%{!?debug:Release}%{?debug:Debug}
472 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
473 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
474 %{__sed} -i -e '
475         s,@libdir@,%{_libdir}/%{name},
476
477         /@OPTIONS@/ {
478                 r options.txt
479                 d
480         }
481 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
482 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
483 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
484 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
485 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
486 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
487 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
488 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
489 %if %{without system_ffmpeg}
490 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
491 %endif
492 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
493 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
494
495 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
496
497 %if %{with nacl}
498 # Install Native Client files on platforms that support it.
499 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
500 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
501 %ifarch %{x8664}
502 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
503 %endif
504 %ifarch %{ix86}
505 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
506 %endif
507 %endif
508
509 cd -
510
511 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
512         size=${icon##*/product_logo_}
513         size=${size%.png}
514
515         # this will skip non-numeric (22_mono_invert, 22_mono)
516         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
517         test -d "$dir" || continue
518
519         install -d $RPM_BUILD_ROOT$dir
520         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
521 done
522
523 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
524 # http://code.google.com/p/chromium/issues/detail?id=24507
525 gecko-mediaplayer*.so
526 EOF
527
528 # find locales
529 %find_lang %{name}.lang
530 # always package en-US
531 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
532
533 %clean
534 rm -rf $RPM_BUILD_ROOT
535
536 %pretrans
537 for d in locales resources; do
538         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
539                 install -d %{_datadir}/%{name}
540                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
541         fi
542 done
543 exit 0
544
545 %post
546 %update_icon_cache hicolor
547 %update_desktop_database
548 %update_browser_plugins
549
550 %postun
551 if [ "$1" = 0 ]; then
552         %update_icon_cache hicolor
553         %update_browser_plugins
554 fi
555
556 %files
557 %defattr(644,root,root,755)
558 %doc AUTHORS LICENSE
559 %{_browserpluginsconfdir}/browsers.d/%{name}.*
560 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
561 %dir %{_sysconfdir}/%{name}
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
564 %attr(755,root,root) %{_bindir}/%{name}
565 %{_mandir}/man1/%{name}.1*
566 %{_desktopdir}/*.desktop
567 %{_iconsdir}/hicolor/*/apps/%{name}.png
568 %dir %{_libdir}/%{name}
569 %{_libdir}/%{name}/chrome*.pak
570 %{_libdir}/%{name}/content_resources.pak
571 %{_libdir}/%{name}/resources.pak
572 %{_libdir}/%{name}/locales
573 %{_libdir}/%{name}/resources
574
575 %dir %{_datadir}/%{name}
576 %dir %{_datadir}/%{name}/locales
577 %{_datadir}/%{name}/locales/en-US.pak
578 %dir %{_datadir}/%{name}/resources
579 %{_datadir}/%{name}/resources/inspector
580
581 %dir %{_libdir}/%{name}/plugins
582 %attr(755,root,root) %{_libdir}/%{name}/%{name}
583 # These unique permissions are intentional and necessary for the sandboxing
584 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
585
586 # ffmpeg libs
587 %if %{without system_ffmpeg}
588 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
589 %endif
590
591 %if %{with nacl}
592 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
593 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
594 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
595 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
596 %endif
597
598 %files l10n -f %{name}.lang
599 %defattr(644,root,root,755)
This page took 0.076288 seconds and 4 git commands to generate.