]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 28.0.1500.20
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 %define         branch          28.0.1500
62 %define         basever         20
63 #define         patchver        70
64 %define         gyp_rev 1014
65 Summary:        A WebKit powered web browser
66 Name:           chromium-browser
67 %if "%{?patchver}" != ""
68 Version:        %{branch}.%{patchver}
69 %else
70 Version:        %{branch}.%{basever}
71 %endif
72 Release:        0.16
73 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
76 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 Patch1:         plugin-searchdirs.patch
90 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
91 Patch4:         path-libpdf.patch
92 Patch6:         get-webkit_revision.patch
93 Patch7:         dlopen_sonamed_gl.patch
94 Patch8:         chromium_useragent.patch.in
95 Patch10:        system-libxnvctrl.patch
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch12:        system-ffmpeg.patch
100 Patch15:        nacl-build-irt.patch
101 Patch16:        nacl-linkingfix.patch
102 Patch18:        nacl-no-untar.patch
103 Patch24:        nacl-verbose.patch
104 Patch25:        gnome3-volume-control.patch
105 Patch26:        master-prefs-path.patch
106 Patch28:        system-mesa.patch
107 Patch31:        sync-session-name.patch
108 URL:            http://www.chromium.org/Home
109 %{?with_gconf:BuildRequires:    GConf2-devel}
110 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
111 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
113 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
114 BuildRequires:  alsa-lib-devel
115 BuildRequires:  atk-devel
116 BuildRequires:  bison
117 BuildRequires:  bzip2-devel
118 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
119 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
122 %{?with_cups:BuildRequires:     cups-devel}
123 BuildRequires:  elfutils-devel
124 BuildRequires:  expat-devel
125 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
126 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
127 BuildRequires:  fontconfig-devel
128 BuildRequires:  glib2-devel
129 BuildRequires:  gperf
130 %{?with_gps:BuildRequires:      gpsd-devel}
131 BuildRequires:  gtest-devel
132 BuildRequires:  gtk+2-devel
133 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
134 %{?with_kerberos:BuildRequires: heimdal-devel}
135 BuildRequires:  hicolor-icon-theme
136 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
137 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
138 BuildRequires:  libevent-devel
139 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
140 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
141 BuildRequires:  libicu-devel >= 4.6
142 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
143 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
144 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
145 BuildRequires:  libpng-devel
146 %{?with_selinux:BuildRequires:  libselinux-devel}
147 BuildRequires:  libstdc++-devel
148 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
149 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
150 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
151 BuildRequires:  libxml2-devel
152 BuildRequires:  libxslt-devel
153 BuildRequires:  man-db
154 %{?with_system_minizip:BuildRequires:   minizip-devel}
155 BuildRequires:  nspr-devel
156 BuildRequires:  nss-devel >= 1:3.12.3
157 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
158 BuildRequires:  pam-devel
159 BuildRequires:  pango-devel
160 BuildRequires:  pciutils-devel
161 BuildRequires:  perl-modules
162 BuildRequires:  pkgconfig
163 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
164 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
165 BuildRequires:  python
166 #BuildRequires: python-gyp >= 1-%{gyp_rev}
167 BuildRequires:  python-modules
168 BuildRequires:  python-ply
169 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
170 BuildRequires:  rpm >= 4.4.9-56
171 BuildRequires:  rpmbuild(macros) >= 1.453
172 BuildRequires:  speech-dispatcher-devel >= 0.8
173 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
174 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
175 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
176 BuildRequires:  subversion
177 BuildRequires:  tar >= 1:1.22
178 BuildRequires:  udev-devel
179 BuildRequires:  usbutils
180 BuildRequires:  util-linux
181 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
182 BuildRequires:  which
183 BuildRequires:  xorg-lib-libXScrnSaver-devel
184 BuildRequires:  xz
185 %{?with_system_yasm:BuildRequires:      yasm}
186 %{?with_system_zlib:BuildRequires:      zlib-devel}
187 Requires:       browser-plugins >= 2.0
188 Requires:       desktop-file-utils
189 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
190 # crashes if no fontconfig font present
191 Requires:       fonts-Type1-urw
192 Requires:       hicolor-icon-theme
193 Requires:       libevent >= 2.0.21
194 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
195 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
196 Requires:       lsb-release
197 %{?with_system_re2:Requires:    re2 >= 20130115-2}
198 Requires:       shared-mime-info
199 %{?with_system_sqlite:Requires: sqlite3(icu)}
200 Requires:       xdg-utils >= 1.0.2-4
201 Requires:       xorg-lib-libX11 >= 1.4.99.1
202 Provides:       wwwbrowser
203 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
204 Obsoletes:      chromium-browser-inspector < 15.0.863.0
205 ExclusiveArch:  %{ix86} %{x8664} arm
206 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
207
208 %define         find_lang       sh find-lang.sh %{buildroot}
209
210 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
211 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
212
213 %if %{without debuginfo}
214 %define         _enable_debug_packages  0
215 %endif
216
217 %description
218 Chromium is an open-source browser project that aims to build a safer,
219 faster, and more stable way for all Internet users to experience the
220 web.
221
222 Chromium serves as a base for Google Chrome, which is Chromium
223 rebranded (name and logo) with very few additions such as usage
224 tracking and an auto-updater system.
225
226 %package l10n
227 Summary:        chromium-browser language packages
228 Group:          I18n
229 Requires:       %{name} = %{version}-%{release}
230 %if "%{_rpmversion}" >= "5"
231 BuildArch:      noarch
232 %endif
233
234 %description l10n
235 Chromium is an open-source browser project that aims to build a safer,
236 faster, and more stable way for all Internet users to experience the
237 web.
238
239 This package contains language packages for 50 languages:
240
241 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
242 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
243 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
244 zh-TW
245
246 %prep
247 %setup -qc
248 %if "%{?patchver}" != ""
249 cd %{name}-%{branch}.%{basever}
250 %patch0 -p1
251 cd ..
252 %endif
253 mv %{name}-%{branch}.%{basever}/* .
254
255 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
256 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
257 . ./chrome/VERSION
258 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
259 test "$chrome" = %{version}
260
261 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
262 test "$gyp_rev" = %{gyp_rev} || :
263
264 . ./v8.sh
265 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
266
267 # add chromium and pld to useragent
268 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
269 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
270         -e 's/@BUILD_DIST_NAME@/PLD/g' \
271         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
272         < %{PATCH8} | %{__patch} -p2
273
274 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
275 ln -s %{SOURCE7} .
276
277 %patch1 -p2
278 %patch3 -p2
279 %patch4 -p3
280 %patch6 -p2
281 %patch7 -p1
282 %patch10 -p1
283 %patch15 -p2
284 %{!?with_libjpegturbo:%patch11 -p0}
285 %patch12 -p1
286 %patch16 -p1
287 %patch28 -p1
288 %patch25 -p2
289 %patch18 -p2
290 %patch24 -p2
291 %patch26 -p2
292 %patch31 -p0
293
294 sh -x clean-source.sh \
295         %{!?with_nacl:nacl=0} \
296         %{!?with_system_libvpx:libvpx=0} \
297         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
298         %{!?with_system_mesa:mesa=0} \
299         %{!?with_system_protobuf:protobuf=0} \
300         %{!?with_system_re2:re2=0} \
301         %{!?with_system_sqlite:sqlite=0} \
302         %{!?with_system_v8:v8=0} \
303         %{!?with_system_zlib:zlib=0} \
304         %{nil}
305
306 %build
307 %if %{with nacl}
308 rm -rf native_client/toolchain/linux_x86_newlib
309 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
310 # Make symlinks for NaCL
311 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
312
313 cd native_client/toolchain/linux_x86_newlib
314 ln -s x86_64-nacl/bin bin
315 cd x86_64-nacl/bin
316 __cc='%{__cc}'
317 if [ "${__cc#ccache}" != "$__cc" ]; then
318         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
319         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
320         %{__sed} -i -e '1i#!/bin/sh' gcc g++
321         chmod +x gcc g++
322 else
323         ln -s %{_bindir}/x86_64-nacl-gcc gcc
324         ln -s %{_bindir}/x86_64-nacl-g++ g++
325 fi
326 ln -s gcc x86_64-nacl-gcc
327 ln -s g++ x86_64-nacl-g++
328 ln -s %{_bindir}/x86_64-nacl-ar .
329 ln -s %{_bindir}/x86_64-nacl-ar ar
330 ln -s %{_bindir}/x86_64-nacl-as as
331 ln -s %{_bindir}/x86_64-nacl-ranlib .
332 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
333 ln -s %{_bindir}/x86_64-nacl-strip .
334 ln -s %{_bindir}/x86_64-nacl-strip strip
335 ln -s %{_prefix}/x86_64-nacl/lib ../lib
336 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
337 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
338 cd ../../../../..
339 fi
340 %endif
341
342 flags="
343 %ifarch %{ix86}
344         -Dtarget_arch=ia32 \
345 %endif
346 %ifarch %{x8664}
347         -Dtarget_arch=x64 \
348 %endif
349 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
350         -Dno_strict_aliasing=1 -Dgcc_version=44 \
351 %endif
352 %if %{with sandboxing}
353         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
354         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
355 %endif
356         %{!?debug:-Dwerror=} \
357         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
358         %{?with_shared_libs:-Dlibrary=shared_library} \
359         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
360         -Dinclude_tests=0 \
361 %if %{with nacl}
362         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
363         -Ddisable_glibc_untar=1 \
364         -Ddisable_newlib_untar=1 \
365         -Ddisable_glibc=1 \
366         -Ddisable_pnacl=1 \
367         -Dbuild_pnacl_newlib=0 \
368 %else
369         -Ddisable_pnacl_untar=1 \
370         -Ddisable_nacl=1 \
371 %endif
372         %{!?with_sse2:-Ddisable_sse2=1} \
373         %{?with_selinux:-Dselinux=1} \
374         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
375         -Dlinux_link_libpci=1 \
376         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
377         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
378         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
379         -Dlinux_use_gold_binary=0 \
380         -Dlinux_use_gold_flags=0 \
381         %{gyp_with cups} \
382         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
383         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
384         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
385         %{gyp_with pulseaudio} \
386         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
387         %{gyp_with system_flac} \
388         %{gyp_with system_harfbuzz} \
389         %{gyp_with system_jsoncpp} \
390         %{gyp_with system_libexif} \
391         %{gyp_with system_libmtp} \
392         %{gyp_with system_libsrtp} \
393         %{gyp_with system_libusb} \
394         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
395         %{gyp_with system_libwebp} \
396         %{gyp_with system_libxnvctrl} \
397         %{gyp_with system_mesa} \
398         %{gyp_with system_minizip} \
399         %{gyp_with system_opus} \
400         %{gyp_with system_protobuf} \
401         %{gyp_with system_re2} \
402         %{gyp_with system_speex} \
403         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
404         %{gyp_with system_v8} \
405         %{gyp_with system_yasm} \
406         %{gyp_with system_zlib} \
407         -Duse_system_bzip2=1 \
408         -Duse_system_expat=1 \
409         -Duse_system_icu=1 \
410         -Duse_system_libevent=1 \
411         -Duse_system_libjpeg=1 \
412         -Duse_system_libpng=1 \
413         -Duse_system_libxml=1 \
414         -Duse_system_libxslt=1 \
415         -Duse_system_nspr=1 \
416         -Duse_system_xdg_utils=1 \
417 "
418
419 build/linux/unbundle/replace_gyp_files.py $flags
420
421 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
422 test -e Makefile || \
423         CC="%{__cc}" \
424         CXX="%{__cxx}" \
425         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
426         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
427         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
428         CC_host="%{__cc}" \
429         CXX_host="%{__cxx}" \
430         LD_host="%{__cxx}" \
431 %{__python} build/gyp_chromium \
432         --format=make \
433         --depth=. \
434         build/all.gyp \
435         $flags
436
437 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
438 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
439         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
440         %{?with_verbose:V=1} \
441         CC.host="%{__cc}" \
442         CXX.host="%{__cxx}" \
443         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
444
445 cd out/%{!?debug:Release}%{?debug:Debug}
446 MANWIDTH=80 man ./chrome.1 > man.out
447 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
452         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
453         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
454
455 cd out/%{!?debug:Release}%{?debug:Debug}
456 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
457 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
458 %{__sed} -i -e '
459         s,@libdir@,%{_libdir}/%{name},
460
461         /@OPTIONS@/ {
462                 r options.txt
463                 d
464         }
465 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
466 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
467 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
468 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
469 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
470 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
471 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
472 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
473 %if %{without system_ffmpeg}
474 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
475 %endif
476 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
477 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
478
479 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
480
481 %if %{with nacl}
482 # Install Native Client files on platforms that support it.
483 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
484 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
485 %ifarch %{x8664}
486 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
487 %endif
488 %ifarch %{ix86}
489 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
490 %endif
491 %endif
492
493 cd -
494
495 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
496         size=${icon##*/product_logo_}
497         size=${size%.png}
498
499         # this will skip non-numeric (22_mono_invert, 22_mono)
500         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
501         test -d "$dir" || continue
502
503         install -d $RPM_BUILD_ROOT$dir
504         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
505 done
506
507 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
508 # http://code.google.com/p/chromium/issues/detail?id=24507
509 gecko-mediaplayer*.so
510 EOF
511
512 # find locales
513 %find_lang %{name}.lang
514 # always package en-US
515 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
516
517 %clean
518 rm -rf $RPM_BUILD_ROOT
519
520 %pretrans
521 for d in locales resources; do
522         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
523                 install -d %{_datadir}/%{name}
524                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
525         fi
526 done
527 exit 0
528
529 %post
530 %update_icon_cache hicolor
531 %update_desktop_database
532 %update_browser_plugins
533
534 %postun
535 if [ "$1" = 0 ]; then
536         %update_icon_cache hicolor
537         %update_browser_plugins
538 fi
539
540 %files
541 %defattr(644,root,root,755)
542 %doc AUTHORS LICENSE
543 %{_browserpluginsconfdir}/browsers.d/%{name}.*
544 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
545 %dir %{_sysconfdir}/%{name}
546 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
547 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
548 %attr(755,root,root) %{_bindir}/%{name}
549 %{_mandir}/man1/%{name}.1*
550 %{_desktopdir}/*.desktop
551 %{_iconsdir}/hicolor/*/apps/%{name}.png
552 %dir %{_libdir}/%{name}
553 %{_libdir}/%{name}/chrome*.pak
554 %{_libdir}/%{name}/content_resources.pak
555 %{_libdir}/%{name}/resources.pak
556 %{_libdir}/%{name}/locales
557 %{_libdir}/%{name}/resources
558
559 %dir %{_datadir}/%{name}
560 %dir %{_datadir}/%{name}/locales
561 %{_datadir}/%{name}/locales/en-US.pak
562 %dir %{_datadir}/%{name}/resources
563 %{_datadir}/%{name}/resources/inspector
564
565 %dir %{_libdir}/%{name}/plugins
566 %attr(755,root,root) %{_libdir}/%{name}/%{name}
567 # These unique permissions are intentional and necessary for the sandboxing
568 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
569
570 # ffmpeg libs
571 %if %{without system_ffmpeg}
572 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
573 %endif
574
575 %if %{with nacl}
576 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
577 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
578 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
579 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
580 %endif
581
582 %files l10n -f %{name}.lang
583 %defattr(644,root,root,755)
This page took 0.093552 seconds and 4 git commands to generate.