]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 29.0.1547.76
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_with     system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_snappy   # system snappy
31 %bcond_without  system_speex    # system speex
32 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
34 %bcond_with             system_v8               # system v8
35 %bcond_without  system_libvpx   # system libvpx
36 %bcond_without  system_yasm             # system yasm
37 %bcond_without  system_zlib             # system zlib
38 %bcond_without  tcmalloc                # use tcmalloc
39 %bcond_without  verbose                 # verbose build (V=1)
40
41 %ifarch %{ix86}
42 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43 %undefine       with_system_mesa
44 %endif
45
46 # TODO
47 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48 # - use_system_skia
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_stlport (android specific)
51 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53 # NOTES:
54 # - mute BEEP mixer if you do not want to hear horrible system bell when
55 #   pressing home/end in url bar or more ^F search results on page.
56 # - space considerations:
57 #   - unpacked sources: ~490MiB
58 #   - built code: ~1.4GiB (x86_64/i686)
59 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60 # - to look for new tarball, use update-source.sh script
61
62 %define         branch          29.0.1547
63 %define         basever         57
64 %define         patchver        76
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 %if "%{?patchver}" != ""
69 Version:        %{branch}.%{patchver}
70 %else
71 Version:        %{branch}.%{basever}
72 %endif
73 Release:        1
74 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77 # Source0-md5:  fcdeb8cb650d64e326d4ae84ca491432
78 %if "%{?patchver}" != ""
79 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80 # Patch0-md5:   ffbb56731a752ce52caaf0448dd6e073
81 %endif
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 Patch1:         plugin-searchdirs.patch
91 Patch4:         path-libpdf.patch
92 Patch7:         dlopen_sonamed_gl.patch
93 Patch8:         chromium_useragent.patch.in
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch12:        system-ffmpeg.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 URL:            http://www.chromium.org/Home
107 %{?with_gconf:BuildRequires:    GConf2-devel}
108 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
109 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
110 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
111 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
112 BuildRequires:  alsa-lib-devel
113 BuildRequires:  perl-JSON
114 BuildRequires:  atk-devel
115 BuildRequires:  bison
116 BuildRequires:  bzip2-devel
117 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
118 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
119 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
120 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
121 %{?with_cups:BuildRequires:     cups-devel}
122 BuildRequires:  elfutils-devel
123 BuildRequires:  expat-devel
124 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
125 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
126 BuildRequires:  fontconfig-devel
127 BuildRequires:  glib2-devel
128 BuildRequires:  gperf
129 %{?with_gps:BuildRequires:      gpsd-devel}
130 BuildRequires:  gtest-devel
131 BuildRequires:  gtk+2-devel
132 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
133 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
134 %{?with_kerberos:BuildRequires: heimdal-devel}
135 BuildRequires:  hicolor-icon-theme
136 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
137 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
138 BuildRequires:  libevent-devel
139 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
140 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
141 BuildRequires:  libicu-devel >= 4.6
142 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
143 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
144 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
145 BuildRequires:  libpng-devel
146 %{?with_selinux:BuildRequires:  libselinux-devel}
147 BuildRequires:  libstdc++-devel
148 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
149 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
150 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
151 BuildRequires:  libxml2-devel
152 BuildRequires:  libxslt-devel
153 BuildRequires:  man-db
154 %{?with_system_minizip:BuildRequires:   minizip-devel}
155 BuildRequires:  nspr-devel
156 BuildRequires:  nss-devel >= 1:3.12.3
157 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
158 BuildRequires:  pam-devel
159 BuildRequires:  pango-devel
160 BuildRequires:  pciutils-devel
161 BuildRequires:  perl-modules
162 BuildRequires:  pkgconfig
163 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
164 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
165 BuildRequires:  python
166 #BuildRequires: python-gyp >= 1-%{gyp_rev}
167 BuildRequires:  python-modules
168 BuildRequires:  python-ply
169 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
170 BuildRequires:  rpm >= 4.4.9-56
171 BuildRequires:  rpmbuild(macros) >= 1.453
172 %{?with_system_snappy:BuildRequires:    snappy-devel}
173 BuildRequires:  speech-dispatcher-devel >= 0.8
174 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
175 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
176 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
177 BuildRequires:  subversion
178 BuildRequires:  tar >= 1:1.22
179 BuildRequires:  udev-devel
180 BuildRequires:  usbutils
181 BuildRequires:  util-linux
182 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
183 BuildRequires:  which
184 BuildRequires:  xorg-lib-libXScrnSaver-devel
185 BuildRequires:  xz
186 %{?with_system_yasm:BuildRequires:      yasm}
187 %{?with_system_zlib:BuildRequires:      zlib-devel}
188 Requires:       browser-plugins >= 2.0
189 Requires:       desktop-file-utils
190 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
191 # crashes if no fontconfig font present
192 Requires:       fonts-Type1-urw
193 Requires:       hicolor-icon-theme
194 Requires:       libevent >= 2.0.21
195 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
196 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
197 Requires:       lsb-release
198 %{?with_system_re2:Requires:    re2 >= 20130115-2}
199 Requires:       shared-mime-info
200 %{?with_system_sqlite:Requires: sqlite3(icu)}
201 Requires:       xdg-utils >= 1.0.2-4
202 Requires:       xorg-lib-libX11 >= 1.4.99.1
203 Provides:       wwwbrowser
204 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
205 Obsoletes:      chromium-browser-inspector < 15.0.863.0
206 ExclusiveArch:  %{ix86} %{x8664} arm
207 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
208
209 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
210 # Note: these are for PLD Linux use ONLY.
211 # For your own distribution, please get your own set of keys.
212 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
213 %define         google_default_client_id 724288223830.apps.googleusercontent.com
214 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
215
216 %define         find_lang       sh find-lang.sh %{buildroot}
217
218 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
219 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
220
221 %if %{without debuginfo}
222 %define         _enable_debug_packages  0
223 %endif
224
225 %description
226 Chromium is an open-source browser project that aims to build a safer,
227 faster, and more stable way for all Internet users to experience the
228 web.
229
230 Chromium serves as a base for Google Chrome, which is Chromium
231 rebranded (name and logo) with very few additions such as usage
232 tracking and an auto-updater system.
233
234 %package l10n
235 Summary:        chromium-browser language packages
236 Group:          I18n
237 Requires:       %{name} = %{version}-%{release}
238 %if "%{_rpmversion}" >= "5"
239 BuildArch:      noarch
240 %endif
241
242 %description l10n
243 Chromium is an open-source browser project that aims to build a safer,
244 faster, and more stable way for all Internet users to experience the
245 web.
246
247 This package contains language packages for 50 languages:
248
249 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
250 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
251 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
252 zh-TW
253
254 %prep
255 %setup -qc
256 %if "%{?patchver}" != ""
257 cd %{name}-%{branch}.%{basever}
258 %patch0 -p1
259 cd ..
260 %endif
261 mv %{name}-%{branch}.%{basever}/* .
262
263 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
264 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
265 . ./chrome/VERSION
266 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
267 test "$chrome" = %{version}
268
269 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
270 test "$gyp_rev" = %{gyp_rev} || :
271
272 . ./v8.sh
273 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
274
275 # add chromium and pld to useragent
276 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
277 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
278         -e 's/@BUILD_DIST_NAME@/PLD/g' \
279         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
280         < %{PATCH8} | %{__patch} -p1
281
282 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
283 ln -s %{SOURCE7} .
284
285 %patch1 -p2
286 %patch4 -p3
287 %patch7 -p1
288 %patch10 -p1
289 %patch15 -p2
290 %{!?with_libjpegturbo:%patch11 -p0}
291 %patch12 -p1
292 %patch16 -p1
293 %patch28 -p1
294 %patch25 -p2
295 %patch18 -p1
296 %patch24 -p2
297 %patch26 -p2
298
299 sh -x clean-source.sh \
300         %{!?with_nacl:nacl=0} \
301         %{!?with_system_libvpx:libvpx=0} \
302         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
303         %{!?with_system_mesa:mesa=0} \
304         %{!?with_system_protobuf:protobuf=0} \
305         %{!?with_system_re2:re2=0} \
306         %{!?with_system_snappy:snappy=0} \
307         %{!?with_system_sqlite:sqlite=0} \
308         %{!?with_system_v8:v8=0} \
309         %{!?with_system_zlib:zlib=0} \
310         %{nil}
311
312 %build
313 %if %{with nacl}
314 rm -rf native_client/toolchain/linux_x86_newlib
315 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
316 # Make symlinks for NaCL
317 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
318
319 cd native_client/toolchain/linux_x86_newlib
320 ln -s x86_64-nacl/bin bin
321 cd x86_64-nacl/bin
322 __cc='%{__cc}'
323 if [ "${__cc#ccache}" != "$__cc" ]; then
324         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
325         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
326         %{__sed} -i -e '1i#!/bin/sh' gcc g++
327         chmod +x gcc g++
328 else
329         ln -s %{_bindir}/x86_64-nacl-gcc gcc
330         ln -s %{_bindir}/x86_64-nacl-g++ g++
331 fi
332 ln -s gcc x86_64-nacl-gcc
333 ln -s g++ x86_64-nacl-g++
334 ln -s %{_bindir}/x86_64-nacl-ar .
335 ln -s %{_bindir}/x86_64-nacl-ar ar
336 ln -s %{_bindir}/x86_64-nacl-as as
337 ln -s %{_bindir}/x86_64-nacl-ranlib .
338 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
339 ln -s %{_bindir}/x86_64-nacl-strip .
340 ln -s %{_bindir}/x86_64-nacl-strip strip
341 ln -s %{_bindir}/x86_64-nacl-objcopy .
342 ln -s %{_prefix}/x86_64-nacl/lib ../lib
343 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
344 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
345 cd ../../../../..
346 fi
347 %endif
348
349 flags="
350 %ifarch %{ix86}
351         -Dtarget_arch=ia32 \
352 %endif
353 %ifarch %{x8664}
354         -Dtarget_arch=x64 \
355 %endif
356 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
357         -Dno_strict_aliasing=1 -Dgcc_version=44 \
358 %endif
359 %if %{with sandboxing}
360         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
361         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
362 %endif
363         %{!?debug:-Dwerror=} \
364         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
365         %{?with_shared_libs:-Dlibrary=shared_library} \
366         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
367         -Dinclude_tests=0 \
368 %if %{with nacl}
369         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
370         -Ddisable_glibc_untar=1 \
371         -Ddisable_newlib_untar=1 \
372         -Ddisable_glibc=1 \
373         -Ddisable_pnacl=1 \
374         -Dbuild_pnacl_newlib=0 \
375 %else
376         -Ddisable_pnacl_untar=1 \
377         -Ddisable_nacl=1 \
378 %endif
379         %{!?with_sse2:-Ddisable_sse2=1} \
380         %{?with_selinux:-Dselinux=1} \
381         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
382         -Dlinux_link_libpci=1 \
383         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
384         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
385         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
386         -Dlinux_use_gold_binary=0 \
387         -Dlinux_use_gold_flags=0 \
388         -Dlogging_like_official_build=1 \
389         -Dgoogle_api_key=%{google_api_key} \
390         -Dgoogle_default_client_id=%{google_default_client_id} \
391         -Dgoogle_default_client_secret=%{google_default_client_secret} \
392         %{gyp_with cups} \
393         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
394         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
395         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
396         %{gyp_with pulseaudio} \
397         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
398         %{gyp_with system_flac} \
399         %{gyp_with system_harfbuzz} \
400         %{gyp_with system_jsoncpp} \
401         %{gyp_with system_libexif} \
402         %{gyp_with system_libmtp} \
403         %{gyp_with system_libsrtp} \
404         %{gyp_with system_libusb} \
405         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
406         %{gyp_with system_libwebp} \
407         %{gyp_with system_libxnvctrl} \
408         %{gyp_with system_mesa} \
409         %{gyp_with system_minizip} \
410         %{gyp_with system_opus} \
411         %{gyp_with system_protobuf} \
412         %{gyp_with system_re2} \
413         %{gyp_with system_snappy} \
414         %{gyp_with system_speex} \
415         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
416         %{gyp_with system_v8} \
417         %{gyp_with system_yasm} \
418         %{gyp_with system_zlib} \
419         -Duse_system_bzip2=1 \
420         -Duse_system_expat=1 \
421         -Duse_system_icu=1 \
422         -Duse_system_libevent=1 \
423         -Duse_system_libjpeg=1 \
424         -Duse_system_libpng=1 \
425         -Duse_system_libxml=1 \
426         -Duse_system_libxslt=1 \
427         -Duse_system_nspr=1 \
428         -Duse_system_xdg_utils=1 \
429 "
430
431 build/linux/unbundle/replace_gyp_files.py $flags
432
433 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
434 test -e Makefile || \
435         CC="%{__cc}" \
436         CXX="%{__cxx}" \
437         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
438         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
439         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
440         CC_host="%{__cc}" \
441         CXX_host="%{__cxx}" \
442         LD_host="%{__cxx}" \
443 %{__python} build/gyp_chromium \
444         --format=make \
445         --depth=. \
446         build/all.gyp \
447         $flags
448
449 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
450 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
451         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
452         %{?with_verbose:V=1} \
453         CC.host="%{__cc}" \
454         CXX.host="%{__cxx}" \
455         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
456
457 cd out/%{!?debug:Release}%{?debug:Debug}
458 MANWIDTH=80 man ./chrome.1 > man.out
459 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
460
461 %install
462 rm -rf $RPM_BUILD_ROOT
463 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
464         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
465         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
466
467 cd out/%{!?debug:Release}%{?debug:Debug}
468 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
469 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
470 %{__sed} -i -e '
471         s,@libdir@,%{_libdir}/%{name},
472
473         /@OPTIONS@/ {
474                 r options.txt
475                 d
476         }
477 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
478 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
479 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
480 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
481 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
482 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
483 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
484 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
485 %if %{without system_ffmpeg}
486 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
487 %endif
488 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
489 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
490
491 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
492
493 %if %{with nacl}
494 # Install Native Client files on platforms that support it.
495 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
496 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
497 %ifarch %{x8664}
498 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
499 %endif
500 %ifarch %{ix86}
501 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
502 %endif
503 %endif
504
505 cd -
506
507 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
508         size=${icon##*/product_logo_}
509         size=${size%.png}
510
511         # this will skip non-numeric (22_mono_invert, 22_mono)
512         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
513         test -d "$dir" || continue
514
515         install -d $RPM_BUILD_ROOT$dir
516         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
517 done
518
519 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
520 # http://code.google.com/p/chromium/issues/detail?id=24507
521 gecko-mediaplayer*.so
522 EOF
523
524 # find locales
525 %find_lang %{name}.lang
526 # always package en-US
527 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
528
529 %clean
530 rm -rf $RPM_BUILD_ROOT
531
532 %pretrans
533 for d in locales resources; do
534         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
535                 install -d %{_datadir}/%{name}
536                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
537         fi
538 done
539 exit 0
540
541 %post
542 %update_icon_cache hicolor
543 %update_desktop_database
544 %update_browser_plugins
545
546 %postun
547 if [ "$1" = 0 ]; then
548         %update_icon_cache hicolor
549         %update_browser_plugins
550 fi
551
552 %files
553 %defattr(644,root,root,755)
554 %doc AUTHORS LICENSE
555 %{_browserpluginsconfdir}/browsers.d/%{name}.*
556 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
557 %dir %{_sysconfdir}/%{name}
558 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
560 %attr(755,root,root) %{_bindir}/%{name}
561 %{_mandir}/man1/%{name}.1*
562 %{_desktopdir}/*.desktop
563 %{_iconsdir}/hicolor/*/apps/%{name}.png
564 %dir %{_libdir}/%{name}
565 %{_libdir}/%{name}/chrome*.pak
566 %{_libdir}/%{name}/content_resources.pak
567 %{_libdir}/%{name}/resources.pak
568 %{_libdir}/%{name}/locales
569 %{_libdir}/%{name}/resources
570
571 %dir %{_datadir}/%{name}
572 %dir %{_datadir}/%{name}/locales
573 %{_datadir}/%{name}/locales/en-US.pak
574 %dir %{_datadir}/%{name}/resources
575 %{_datadir}/%{name}/resources/inspector
576
577 %dir %{_libdir}/%{name}/plugins
578 %attr(755,root,root) %{_libdir}/%{name}/%{name}
579 # These unique permissions are intentional and necessary for the sandboxing
580 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
581
582 # ffmpeg libs
583 %if %{without system_ffmpeg}
584 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
585 %endif
586
587 %if %{with nacl}
588 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
589 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
590 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
591 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
592 %endif
593
594 %files l10n -f %{name}.lang
595 %defattr(644,root,root,755)
This page took 0.103487 seconds and 4 git commands to generate.