]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 34.0.1847.132
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
11 %bcond_with     ninja                   # use Ninja instead of make to build
12 %bcond_without  pulseaudio              # with pulseaudio
13 %bcond_without  sandboxing              # with sandboxing
14 %bcond_with             selinux                 # with SELinux (need policy first)
15 %bcond_with             shared_libs             # with shared libs
16 %bcond_with             sse2                    # use SSE2 instructions
17 %bcond_without  system_flac             # system flac
18 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
19 %bcond_without  system_harfbuzz # system harfbuzz
20 %bcond_without  system_jsoncpp  # system jsoncpp
21 %bcond_without  system_libexif  # system libexif
22 %bcond_without  system_libmtp   # system libmtp
23 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
24 %bcond_without  system_libwebp  # system libwebp
25 %bcond_without  system_libxnvctrl       # system libxnvctrl
26 %bcond_with     system_mesa             # system Mesa
27 %bcond_without  system_minizip  # system minizip
28 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
29 %bcond_without  system_protobuf # system protobuf
30 %bcond_without  system_re2              # system re2
31 %bcond_without  system_snappy   # system snappy
32 %bcond_without  system_speex    # system speex
33 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
34 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
35 %bcond_with             system_v8               # system v8
36 %bcond_without  system_libvpx   # system libvpx
37 %bcond_without  system_yasm             # system yasm
38 %bcond_without  system_zlib             # system zlib
39 %bcond_without  tcmalloc                # use tcmalloc
40 %bcond_without  verbose                 # verbose build (V=1)
41
42 %ifarch %{ix86}
43 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
44 %undefine       with_system_mesa
45 %endif
46
47 # TODO
48 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
49 # - use_system_skia
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_stlport (android specific)
52 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
53
54 # NOTES:
55 # - mute BEEP mixer if you do not want to hear horrible system bell when
56 #   pressing home/end in url bar or more ^F search results on page.
57 # - space considerations:
58 #   - unpacked sources: ~490MiB
59 #   - built code: ~1.4GiB (x86_64/i686)
60 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
61 # - to look for new tarball, use update-source.sh script
62
63 %define         branch          34.0.1847
64 %define         basever         116
65 %define         patchver        132
66 %define         gyp_rev 1014
67 Summary:        A WebKit powered web browser
68 Name:           chromium-browser
69 %if "%{?patchver}" != ""
70 Version:        %{branch}.%{patchver}
71 %else
72 Version:        %{branch}.%{basever}
73 %endif
74 Release:        2
75 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
76 Group:          X11/Applications/Networking
77 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
78 # Source0-md5:  987b25c0a3aa7bc2354c573113e94e04
79 %if "%{?patchver}" != ""
80 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
81 # Patch0-md5:   4eafe1e64bd47a11dbfaf61a2dd50b6e
82 %endif
83 Source1:        %{name}.default
84 Source2:        %{name}.sh
85 Source3:        %{name}.desktop
86 Source5:        find-lang.sh
87 Source6:        update-source.sh
88 Source7:        clean-source.sh
89 Source8:        get-source.sh
90 Source9:        master_preferences.json
91 Patch1:         plugin-searchdirs.patch
92 Patch2:         enable-video-decode-accel.patch
93 Patch4:         path-libpdf.patch
94 Patch7:         dlopen_sonamed_gl.patch
95 Patch8:         chromium_useragent.patch.in
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch30:        system-ply.patch
107 Patch31:        system-jinja.patch
108 Patch32:        remove_bundled_libraries-stale.patch
109 Patch33:        gn.patch
110 Patch34:        depot-tools.patch
111 URL:            http://www.chromium.org/Home
112 %{?with_gconf:BuildRequires:    GConf2-devel}
113 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
114 BuildRequires:  Mesa-libGLES-devel >= 9.1
115 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
116 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
117 BuildRequires:  alsa-lib-devel
118 BuildRequires:  atk-devel
119 BuildRequires:  bison
120 BuildRequires:  bzip2-devel
121 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
122 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
123 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
124 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
125 %{?with_cups:BuildRequires:     cups-devel}
126 BuildRequires:  elfutils-devel
127 BuildRequires:  expat-devel
128 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
129 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
130 BuildRequires:  fontconfig-devel
131 BuildRequires:  glib2-devel
132 BuildRequires:  gperf
133 %{?with_gps:BuildRequires:      gpsd-devel}
134 BuildRequires:  gtest-devel
135 BuildRequires:  gtk+2-devel
136 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
137 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
138 %{?with_kerberos:BuildRequires: heimdal-devel}
139 BuildRequires:  hicolor-icon-theme
140 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
141 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
142 BuildRequires:  libevent-devel
143 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
144 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
145 BuildRequires:  libicu-devel >= 4.6
146 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
147 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
148 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
149 BuildRequires:  libpng-devel
150 %{?with_selinux:BuildRequires:  libselinux-devel}
151 BuildRequires:  libstdc++-devel
152 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
153 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
154 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
155 BuildRequires:  libxml2-devel
156 BuildRequires:  libxslt-devel
157 BuildRequires:  man-db
158 %{?with_system_minizip:BuildRequires:   minizip-devel}
159 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
160 BuildRequires:  nspr-devel
161 BuildRequires:  nss-devel >= 1:3.12.3
162 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
163 BuildRequires:  pam-devel
164 BuildRequires:  pango-devel
165 BuildRequires:  pciutils-devel
166 BuildRequires:  perl-JSON
167 BuildRequires:  perl-modules
168 BuildRequires:  pkgconfig
169 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
170 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
171 BuildRequires:  python
172 #BuildRequires: python-gyp >= 1-%{gyp_rev}
173 BuildRequires:  python-jinja2 >= 2.7
174 BuildRequires:  python-modules
175 BuildRequires:  python-ply >= 3.4
176 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
177 BuildRequires:  rpm >= 4.4.9-56
178 BuildRequires:  rpmbuild(macros) >= 1.453
179 %{?with_system_snappy:BuildRequires:    snappy-devel}
180 BuildRequires:  speech-dispatcher-devel >= 0.8
181 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
182 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
183 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
184 BuildRequires:  tar >= 1:1.22
185 BuildRequires:  udev-devel
186 BuildRequires:  usbutils
187 BuildRequires:  util-linux
188 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
189 BuildRequires:  which
190 BuildRequires:  xorg-lib-libXScrnSaver-devel
191 BuildRequires:  xorg-lib-libXtst-devel
192 BuildRequires:  xz
193 %{?with_system_yasm:BuildRequires:      yasm}
194 %{?with_system_zlib:BuildRequires:      zlib-devel}
195 Requires:       browser-plugins >= 2.0
196 Requires:       desktop-file-utils
197 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
198 # crashes if no fontconfig font present
199 Requires:       fonts-Type1-urw
200 Requires:       hicolor-icon-theme
201 Requires:       libevent >= 2.0.21
202 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
203 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
204 Requires:       lsb-release
205 %{?with_system_re2:Requires:    re2 >= 20130115-2}
206 Requires:       shared-mime-info
207 %{?with_system_sqlite:Requires: sqlite3(icu)}
208 Requires:       xdg-utils >= 1.0.2-4
209 Requires:       xorg-lib-libX11 >= 1.4.99.1
210 Provides:       wwwbrowser
211 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
212 Obsoletes:      chromium-browser-inspector < 15.0.863.0
213 ExclusiveArch:  %{ix86} %{x8664} arm
214 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
215
216 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
217 # Note: these are for PLD Linux use ONLY.
218 # For your own distribution, please get your own set of keys.
219 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
220 %define         google_default_client_id 724288223830.apps.googleusercontent.com
221 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
222
223 %define         find_lang       sh find-lang.sh %{buildroot}
224
225 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
226 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
227
228 %ifarch %{ix86}
229 %define         target_arch ia32
230 %endif
231 %ifarch %{x8664}
232 %define         target_arch x64
233 %endif
234
235 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
236 %define         builddir        out/%{buildtype}
237
238 %if %{without debuginfo}
239 %define         _enable_debug_packages  0
240 %endif
241
242 %description
243 Chromium is an open-source browser project that aims to build a safer,
244 faster, and more stable way for all Internet users to experience the
245 web.
246
247 Chromium serves as a base for Google Chrome, which is Chromium
248 rebranded (name and logo) with very few additions such as usage
249 tracking and an auto-updater system.
250
251 %package l10n
252 Summary:        chromium-browser language packages
253 Group:          I18n
254 Requires:       %{name} = %{version}-%{release}
255 %if "%{_rpmversion}" >= "5"
256 BuildArch:      noarch
257 %endif
258
259 %description l10n
260 Chromium is an open-source browser project that aims to build a safer,
261 faster, and more stable way for all Internet users to experience the
262 web.
263
264 This package contains language packages for 50 languages:
265
266 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
267 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
268 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
269 zh-TW
270
271 %prep
272 %setup -qc
273 %if "%{?patchver}" != ""
274 cd chromium*-%{branch}.%{basever}
275 %patch0 -p1
276 cd ..
277 %endif
278 mv chromium*-%{branch}.%{basever}/* .
279
280 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
281 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
282 . ./chrome/VERSION
283 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
284 test "$chrome" = %{version}
285
286 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
287 test "$gyp_rev" = %{gyp_rev} || :
288
289 # add chromium and pld to useragent
290 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
291 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
292         -e 's/@BUILD_DIST_NAME@/PLD/g' \
293         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
294         < %{PATCH8} | %{__patch} -p1
295
296 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
297 ln -s %{SOURCE7} .
298
299 %patch1 -p1
300 #%patch2 -p1 NOT COMPILING
301 %patch4 -p3
302 %patch7 -p1
303 %patch15 -p2
304 %{!?with_libjpegturbo:%patch11 -p0}
305 %patch16 -p1
306 %patch28 -p1
307 %patch25 -p1
308 %{?with_nacl:%patch18 -p1}
309 %patch24 -p2
310 %patch26 -p2
311 #%patch30 -p1
312 #%patch31 -p0
313 %patch32 -p1
314 %patch33 -p1
315 %patch34 -p0
316
317 sh -x clean-source.sh \
318         %{!?with_nacl:nacl=0} \
319         %{!?with_system_libvpx:libvpx=0} \
320         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
321         %{!?with_system_mesa:mesa=0} \
322         %{!?with_system_protobuf:protobuf=0} \
323         %{!?with_system_re2:re2=0} \
324         %{!?with_system_snappy:snappy=0} \
325         %{!?with_system_sqlite:sqlite=0} \
326         %{!?with_system_v8:v8=0} \
327         %{!?with_system_libwebp:libwebp=0} \
328         %{!?with_system_zlib:zlib=0} \
329         %{!?with_system_ffmpeg:ffmpeg=0} \
330         %{nil}
331
332 %build
333 %if %{with nacl}
334 rm -rf native_client/toolchain/linux_x86_newlib
335 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
336 # Make symlinks for NaCL
337 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
338
339 cd native_client/toolchain/linux_x86_newlib
340 ln -s x86_64-nacl/bin bin
341 cd x86_64-nacl/bin
342 __cc='%{__cc}'
343 if [ "${__cc#ccache}" != "$__cc" ]; then
344         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
345         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
346         %{__sed} -i -e '1i#!/bin/sh' gcc g++
347         chmod +x gcc g++
348 else
349         ln -s %{_bindir}/x86_64-nacl-gcc gcc
350         ln -s %{_bindir}/x86_64-nacl-g++ g++
351 fi
352 ln -s gcc x86_64-nacl-gcc
353 ln -s g++ x86_64-nacl-g++
354 ln -s %{_bindir}/x86_64-nacl-ar .
355 ln -s %{_bindir}/x86_64-nacl-ar ar
356 ln -s %{_bindir}/x86_64-nacl-as as
357 ln -s %{_bindir}/x86_64-nacl-ranlib .
358 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
359 ln -s %{_bindir}/x86_64-nacl-strip .
360 ln -s %{_bindir}/x86_64-nacl-strip strip
361 ln -s %{_bindir}/x86_64-nacl-objcopy .
362 ln -s %{_prefix}/x86_64-nacl/lib ../lib
363 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
364 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
365 cd ../../../../..
366 fi
367 %endif
368
369 %if %{without system_ffmpeg}
370 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
371         # Re-configure bundled ffmpeg
372         cd third_party/ffmpeg
373         chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
374         chromium/scripts/copy_config.sh
375         cd -
376 fi
377 %endif
378
379 flags="
380         -Dtarget_arch=%{target_arch} \
381         -Dpython_arch=%{target_arch} \
382         -Dsystem_libdir=%{_lib} \
383         -Dpython_ver=%{py_ver} \
384 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
385         -Dno_strict_aliasing=1 -Dgcc_version=44 \
386 %endif
387         %{!?debug:-Dwerror=} \
388         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
389         %{?with_shared_libs:-Dlibrary=shared_library} \
390         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
391         -Dinclude_tests__=0 \
392 %if %{with nacl}
393         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
394         -Ddisable_glibc_untar=1 \
395         -Ddisable_newlib_untar=1 \
396         -Ddisable_glibc=1 \
397         -Ddisable_pnacl=1 \
398         -Dbuild_pnacl_newlib=0 \
399 %else
400         -Ddisable_pnacl_untar=1 \
401         -Ddisable_nacl=1 \
402 %endif
403         %{!?with_sse2:-Ddisable_sse2=1} \
404         %{?with_selinux:-Dselinux=1} \
405         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
406         -Dlinux_link_libpci=1 \
407         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
408         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
409         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
410         -Dlinux_use_gold_binary=0 \
411         -Dlinux_use_gold_flags=0 \
412         -Dlogging_like_official_build=1 \
413         -Dgoogle_api_key=%{google_api_key} \
414         -Dgoogle_default_client_id=%{google_default_client_id} \
415         -Dgoogle_default_client_secret=%{google_default_client_secret} \
416         %{gyp_with cups} \
417         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
418         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
419         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
420         %{gyp_with pulseaudio} \
421         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
422         %{gyp_with system_flac} \
423         %{gyp_with system_harfbuzz} \
424         %{gyp_with system_jsoncpp} \
425         %{gyp_with system_libexif} \
426         %{gyp_with system_libmtp} \
427         %{gyp_with system_libsrtp} \
428         %{gyp_with system_libusb} \
429         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
430         %{gyp_with system_libwebp} \
431         %{gyp_with system_libxnvctrl} \
432         %{gyp_with system_mesa} \
433         %{gyp_with system_minizip} \
434         %{gyp_with system_opus} \
435         %{gyp_with system_protobuf} \
436         %{gyp_with system_re2} \
437         %{gyp_with system_snappy} \
438         %{gyp_with system_speex} \
439         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
440         %{gyp_with system_v8} \
441         %{gyp_with system_yasm} \
442         %{gyp_with system_zlib} \
443         -Duse_system_bzip2=1 \
444         -Duse_system_expat=1 \
445         -Duse_system_icu=1 \
446         -Duse_system_libevent=1 \
447         -Duse_system_libjpeg=1 \
448         -Duse_system_libpng=1 \
449         -Duse_system_libxml=1 \
450         -Duse_system_libxslt=1 \
451         -Duse_system_nspr=1 \
452         -Duse_system_xdg_utils=1 \
453 "
454
455 build/linux/unbundle/replace_gyp_files.py $flags
456
457 %if %{with ninja}
458 chkfile=%{builddir}/build.ninja
459 %else
460 chkfile=Makefile
461 %endif
462 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
463 test -e $chkfile || \
464         CC="%{__cc}" \
465         CXX="%{__cxx}" \
466         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
467         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
468         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
469         CC_host="%{__cc}" \
470         CXX_host="%{__cxx}" \
471         LD_host="%{__cxx}" \
472 %{__python} build/gyp_chromium \
473         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
474         --depth=. \
475         build/all.gyp \
476         $flags
477
478 %if %{with ninja}
479 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
480 %else
481 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
482 %{__make} -r \
483         BUILDTYPE=%{buildtype} \
484         %{?with_verbose:V=1} \
485         CC.host="%{__cc}" \
486         CXX.host="%{__cxx}" \
487         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
488 %endif
489         chrome %{?with_sandboxing:chrome_sandbox} \
490         %{nil}
491
492 cd %{builddir}
493 MANWIDTH=80 man ./chrome.1 > man.out
494 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
495
496 %install
497 rm -rf $RPM_BUILD_ROOT
498 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
499         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
500         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
501
502 cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
503
504 cd %{builddir}
505 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
506 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
507 %{__sed} -i -e '
508         s,@libdir@,%{_libdir}/%{name},
509
510         /@OPTIONS@/ {
511                 r options.txt
512                 d
513         }
514 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
515 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
516 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
517 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
518 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
519 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
520 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
521 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
522 %if %{without system_ffmpeg}
523 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
524 %endif
525 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
526 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
527
528 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
529
530 %if %{with nacl}
531 # Install Native Client files on platforms that support it.
532 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
533 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
534 %ifarch %{x8664}
535 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
536 %endif
537 %ifarch %{ix86}
538 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
539 %endif
540 %endif
541
542 cd -
543
544 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
545         size=${icon##*/product_logo_}
546         size=${size%.png}
547
548         # this will skip non-numeric (22_mono_invert, 22_mono)
549         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
550         test -d "$dir" || continue
551
552         install -d $RPM_BUILD_ROOT$dir
553         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
554 done
555
556 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
557 # http://code.google.com/p/chromium/issues/detail?id=24507
558 gecko-mediaplayer*.so
559 EOF
560
561 # find locales
562 %find_lang %{name}.lang
563 # always package en-US
564 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
565
566 %clean
567 rm -rf $RPM_BUILD_ROOT
568
569 %pretrans
570 for d in locales resources; do
571         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
572                 install -d %{_datadir}/%{name}
573                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
574         fi
575 done
576 exit 0
577
578 %post
579 %update_icon_cache hicolor
580 %update_desktop_database
581 %update_browser_plugins
582
583 %postun
584 if [ "$1" = 0 ]; then
585         %update_icon_cache hicolor
586         %update_browser_plugins
587 fi
588
589 %files
590 %defattr(644,root,root,755)
591 %doc AUTHORS LICENSE
592 %{_browserpluginsconfdir}/browsers.d/%{name}.*
593 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
594 %dir %{_sysconfdir}/%{name}
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
596 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
597 %attr(755,root,root) %{_bindir}/%{name}
598 %{_mandir}/man1/%{name}.1*
599 %{_desktopdir}/*.desktop
600 %{_iconsdir}/hicolor/*/apps/%{name}.png
601 %dir %{_libdir}/%{name}
602 %{_libdir}/%{name}/chrome*.pak
603 %{_libdir}/%{name}/icudtl.dat
604 %{_libdir}/%{name}/content_resources.pak
605 %{_libdir}/%{name}/resources.pak
606 %{_libdir}/%{name}/locales
607 %{_libdir}/%{name}/resources
608
609 %dir %{_datadir}/%{name}
610 %dir %{_datadir}/%{name}/locales
611 %{_datadir}/%{name}/locales/en-US.pak
612 %dir %{_datadir}/%{name}/resources
613 %{_datadir}/%{name}/resources/inspector
614
615 %dir %{_libdir}/%{name}/plugins
616 %attr(755,root,root) %{_libdir}/%{name}/%{name}
617 # These unique permissions are intentional and necessary for the sandboxing
618 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
619
620 # ffmpeg libs
621 %if %{without system_ffmpeg}
622 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
623 %endif
624
625 %if %{with nacl}
626 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
627 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
628 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
629 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
630 %endif
631
632 %files l10n -f %{name}.lang
633 %defattr(644,root,root,755)
This page took 0.109635 seconds and 3 git commands to generate.