]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
system protobuf broken
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32 %bcond_with     system_protobuf # system protobuf
33 %bcond_without  system_re2              # system re2
34 %bcond_without  system_snappy   # system snappy
35 %bcond_without  system_speex    # system speex
36 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
38 %bcond_with             system_v8               # system v8
39 %bcond_with     system_libvpx   # system libvpx
40 %bcond_without  system_yasm             # system yasm
41 %bcond_without  system_zlib             # system zlib
42 %bcond_with     tcmalloc                # use tcmalloc
43 %bcond_without  verbose                 # verbose build (V=1)
44
45 %ifarch %{ix86}
46 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47 %undefine       with_system_mesa
48
49 # unable build with debuginfo on 32bit build systems
50 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51 %undefine       with_debuginfo
52 %endif
53
54 %ifarch %{x8664}
55 # x86_64 systems fail with debugedit crashing
56 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57 %undefine       with_debuginfo
58 %endif
59
60 # TODO
61 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62 # - use_system_skia
63 # - use_system_ssl (use_openssl: http://crbug.com/62803)
64 # - use_system_stlport (android specific)
65 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.4GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          40.0.2214
77 %define         basever         91
78 %define         patchver        93
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Name:           chromium-browser
82 %if "%{?patchver}" != ""
83 Version:        %{branch}.%{patchver}
84 %else
85 Version:        %{branch}.%{basever}
86 %endif
87 Release:        1
88 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89 Group:          X11/Applications/Networking
90 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91 # Source0-md5:  662f134029f2d6484873ec3c93a8e049
92 %if "%{?patchver}" != ""
93 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
94 # Patch0-md5:   d810c6bc3a40bbab1f04c8af397d93a1
95 %endif
96 Source1:        %{name}.default
97 Source2:        %{name}.sh
98 Source3:        %{name}.desktop
99 Source5:        find-lang.sh
100 Source6:        update-source.sh
101 Source7:        clean-source.sh
102 Source8:        get-source.sh
103 Source9:        master_preferences.json
104 Patch2:         enable-video-decode-accel.patch
105 Patch4:         path-libpdf.patch
106 Patch7:         dlopen_sonamed_gl.patch
107 Patch8:         chromium_useragent.patch.in
108 # https://bugs.gentoo.org/show_bug.cgi?id=393471
109 # libjpeg-turbo >= 1.1.90 supports that feature
110 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
111 Patch15:        nacl-build-irt.patch
112 Patch16:        nacl-linkingfix.patch
113 Patch18:        nacl-no-untar.patch
114 Patch24:        nacl-verbose.patch
115 Patch25:        gnome3-volume-control.patch
116 Patch26:        master-prefs-path.patch
117 Patch28:        system-mesa.patch
118 Patch31:        system-jinja.patch
119 Patch32:        remove_bundled_libraries-stale.patch
120 Patch35:        etc-dir.patch
121 Patch36:        angle.patch
122 Patch37:        %{name}-build.patch
123 URL:            http://www.chromium.org/Home
124 %{?with_gconf:BuildRequires:    GConf2-devel}
125 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
126 BuildRequires:  Mesa-libGLES-devel >= 9.1
127 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
128 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
129 BuildRequires:  alsa-lib-devel
130 BuildRequires:  atk-devel
131 BuildRequires:  bison
132 BuildRequires:  bzip2-devel
133 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
134 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
135 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
136 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
137 %{?with_cups:BuildRequires:     cups-devel}
138 BuildRequires:  elfutils-devel
139 BuildRequires:  expat-devel
140 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
141 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
142 BuildRequires:  fontconfig-devel
143 BuildRequires:  glib2-devel
144 BuildRequires:  gperf
145 %{?with_gps:BuildRequires:      gpsd-devel}
146 BuildRequires:  gtest-devel
147 BuildRequires:  gtk+2-devel
148 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
149 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
150 %{?with_kerberos:BuildRequires: heimdal-devel}
151 BuildRequires:  hicolor-icon-theme
152 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
153 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
154 BuildRequires:  libevent-devel
155 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
156 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
157 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
158 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
159 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
160 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
161 BuildRequires:  libpng-devel
162 %{?with_selinux:BuildRequires:  libselinux-devel}
163 BuildRequires:  libstdc++-devel
164 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
165 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
166 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
167 BuildRequires:  libxml2-devel
168 BuildRequires:  libxslt-devel
169 BuildRequires:  man-db
170 %{?with_system_minizip:BuildRequires:   minizip-devel}
171 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
172 BuildRequires:  nspr-devel
173 BuildRequires:  nss-devel >= 1:3.12.3
174 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
175 BuildRequires:  pam-devel
176 BuildRequires:  pango-devel
177 BuildRequires:  pciutils-devel
178 BuildRequires:  perl-JSON
179 BuildRequires:  perl-modules
180 BuildRequires:  pkgconfig
181 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
182 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
183 BuildRequires:  python
184 BuildRequires:  python-BeautifulSoup
185 #BuildRequires: python-gyp >= 1-%{gyp_rev}
186 BuildRequires:  python-jinja2 >= 2.7
187 BuildRequires:  python-modules
188 BuildRequires:  python-ply >= 3.4
189 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
190 BuildRequires:  rpm >= 4.4.9-56
191 BuildRequires:  rpmbuild(macros) >= 1.453
192 %{?with_system_snappy:BuildRequires:    snappy-devel}
193 BuildRequires:  speech-dispatcher-devel >= 0.8
194 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
195 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
196 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
197 BuildRequires:  tar >= 1:1.22
198 BuildRequires:  udev-devel
199 BuildRequires:  usbutils
200 BuildRequires:  util-linux
201 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
202 BuildRequires:  which
203 BuildRequires:  xorg-lib-libXScrnSaver-devel
204 BuildRequires:  xorg-lib-libXtst-devel
205 BuildRequires:  xz
206 %{?with_system_yasm:BuildRequires:      yasm}
207 %{?with_system_zlib:BuildRequires:      zlib-devel}
208 Requires:       browser-plugins >= 2.0
209 Requires:       desktop-file-utils
210 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
211 # crashes if no fontconfig font present
212 Requires:       fonts-Type1-urw
213 Requires:       hicolor-icon-theme
214 Requires:       libevent >= 2.0.21
215 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
216 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
217 Requires:       lsb-release
218 %{?with_system_re2:Requires:    re2 >= 20130115-2}
219 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
220 Requires:       shared-mime-info
221 %{?with_system_sqlite:Requires: sqlite3(icu)}
222 Requires:       xdg-utils >= 1.0.2-4
223 Requires:       xorg-lib-libX11 >= 1.4.99.1
224 Provides:       wwwbrowser
225 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
226 Obsoletes:      chromium-browser-inspector < 15.0.863.0
227 ExclusiveArch:  %{ix86} %{x8664} arm
228 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
229
230 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
231 # Note: these are for PLD Linux use ONLY.
232 # For your own distribution, please get your own set of keys.
233 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
234 %define         google_default_client_id 724288223830.apps.googleusercontent.com
235 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
236
237 %define         find_lang       sh find-lang.sh %{buildroot}
238
239 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
240 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
241
242 %ifarch %{ix86}
243 %define         target_arch ia32
244 %endif
245 %ifarch %{x8664}
246 %define         target_arch x64
247 %endif
248
249 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
250 %define         builddir        out/%{buildtype}
251
252 %if %{without debuginfo}
253 %define         _enable_debug_packages  0
254 %endif
255
256 %description
257 Chromium is an open-source browser project that aims to build a safer,
258 faster, and more stable way for all Internet users to experience the
259 web.
260
261 Chromium serves as a base for Google Chrome, which is Chromium
262 rebranded (name and logo) with very few additions such as usage
263 tracking and an auto-updater system.
264
265 %package l10n
266 Summary:        chromium-browser language packages
267 Group:          I18n
268 Requires:       %{name} = %{version}-%{release}
269 %if "%{_rpmversion}" >= "5"
270 BuildArch:      noarch
271 %endif
272
273 %description l10n
274 Chromium is an open-source browser project that aims to build a safer,
275 faster, and more stable way for all Internet users to experience the
276 web.
277
278 This package contains language packages for 50 languages:
279
280 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
281 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
282 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
283 zh-TW
284
285 %prep
286 %setup -qc
287 %if "%{?patchver}" != ""
288 cd chromium*-%{branch}.%{basever}
289 %patch0 -p1
290 cd ..
291 %endif
292 mv chromium*-%{branch}.%{basever}/* .
293
294 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
295 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
296 . ./chrome/VERSION
297 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
298 test "$chrome" = %{version}
299
300 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
301 test "$gyp_rev" = %{gyp_rev} || :
302
303 # add chromium and pld to useragent
304 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
305 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
306         -e 's/@BUILD_DIST_NAME@/PLD/g' \
307         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
308         < %{PATCH8} | %{__patch} -p1
309
310 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
311 ln -s %{SOURCE7} .
312
313 #%patch2 -p1 NOT COMPILING
314 %patch4 -p3
315 %patch7 -p1
316 %patch15 -p2
317 %{!?with_libjpegturbo:%patch11 -p0}
318 %patch16 -p1
319 %patch28 -p1
320 %patch25 -p1
321 %{?with_nacl:%patch18 -p1}
322 %patch24 -p1
323 %patch26 -p2
324 %patch31 -p0
325 %patch32 -p1
326 %patch35 -p1
327 %patch36 -p1
328 %patch37 -p1
329
330 %{?with_dev:exit 0}
331
332 sh -x clean-source.sh \
333         %{!?with_nacl:nacl=0} \
334         %{!?with_system_libvpx:libvpx=0} \
335         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
336         %{!?with_system_mesa:mesa=0} \
337         %{!?with_system_protobuf:protobuf=0} \
338         %{!?with_system_re2:re2=0} \
339         %{!?with_system_snappy:snappy=0} \
340         %{!?with_system_sqlite:sqlite=0} \
341         %{!?with_system_v8:v8=0} \
342         %{!?with_system_libwebp:libwebp=0} \
343         %{!?with_system_zlib:zlib=0} \
344         %{!?with_system_ffmpeg:ffmpeg=0} \
345         %{nil}
346
347 %build
348 %if %{with nacl}
349 rm -rf native_client/toolchain/linux_x86_newlib
350 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
351 # Make symlinks for NaCL
352 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
353
354 cd native_client/toolchain/linux_x86_newlib
355 ln -s x86_64-nacl/bin bin
356 cd x86_64-nacl/bin
357 __cc='%{__cc}'
358 if [ "${__cc#ccache}" != "$__cc" ]; then
359         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
360         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
361         %{__sed} -i -e '1i#!/bin/sh' gcc g++
362         chmod +x gcc g++
363 else
364         ln -s %{_bindir}/x86_64-nacl-gcc gcc
365         ln -s %{_bindir}/x86_64-nacl-g++ g++
366 fi
367 ln -s gcc x86_64-nacl-gcc
368 ln -s g++ x86_64-nacl-g++
369 ln -s %{_bindir}/x86_64-nacl-ar .
370 ln -s %{_bindir}/x86_64-nacl-ar ar
371 ln -s %{_bindir}/x86_64-nacl-as as
372 ln -s %{_bindir}/x86_64-nacl-ranlib .
373 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
374 ln -s %{_bindir}/x86_64-nacl-strip .
375 ln -s %{_bindir}/x86_64-nacl-strip strip
376 ln -s %{_bindir}/x86_64-nacl-objcopy .
377 ln -s %{_prefix}/x86_64-nacl/lib ../lib
378 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
379 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
380 cd ../../../../..
381 fi
382 %endif
383
384 %if %{without system_ffmpeg}
385 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
386         # Re-configure bundled ffmpeg
387         cd third_party/ffmpeg
388         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
389                 --branding Chromium
390         chromium/scripts/copy_config.sh
391         chromium/scripts/generate_gyp.py
392         cd -
393 fi
394 %endif
395
396 third_party/libaddressinput/chromium/tools/update-strings.py
397
398 flags="
399         -Dtarget_arch=%{target_arch} \
400         -Dpython_arch=%{target_arch} \
401         -Dffmpeg_branding=Chromium \
402         -Dsystem_libdir=%{_lib} \
403         -Dpython_ver=%{py_ver} \
404 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
405         -Dno_strict_aliasing=1 -Dgcc_version=44 \
406 %endif
407         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
408         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
409         %{?with_shared_libs:-Dlibrary=shared_library} \
410         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
411         -Dinclude_tests__=0 \
412 %if %{with nacl}
413         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
414         -Ddisable_glibc_untar=1 \
415         -Ddisable_newlib_untar=1 \
416         -Ddisable_glibc=1 \
417         -Ddisable_pnacl=1 \
418         -Dbuild_pnacl_newlib=0 \
419 %else
420         -Ddisable_pnacl_untar=1 \
421         -Ddisable_nacl=1 \
422 %endif
423         %{!?with_sse2:-Ddisable_sse2=1} \
424         %{?with_selinux:-Dselinux=1} \
425         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
426         -Dlinux_link_libpci=1 \
427         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
428         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
429         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
430         -Dclang=0 \
431         -Dhost_clang=0 \
432         -Dlinux_use_bundled_binutils=0 \
433         -Dlinux_use_bundled_gold=0 \
434         -Dlinux_use_gold_flags=0 \
435         -Dlogging_like_official_build=1 \
436         -Dgoogle_api_key=%{google_api_key} \
437         -Dgoogle_default_client_id=%{google_default_client_id} \
438         -Dgoogle_default_client_secret=%{google_default_client_secret} \
439         %{gyp_with cups} \
440         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
441         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
442         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
443         %{gyp_with pulseaudio} \
444         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
445         %{gyp_with system_flac} \
446         %{gyp_with system_harfbuzz} \
447         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
448         %{gyp_with system_jsoncpp} \
449         %{gyp_with system_libexif} \
450         %{gyp_with system_libmtp} \
451         %{gyp_with system_libsrtp} \
452         %{gyp_with system_libusb} \
453         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
454         %{gyp_with system_libwebp} \
455         %{gyp_with system_libxnvctrl} \
456         %{gyp_with system_mesa} \
457         %{gyp_with system_minizip} \
458         %{gyp_with system_opus} \
459         %{gyp_with system_protobuf} \
460         %{gyp_with system_re2} \
461         %{gyp_with system_snappy} \
462         %{gyp_with system_speex} \
463         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
464         %{gyp_with system_v8} \
465         %{gyp_with system_yasm} \
466         %{gyp_with system_zlib} \
467         -Duse_system_bzip2=1 \
468         -Duse_system_expat=1 \
469         -Duse_system_libevent=1 \
470         -Duse_system_libjpeg=1 \
471         -Duse_system_libpng=1 \
472         -Duse_system_libxml=1 \
473         -Duse_system_libxslt=1 \
474         -Duse_system_nspr=1 \
475         -Duse_system_xdg_utils=1 \
476 "
477
478 build/linux/unbundle/replace_gyp_files.py $flags
479
480 %if %{with ninja}
481 chkfile=%{builddir}/build.ninja
482 %else
483 chkfile=Makefile
484 %endif
485 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
486 test -e $chkfile || \
487         CC="%{__cc}" \
488         CXX="%{__cxx}" \
489         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
490         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
491         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
492         CC_host="%{__cc}" \
493         CXX_host="%{__cxx}" \
494         LD_host="%{__cxx}" \
495 %{__python} build/gyp_chromium \
496         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
497         --depth=. \
498         build/all.gyp \
499         $flags
500
501 %if %{with ninja}
502 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
503 %else
504 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
505 %{__make} -r \
506         BUILDTYPE=%{buildtype} \
507         %{?with_verbose:V=1} \
508         CC.host="%{__cc}" \
509         CXX.host="%{__cxx}" \
510         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
511 %endif
512         chrome %{?with_sandboxing:chrome_sandbox} \
513         %{nil}
514
515 cd %{builddir}
516 MANWIDTH=80 man ./chrome.1 > man.out
517 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
518
519 %install
520 rm -rf $RPM_BUILD_ROOT
521 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
522         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
523         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
524         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
525
526 cd %{builddir}
527 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
528 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
529 %{__sed} -i -e '
530         s,@libdir@,%{_libdir}/%{name},
531
532         /@OPTIONS@/ {
533                 r options.txt
534                 d
535         }
536 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
537 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
538 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
539 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
540 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
541 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
542 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
543 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
544 %if %{without system_ffmpeg}
545 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
546 %endif
547 install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
548 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
549 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
550
551 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
552
553 %if %{with nacl}
554 # Install Native Client files on platforms that support it.
555 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
556 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
557 %ifarch %{x8664}
558 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
559 %endif
560 %ifarch %{ix86}
561 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
562 %endif
563 %endif
564
565 cd -
566
567 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
568         size=${icon##*/product_logo_}
569         size=${size%.png}
570
571         # this will skip non-numeric (22_mono_invert, 22_mono)
572         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
573         test -d "$dir" || continue
574
575         install -d $RPM_BUILD_ROOT$dir
576         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
577 done
578
579 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
580 # http://code.google.com/p/chromium/issues/detail?id=24507
581 gecko-mediaplayer*.so
582 EOF
583
584 # find locales
585 %find_lang %{name}.lang
586 # always package en-US
587 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %pretrans
593 for d in locales resources; do
594         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
595                 install -d %{_datadir}/%{name}
596                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
597         fi
598 done
599 exit 0
600
601 %post
602 %update_icon_cache hicolor
603 %update_desktop_database
604 %update_browser_plugins
605
606 %postun
607 if [ "$1" = 0 ]; then
608         %update_icon_cache hicolor
609         %update_browser_plugins
610 fi
611
612 %files
613 %defattr(644,root,root,755)
614 %doc AUTHORS LICENSE
615 %{_browserpluginsconfdir}/browsers.d/%{name}.*
616 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
617 %dir %{_sysconfdir}/%{name}
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
619 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
620 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
621 %dir %{_sysconfdir}/%{name}/policies
622 %dir %{_sysconfdir}/%{name}/policies/managed
623 %attr(755,root,root) %{_bindir}/%{name}
624 %{_mandir}/man1/%{name}.1*
625 %{_desktopdir}/*.desktop
626 %{_iconsdir}/hicolor/*/apps/%{name}.png
627 %dir %{_libdir}/%{name}
628 %{_libdir}/%{name}/chrome*.pak
629 %{_libdir}/%{name}/content_resources.pak
630 %{_libdir}/%{name}/keyboard_resources.pak
631 %{_libdir}/%{name}/resources.pak
632 %{_libdir}/%{name}/locales
633 %{_libdir}/%{name}/resources
634
635 # conflicts with browser-plugin-chrome-pdf?
636 %attr(755,root,root) %{_libdir}/%{name}/libpdf.so
637
638 %dir %{_datadir}/%{name}
639 %dir %{_datadir}/%{name}/locales
640 %{_datadir}/%{name}/locales/en-US.pak
641 %dir %{_datadir}/%{name}/resources
642 %{_datadir}/%{name}/resources/inspector
643
644 %dir %{_libdir}/%{name}/plugins
645 %attr(755,root,root) %{_libdir}/%{name}/%{name}
646 # These unique permissions are intentional and necessary for the sandboxing
647 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
648
649 # ffmpeg libs
650 %if %{without system_ffmpeg}
651 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
652 %endif
653
654 %if %{with nacl}
655 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
656 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
657 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
658 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
659 %endif
660
661 %files l10n -f %{name}.lang
662 %defattr(644,root,root,755)
This page took 0.182756 seconds and 3 git commands to generate.