]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 43.0.2357.134
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32 %bcond_with     system_protobuf # system protobuf
33 %bcond_without  system_re2              # system re2
34 %bcond_without  system_snappy   # system snappy
35 %bcond_without  system_speex    # system speex
36 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
38 %bcond_with             system_v8               # system v8
39 %bcond_with     system_libvpx   # system libvpx
40 %bcond_without  system_yasm             # system yasm
41 %bcond_without  system_zlib             # system zlib
42 %bcond_with     tcmalloc                # use tcmalloc
43 %bcond_without  verbose                 # verbose build (V=1)
44
45 %ifarch %{ix86}
46 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47 %undefine       with_system_mesa
48
49 # unable build with debuginfo on 32bit build systems
50 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51 %undefine       with_debuginfo
52 %endif
53
54 %ifarch %{x8664}
55 # x86_64 systems fail with debugedit crashing
56 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57 %undefine       with_debuginfo
58 %endif
59
60 # TODO
61 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62 # - use_system_skia
63 # - use_system_ssl (use_openssl: http://crbug.com/62803)
64 # - use_system_stlport (android specific)
65 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.4GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          43.0.2357
77 %define         basever         65
78 %define         patchver        134
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Name:           chromium-browser
82 %if "%{?patchver}" != ""
83 Version:        %{branch}.%{patchver}
84 %else
85 Version:        %{branch}.%{basever}
86 %endif
87 Release:        1
88 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89 Group:          X11/Applications/Networking
90 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91 # Source0-md5:  4aa590c1965817cfb693df7f8404e0b6
92 %if "%{?patchver}" != ""
93 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
94 # Patch0-md5:   0cfc52a089350571474c308dab1327ee
95 %endif
96 Source1:        %{name}.default
97 Source2:        %{name}.sh
98 Source3:        %{name}.desktop
99 Source5:        find-lang.sh
100 Source6:        update-source.sh
101 Source7:        clean-source.sh
102 Source8:        get-source.sh
103 Source9:        master_preferences.json
104 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
105 Patch2:         enable-video-decode-accel.patch
106 Patch7:         dlopen_sonamed_gl.patch
107 Patch8:         chromium_useragent.patch.in
108 # https://bugs.gentoo.org/show_bug.cgi?id=393471
109 # libjpeg-turbo >= 1.1.90 supports that feature
110 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
111 Patch15:        nacl-build-irt.patch
112 Patch16:        nacl-linkingfix.patch
113 Patch18:        nacl-no-untar.patch
114 Patch24:        nacl-verbose.patch
115 Patch25:        gnome3-volume-control.patch
116 Patch26:        master-prefs-path.patch
117 Patch28:        system-mesa.patch
118 Patch31:        system-jinja.patch
119 Patch32:        remove_bundled_libraries-stale.patch
120 Patch35:        etc-dir.patch
121 Patch36:        angle.patch
122 Patch37:        %{name}-build.patch
123 Patch38:        vaapi_include.patch
124 Patch39:        libsecret.patch
125 Patch40:        system-libvpx.patch
126 URL:            http://www.chromium.org/Home
127 %{?with_gconf:BuildRequires:    GConf2-devel}
128 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
129 BuildRequires:  Mesa-libGLES-devel >= 9.1
130 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
131 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
132 BuildRequires:  alsa-lib-devel
133 BuildRequires:  atk-devel
134 BuildRequires:  bison
135 BuildRequires:  bzip2-devel
136 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
137 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
138 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
139 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
140 %{?with_cups:BuildRequires:     cups-devel}
141 BuildRequires:  elfutils-devel
142 BuildRequires:  expat-devel
143 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
144 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
145 BuildRequires:  fontconfig-devel
146 BuildRequires:  glib2-devel
147 BuildRequires:  gperf
148 %{?with_gps:BuildRequires:      gpsd-devel}
149 BuildRequires:  gtest-devel
150 BuildRequires:  gtk+2-devel
151 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
152 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
153 %{?with_kerberos:BuildRequires: heimdal-devel}
154 BuildRequires:  hicolor-icon-theme
155 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
156 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
157 BuildRequires:  libevent-devel
158 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
159 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
160 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
161 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
162 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
163 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
164 BuildRequires:  libpng-devel
165 BuildRequires:  libsecret-devel
166 %{?with_selinux:BuildRequires:  libselinux-devel}
167 BuildRequires:  libstdc++-devel
168 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
169 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.4.0}
170 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
171 BuildRequires:  libxml2-devel
172 BuildRequires:  libxslt-devel
173 BuildRequires:  man-db
174 %{?with_system_minizip:BuildRequires:   minizip-devel}
175 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
176 BuildRequires:  nspr-devel
177 BuildRequires:  nss-devel >= 1:3.12.3
178 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
179 BuildRequires:  pam-devel
180 BuildRequires:  pango-devel
181 BuildRequires:  pciutils-devel
182 BuildRequires:  perl-JSON
183 BuildRequires:  perl-modules
184 BuildRequires:  pkgconfig
185 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
186 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
187 BuildRequires:  python
188 BuildRequires:  python-BeautifulSoup
189 #BuildRequires: python-gyp >= 1-%{gyp_rev}
190 BuildRequires:  python-jinja2 >= 2.7
191 BuildRequires:  python-modules
192 BuildRequires:  python-ply >= 3.4
193 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
194 BuildRequires:  rpm >= 4.4.9-56
195 BuildRequires:  rpmbuild(macros) >= 1.453
196 %{?with_system_snappy:BuildRequires:    snappy-devel}
197 BuildRequires:  speech-dispatcher-devel >= 0.8
198 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
199 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
200 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
201 BuildRequires:  tar >= 1:1.22
202 BuildRequires:  udev-devel
203 BuildRequires:  usbutils
204 BuildRequires:  util-linux
205 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
206 BuildRequires:  which
207 BuildRequires:  xorg-lib-libXScrnSaver-devel
208 BuildRequires:  xorg-lib-libXtst-devel
209 BuildRequires:  xz
210 %{?with_system_yasm:BuildRequires:      yasm}
211 %{?with_system_zlib:BuildRequires:      zlib-devel}
212 Requires:       browser-plugins >= 2.0
213 Requires:       desktop-file-utils
214 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
215 # crashes if no fontconfig font present
216 Requires:       fonts-Type1-urw
217 Requires:       hicolor-icon-theme
218 Requires:       libevent >= 2.0.21
219 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
220 %{?with_system_libvpx:Requires: libvpx >= 1.4.0}
221 Requires:       lsb-release
222 %{?with_system_re2:Requires:    re2 >= 20130115-2}
223 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
224 Requires:       shared-mime-info
225 %{?with_system_sqlite:Requires: sqlite3(icu)}
226 Requires:       uname(release) >= 3.17
227 Requires:       xdg-utils >= 1.0.2-4
228 Requires:       xorg-lib-libX11 >= 1.4.99.1
229 Provides:       wwwbrowser
230 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
231 Obsoletes:      chromium-browser-inspector < 15.0.863.0
232 ExclusiveArch:  %{ix86} %{x8664} arm
233 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
234
235 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
236 # Note: these are for PLD Linux use ONLY.
237 # For your own distribution, please get your own set of keys.
238 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
239 %define         google_default_client_id 724288223830.apps.googleusercontent.com
240 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
241
242 %define         find_lang       sh find-lang.sh %{buildroot}
243
244 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
245 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
246
247 %ifarch %{ix86}
248 %define         target_arch ia32
249 %endif
250 %ifarch %{x8664}
251 %define         target_arch x64
252 %endif
253
254 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
255 %define         builddir        out/%{buildtype}
256
257 %if %{without debuginfo}
258 %define         _enable_debug_packages  0
259 %endif
260
261 %description
262 Chromium is an open-source browser project that aims to build a safer,
263 faster, and more stable way for all Internet users to experience the
264 web.
265
266 Chromium serves as a base for Google Chrome, which is Chromium
267 rebranded (name and logo) with very few additions such as usage
268 tracking and an auto-updater system.
269
270 %package l10n
271 Summary:        chromium-browser language packages
272 Group:          I18n
273 Requires:       %{name} = %{version}-%{release}
274 %if "%{_rpmversion}" >= "5"
275 BuildArch:      noarch
276 %endif
277
278 %description l10n
279 Chromium is an open-source browser project that aims to build a safer,
280 faster, and more stable way for all Internet users to experience the
281 web.
282
283 This package contains language packages for 50 languages:
284
285 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
286 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
287 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
288 zh-TW
289
290 %prep
291 %setup -qc
292 %if "%{?patchver}" != ""
293 cd chromium*-%{branch}.%{basever}
294 %patch0 -p1
295 cd ..
296 %endif
297 mv chromium*-%{branch}.%{basever}/* .
298
299 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
300 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
301 . ./chrome/VERSION
302 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
303 test "$chrome" = %{version}
304
305 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
306 test "$gyp_rev" = %{gyp_rev} || :
307
308 # add chromium and pld to useragent
309 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
310 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
311         -e 's/@BUILD_DIST_NAME@/PLD/g' \
312         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
313         < %{PATCH8} | %{__patch} -p1
314
315 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
316 ln -s %{SOURCE7} .
317
318 #%patch2 -p1 CHECK
319 %patch7 -p1
320 %patch15 -p2
321 %{!?with_libjpegturbo:%patch11 -p0}
322 %patch16 -p1
323 %patch28 -p1
324 %patch25 -p1
325 %{?with_nacl:%patch18 -p1}
326 %patch24 -p1
327 %patch26 -p2
328 %patch31 -p0
329 %patch32 -p1
330 %patch35 -p1
331 %patch36 -p1
332 %patch37 -p1
333 #%patch38 -p1 CHECK
334 %patch39 -p1
335 %patch40 -p0
336
337 %{?with_dev:exit 0}
338
339 sh -x clean-source.sh \
340         %{!?with_nacl:nacl=0} \
341         %{!?with_system_libvpx:libvpx=0} \
342         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
343         %{!?with_system_mesa:mesa=0} \
344         %{!?with_system_protobuf:protobuf=0} \
345         %{!?with_system_re2:re2=0} \
346         %{!?with_system_snappy:snappy=0} \
347         %{!?with_system_sqlite:sqlite=0} \
348         %{!?with_system_v8:v8=0} \
349         %{!?with_system_libwebp:libwebp=0} \
350         %{!?with_system_zlib:zlib=0} \
351         %{!?with_system_ffmpeg:ffmpeg=0} \
352         %{nil}
353
354 %build
355 %if %{with nacl}
356 rm -rf native_client/toolchain/linux_x86_newlib
357 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
358 # Make symlinks for NaCL
359 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
360
361 cd native_client/toolchain/linux_x86_newlib
362 ln -s x86_64-nacl/bin bin
363 cd x86_64-nacl/bin
364 __cc='%{__cc}'
365 if [ "${__cc#ccache}" != "$__cc" ]; then
366         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
367         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
368         %{__sed} -i -e '1i#!/bin/sh' gcc g++
369         chmod +x gcc g++
370 else
371         ln -s %{_bindir}/x86_64-nacl-gcc gcc
372         ln -s %{_bindir}/x86_64-nacl-g++ g++
373 fi
374 ln -s gcc x86_64-nacl-gcc
375 ln -s g++ x86_64-nacl-g++
376 ln -s %{_bindir}/x86_64-nacl-ar .
377 ln -s %{_bindir}/x86_64-nacl-ar ar
378 ln -s %{_bindir}/x86_64-nacl-as as
379 ln -s %{_bindir}/x86_64-nacl-ranlib .
380 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
381 ln -s %{_bindir}/x86_64-nacl-strip .
382 ln -s %{_bindir}/x86_64-nacl-strip strip
383 ln -s %{_bindir}/x86_64-nacl-objcopy .
384 ln -s %{_prefix}/x86_64-nacl/lib ../lib
385 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
386 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
387 cd ../../../../..
388 fi
389 %endif
390
391 %if %{without system_ffmpeg}
392 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
393         # Re-configure bundled ffmpeg
394         cd third_party/ffmpeg
395         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
396                 --branding Chromium
397         chromium/scripts/copy_config.sh
398         chromium/scripts/generate_gyp.py
399         cd -
400 fi
401 %endif
402
403 third_party/libaddressinput/chromium/tools/update-strings.py
404
405 flags="
406         -Dtarget_arch=%{target_arch} \
407         -Dpython_arch=%{target_arch} \
408         -Dproprietary_codecs=1 \
409         -Dffmpeg_branding=Chromium \
410         -Dsystem_libdir=%{_lib} \
411         -Dpython_ver=%{py_ver} \
412 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
413         -Dno_strict_aliasing=1 -Dgcc_version=44 \
414 %endif
415         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
416         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
417         %{?with_shared_libs:-Dlibrary=shared_library} \
418         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
419         -Dinclude_tests__=0 \
420 %if %{with nacl}
421         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
422         -Ddisable_glibc_untar=1 \
423         -Ddisable_newlib_untar=1 \
424         -Ddisable_glibc=1 \
425         -Ddisable_pnacl=1 \
426         -Dbuild_pnacl_newlib=0 \
427 %else
428         -Ddisable_pnacl_untar=1 \
429         -Ddisable_nacl=1 \
430 %endif
431         %{!?with_sse2:-Ddisable_sse2=1} \
432         %{?with_selinux:-Dselinux=1} \
433         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
434         -Dlinux_link_libpci=1 \
435         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
436         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
437         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
438         -Dclang=0 \
439         -Dhost_clang=0 \
440         -Dlinux_use_bundled_binutils=0 \
441         -Dlinux_use_bundled_gold=0 \
442         -Dlinux_use_gold_flags=0 \
443         -Dlogging_like_official_build=1 \
444         -Dgoogle_api_key=%{google_api_key} \
445         -Dgoogle_default_client_id=%{google_default_client_id} \
446         -Dgoogle_default_client_secret=%{google_default_client_secret} \
447         %{gyp_with cups} \
448         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
449         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
450         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
451         %{gyp_with pulseaudio} \
452         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
453         %{gyp_with system_flac} \
454         %{gyp_with system_harfbuzz} \
455         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
456         %{gyp_with system_jsoncpp} \
457         %{gyp_with system_libexif} \
458         %{gyp_with system_libmtp} \
459         %{gyp_with system_libsrtp} \
460         %{gyp_with system_libusb} \
461         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
462         %{gyp_with system_libwebp} \
463         %{gyp_with system_libxnvctrl} \
464         %{gyp_with system_mesa} \
465         %{gyp_with system_minizip} \
466         %{gyp_with system_opus} \
467         %{gyp_with system_protobuf} \
468         %{gyp_with system_re2} \
469         %{gyp_with system_snappy} \
470         %{gyp_with system_speex} \
471         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
472         %{gyp_with system_v8} \
473         %{gyp_with system_yasm} \
474         %{gyp_with system_zlib} \
475         -Duse_system_bzip2=1 \
476         -Duse_system_expat=1 \
477         -Duse_system_libevent=1 \
478         -Duse_system_libjpeg=1 \
479         -Duse_system_libpng=1 \
480         -Duse_system_libxml=1 \
481         -Duse_system_libxslt=1 \
482         -Duse_system_nspr=1 \
483         -Duse_system_xdg_utils=1 \
484 "
485
486 build/linux/unbundle/replace_gyp_files.py $flags
487
488 %if %{with ninja}
489 chkfile=%{builddir}/build.ninja
490 %else
491 chkfile=Makefile
492 %endif
493 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
494 test -e $chkfile || \
495         CC="%{__cc}" \
496         CXX="%{__cxx}" \
497         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
498         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
499         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
500         CC_host="%{__cc}" \
501         CXX_host="%{__cxx}" \
502         LD_host="%{__cxx}" \
503 %{__python} build/gyp_chromium \
504         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
505         --depth=. \
506         build/all.gyp \
507         $flags
508
509 %if %{with ninja}
510 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
511 %else
512 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
513 %{__make} -r \
514         BUILDTYPE=%{buildtype} \
515         %{?with_verbose:V=1} \
516         CC.host="%{__cc}" \
517         CXX.host="%{__cxx}" \
518         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
519 %endif
520         chrome %{?with_sandboxing:chrome_sandbox} \
521         %{nil}
522
523 cd %{builddir}
524 MANWIDTH=80 man ./chrome.1 > man.out
525 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
526
527 %install
528 rm -rf $RPM_BUILD_ROOT
529 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
530         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
531         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
532         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
533
534 cd %{builddir}
535 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
536 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
537 %{__sed} -i -e '
538         s,@libdir@,%{_libdir}/%{name},
539
540         /@OPTIONS@/ {
541                 r options.txt
542                 d
543         }
544 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
545 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
546 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
547 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
548 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
549 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
550 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
551 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
552 %if %{without system_ffmpeg}
553 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
554 %endif
555 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
556 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
557
558 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
559
560 %if %{with nacl}
561 # Install Native Client files on platforms that support it.
562 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
563 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
564 %ifarch %{x8664}
565 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
566 %endif
567 %ifarch %{ix86}
568 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
569 %endif
570 %endif
571
572 cd -
573
574 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
575         size=${icon##*/product_logo_}
576         size=${size%.png}
577
578         # this will skip non-numeric (22_mono_invert, 22_mono)
579         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
580         test -d "$dir" || continue
581
582         install -d $RPM_BUILD_ROOT$dir
583         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
584 done
585
586 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
587 # http://code.google.com/p/chromium/issues/detail?id=24507
588 gecko-mediaplayer*.so
589 EOF
590
591 # find locales
592 %find_lang %{name}.lang
593 # always package en-US
594 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
595
596 %clean
597 rm -rf $RPM_BUILD_ROOT
598
599 %pretrans
600 for d in locales resources; do
601         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
602                 install -d %{_datadir}/%{name}
603                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
604         fi
605 done
606 exit 0
607
608 %post
609 %update_icon_cache hicolor
610 %update_desktop_database
611 %update_browser_plugins
612
613 %postun
614 if [ "$1" = 0 ]; then
615         %update_icon_cache hicolor
616         %update_browser_plugins
617 fi
618
619 %files
620 %defattr(644,root,root,755)
621 %doc AUTHORS LICENSE
622 %{_browserpluginsconfdir}/browsers.d/%{name}.*
623 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
624 %dir %{_sysconfdir}/%{name}
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
626 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
627 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
628 %dir %{_sysconfdir}/%{name}/policies
629 %dir %{_sysconfdir}/%{name}/policies/managed
630 %attr(755,root,root) %{_bindir}/%{name}
631 %{_mandir}/man1/%{name}.1*
632 %{_desktopdir}/*.desktop
633 %{_iconsdir}/hicolor/*/apps/%{name}.png
634 %dir %{_libdir}/%{name}
635 %{_libdir}/%{name}/chrome*.pak
636 %{_libdir}/%{name}/content_resources.pak
637 %{_libdir}/%{name}/keyboard_resources.pak
638 %{_libdir}/%{name}/resources.pak
639 %{_libdir}/%{name}/natives_blob.bin
640 %{_libdir}/%{name}/snapshot_blob.bin
641 %{_libdir}/%{name}/locales
642 %{_libdir}/%{name}/resources
643
644 %dir %{_datadir}/%{name}
645 %dir %{_datadir}/%{name}/locales
646 %{_datadir}/%{name}/locales/en-US.pak
647 %dir %{_datadir}/%{name}/resources
648 %{_datadir}/%{name}/resources/inspector
649
650 %dir %{_libdir}/%{name}/plugins
651 %attr(755,root,root) %{_libdir}/%{name}/%{name}
652 # These unique permissions are intentional and necessary for the sandboxing
653 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
654
655 # ffmpeg libs
656 %if %{without system_ffmpeg}
657 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
658 %endif
659
660 %if %{with nacl}
661 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
662 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
663 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
664 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
665 %endif
666
667 %files l10n -f %{name}.lang
668 %defattr(644,root,root,755)
This page took 0.11281 seconds and 3 git commands to generate.