]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 32.0.1700.77
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
23 %bcond_with     system_libwebp  # system libwebp, disabled: http://crbug.com/288019
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_with     system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_snappy   # system snappy
31 %bcond_without  system_speex    # system speex
32 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
34 %bcond_with             system_v8               # system v8
35 %bcond_without  system_libvpx   # system libvpx
36 %bcond_without  system_yasm             # system yasm
37 %bcond_without  system_zlib             # system zlib
38 %bcond_without  tcmalloc                # use tcmalloc
39 %bcond_without  verbose                 # verbose build (V=1)
40
41 %ifarch %{ix86}
42 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43 %undefine       with_system_mesa
44 %endif
45
46 # TODO
47 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48 # - use_system_skia
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_stlport (android specific)
51 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53 # NOTES:
54 # - mute BEEP mixer if you do not want to hear horrible system bell when
55 #   pressing home/end in url bar or more ^F search results on page.
56 # - space considerations:
57 #   - unpacked sources: ~490MiB
58 #   - built code: ~1.4GiB (x86_64/i686)
59 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60 # - to look for new tarball, use update-source.sh script
61
62 %define         branch          32.0.1700
63 %define         basever         77
64 #define         patchver        63
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 %if "%{?patchver}" != ""
69 Version:        %{branch}.%{patchver}
70 %else
71 Version:        %{branch}.%{basever}
72 %endif
73 Release:        0.2
74 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77 # Source0-md5:  591fde5a952808fe06cb24030e6c29f1
78 %if "%{?patchver}" != ""
79 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80 # Patch0-md5:   f17f75a65414167cf822c6aaf409a537
81 %endif
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 Patch1:         plugin-searchdirs.patch
91 Patch4:         path-libpdf.patch
92 Patch7:         dlopen_sonamed_gl.patch
93 Patch8:         chromium_useragent.patch.in
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch12:        system-ffmpeg.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch30:        system-ply.patch
107 Patch31:        system-jinja.patch
108 Patch32:        remove_bundled_libraries-stale.patch
109 URL:            http://www.chromium.org/Home
110 %{?with_gconf:BuildRequires:    GConf2-devel}
111 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
112 BuildRequires:  Mesa-libGLES-devel >= 9.1
113 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
114 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  atk-devel
117 BuildRequires:  bison
118 BuildRequires:  bzip2-devel
119 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
123 %{?with_cups:BuildRequires:     cups-devel}
124 BuildRequires:  elfutils-devel
125 BuildRequires:  expat-devel
126 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
127 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
128 BuildRequires:  fontconfig-devel
129 BuildRequires:  glib2-devel
130 BuildRequires:  gperf
131 %{?with_gps:BuildRequires:      gpsd-devel}
132 BuildRequires:  gtest-devel
133 BuildRequires:  gtk+2-devel
134 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
135 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
136 %{?with_kerberos:BuildRequires: heimdal-devel}
137 BuildRequires:  hicolor-icon-theme
138 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
139 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
140 BuildRequires:  libevent-devel
141 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
142 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
143 BuildRequires:  libicu-devel >= 4.6
144 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
145 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
146 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
147 BuildRequires:  libpng-devel
148 %{?with_selinux:BuildRequires:  libselinux-devel}
149 BuildRequires:  libstdc++-devel
150 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
151 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
152 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
153 BuildRequires:  libxml2-devel
154 BuildRequires:  libxslt-devel
155 BuildRequires:  man-db
156 %{?with_system_minizip:BuildRequires:   minizip-devel}
157 BuildRequires:  nspr-devel
158 BuildRequires:  nss-devel >= 1:3.12.3
159 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
160 BuildRequires:  pam-devel
161 BuildRequires:  pango-devel
162 BuildRequires:  pciutils-devel
163 BuildRequires:  perl-JSON
164 BuildRequires:  perl-modules
165 BuildRequires:  pkgconfig
166 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
167 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
168 BuildRequires:  python
169 #BuildRequires: python-gyp >= 1-%{gyp_rev}
170 BuildRequires:  python-jinja2 >= 2.7
171 BuildRequires:  python-modules
172 BuildRequires:  python-ply >= 3.4
173 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
174 BuildRequires:  rpm >= 4.4.9-56
175 BuildRequires:  rpmbuild(macros) >= 1.453
176 %{?with_system_snappy:BuildRequires:    snappy-devel}
177 BuildRequires:  speech-dispatcher-devel >= 0.8
178 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
179 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
180 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
181 BuildRequires:  tar >= 1:1.22
182 BuildRequires:  udev-devel
183 BuildRequires:  usbutils
184 BuildRequires:  util-linux
185 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
186 BuildRequires:  which
187 BuildRequires:  xorg-lib-libXScrnSaver-devel
188 BuildRequires:  xorg-lib-libXtst-devel
189 BuildRequires:  xz
190 %{?with_system_yasm:BuildRequires:      yasm}
191 %{?with_system_zlib:BuildRequires:      zlib-devel}
192 Requires:       browser-plugins >= 2.0
193 Requires:       desktop-file-utils
194 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
195 # crashes if no fontconfig font present
196 Requires:       fonts-Type1-urw
197 Requires:       hicolor-icon-theme
198 Requires:       libevent >= 2.0.21
199 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
200 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
201 Requires:       lsb-release
202 %{?with_system_re2:Requires:    re2 >= 20130115-2}
203 Requires:       shared-mime-info
204 %{?with_system_sqlite:Requires: sqlite3(icu)}
205 Requires:       xdg-utils >= 1.0.2-4
206 Requires:       xorg-lib-libX11 >= 1.4.99.1
207 Provides:       wwwbrowser
208 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
209 Obsoletes:      chromium-browser-inspector < 15.0.863.0
210 ExclusiveArch:  %{ix86} %{x8664} arm
211 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
212
213 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
214 # Note: these are for PLD Linux use ONLY.
215 # For your own distribution, please get your own set of keys.
216 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
217 %define         google_default_client_id 724288223830.apps.googleusercontent.com
218 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
219
220 %define         find_lang       sh find-lang.sh %{buildroot}
221
222 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
223 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
224
225 %if %{without debuginfo}
226 %define         _enable_debug_packages  0
227 %endif
228
229 %description
230 Chromium is an open-source browser project that aims to build a safer,
231 faster, and more stable way for all Internet users to experience the
232 web.
233
234 Chromium serves as a base for Google Chrome, which is Chromium
235 rebranded (name and logo) with very few additions such as usage
236 tracking and an auto-updater system.
237
238 %package l10n
239 Summary:        chromium-browser language packages
240 Group:          I18n
241 Requires:       %{name} = %{version}-%{release}
242 %if "%{_rpmversion}" >= "5"
243 BuildArch:      noarch
244 %endif
245
246 %description l10n
247 Chromium is an open-source browser project that aims to build a safer,
248 faster, and more stable way for all Internet users to experience the
249 web.
250
251 This package contains language packages for 50 languages:
252
253 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
254 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
255 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
256 zh-TW
257
258 %prep
259 %setup -qc
260 %if "%{?patchver}" != ""
261 cd %{name}-%{branch}.%{basever}
262 %patch0 -p1
263 cd ..
264 %endif
265 mv %{name}-%{branch}.%{basever}/* .
266
267 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
268 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
269 . ./chrome/VERSION
270 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
271 test "$chrome" = %{version}
272
273 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
274 test "$gyp_rev" = %{gyp_rev} || :
275
276 . ./v8.sh
277 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
278
279 # add chromium and pld to useragent
280 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
281 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
282         -e 's/@BUILD_DIST_NAME@/PLD/g' \
283         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
284         < %{PATCH8} | %{__patch} -p1
285
286 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
287 ln -s %{SOURCE7} .
288
289 %patch1 -p1
290 %patch4 -p3
291 %patch7 -p1
292 %patch10 -p1
293 %patch15 -p2
294 %{!?with_libjpegturbo:%patch11 -p0}
295 %patch12 -p1
296 %patch16 -p1
297 %patch28 -p1
298 %patch25 -p2
299 %{?with_nacl:%patch18 -p1}
300 %patch24 -p2
301 %patch26 -p2
302 %patch30 -p1
303 %patch31 -p0
304 %patch32 -p1
305
306 sh -x clean-source.sh \
307         %{!?with_nacl:nacl=0} \
308         %{!?with_system_libvpx:libvpx=0} \
309         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
310         %{!?with_system_mesa:mesa=0} \
311         %{!?with_system_protobuf:protobuf=0} \
312         %{!?with_system_re2:re2=0} \
313         %{!?with_system_snappy:snappy=0} \
314         %{!?with_system_sqlite:sqlite=0} \
315         %{!?with_system_v8:v8=0} \
316         %{!?with_system_libwebp:libwebp=0} \
317         %{!?with_system_zlib:zlib=0} \
318         %{nil}
319
320 %build
321 %if %{with nacl}
322 rm -rf native_client/toolchain/linux_x86_newlib
323 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
324 # Make symlinks for NaCL
325 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
326
327 cd native_client/toolchain/linux_x86_newlib
328 ln -s x86_64-nacl/bin bin
329 cd x86_64-nacl/bin
330 __cc='%{__cc}'
331 if [ "${__cc#ccache}" != "$__cc" ]; then
332         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
333         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
334         %{__sed} -i -e '1i#!/bin/sh' gcc g++
335         chmod +x gcc g++
336 else
337         ln -s %{_bindir}/x86_64-nacl-gcc gcc
338         ln -s %{_bindir}/x86_64-nacl-g++ g++
339 fi
340 ln -s gcc x86_64-nacl-gcc
341 ln -s g++ x86_64-nacl-g++
342 ln -s %{_bindir}/x86_64-nacl-ar .
343 ln -s %{_bindir}/x86_64-nacl-ar ar
344 ln -s %{_bindir}/x86_64-nacl-as as
345 ln -s %{_bindir}/x86_64-nacl-ranlib .
346 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
347 ln -s %{_bindir}/x86_64-nacl-strip .
348 ln -s %{_bindir}/x86_64-nacl-strip strip
349 ln -s %{_bindir}/x86_64-nacl-objcopy .
350 ln -s %{_prefix}/x86_64-nacl/lib ../lib
351 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
352 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
353 cd ../../../../..
354 fi
355 %endif
356
357 flags="
358 %ifarch %{ix86}
359         -Dtarget_arch=ia32 \
360         -Dpython_arch=ia32 \
361 %endif
362 %ifarch %{x8664}
363         -Dtarget_arch=x64 \
364         -Dpython_arch=x64 \
365 %endif
366         -Dsystem_libdir=%{_lib} \
367         -Dpython_ver=2.7 \
368 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
369         -Dno_strict_aliasing=1 -Dgcc_version=44 \
370 %endif
371         %{!?debug:-Dwerror=} \
372         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
373         %{?with_shared_libs:-Dlibrary=shared_library} \
374         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
375         -Dinclude_tests=0 \
376 %if %{with nacl}
377         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
378         -Ddisable_glibc_untar=1 \
379         -Ddisable_newlib_untar=1 \
380         -Ddisable_glibc=1 \
381         -Ddisable_pnacl=1 \
382         -Dbuild_pnacl_newlib=0 \
383 %else
384         -Ddisable_pnacl_untar=1 \
385         -Ddisable_nacl=1 \
386 %endif
387         %{!?with_sse2:-Ddisable_sse2=1} \
388         %{?with_selinux:-Dselinux=1} \
389         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
390         -Dlinux_link_libpci=1 \
391         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
392         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
393         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
394         -Dlinux_use_gold_binary=0 \
395         -Dlinux_use_gold_flags=0 \
396         -Dlogging_like_official_build=1 \
397         -Dgoogle_api_key=%{google_api_key} \
398         -Dgoogle_default_client_id=%{google_default_client_id} \
399         -Dgoogle_default_client_secret=%{google_default_client_secret} \
400         %{gyp_with cups} \
401         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
402         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
403         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
404         %{gyp_with pulseaudio} \
405         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
406         %{gyp_with system_flac} \
407         %{gyp_with system_harfbuzz} \
408         %{gyp_with system_jsoncpp} \
409         %{gyp_with system_libexif} \
410         %{gyp_with system_libmtp} \
411         %{gyp_with system_libsrtp} \
412         %{gyp_with system_libusb} \
413         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
414         %{gyp_with system_libwebp} \
415         %{gyp_with system_libxnvctrl} \
416         %{gyp_with system_mesa} \
417         %{gyp_with system_minizip} \
418         %{gyp_with system_opus} \
419         %{gyp_with system_protobuf} \
420         %{gyp_with system_re2} \
421         %{gyp_with system_snappy} \
422         %{gyp_with system_speex} \
423         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
424         %{gyp_with system_v8} \
425         %{gyp_with system_yasm} \
426         %{gyp_with system_zlib} \
427         -Duse_system_bzip2=1 \
428         -Duse_system_expat=1 \
429         -Duse_system_icu=1 \
430         -Duse_system_libevent=1 \
431         -Duse_system_libjpeg=1 \
432         -Duse_system_libpng=1 \
433         -Duse_system_libxml=1 \
434         -Duse_system_libxslt=1 \
435         -Duse_system_nspr=1 \
436         -Duse_system_xdg_utils=1 \
437 "
438
439 build/linux/unbundle/replace_gyp_files.py $flags
440
441 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
442 test -e Makefile || \
443         CC="%{__cc}" \
444         CXX="%{__cxx}" \
445         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
446         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
447         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
448         CC_host="%{__cc}" \
449         CXX_host="%{__cxx}" \
450         LD_host="%{__cxx}" \
451 %{__python} build/gyp_chromium \
452         --format=make \
453         --depth=. \
454         build/all.gyp \
455         $flags
456
457 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
458 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
459         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
460         %{?with_verbose:V=1} \
461         CC.host="%{__cc}" \
462         CXX.host="%{__cxx}" \
463         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
464
465 cd out/%{!?debug:Release}%{?debug:Debug}
466 MANWIDTH=80 man ./chrome.1 > man.out
467 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
468
469 %install
470 rm -rf $RPM_BUILD_ROOT
471 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
472         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
473         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
474
475 cd out/%{!?debug:Release}%{?debug:Debug}
476 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
477 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
478 %{__sed} -i -e '
479         s,@libdir@,%{_libdir}/%{name},
480
481         /@OPTIONS@/ {
482                 r options.txt
483                 d
484         }
485 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
486 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
487 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
488 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
489 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
490 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
491 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
492 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
493 %if %{without system_ffmpeg}
494 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
495 %endif
496 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
497 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
498
499 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
500
501 %if %{with nacl}
502 # Install Native Client files on platforms that support it.
503 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
504 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
505 %ifarch %{x8664}
506 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
507 %endif
508 %ifarch %{ix86}
509 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
510 %endif
511 %endif
512
513 cd -
514
515 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
516         size=${icon##*/product_logo_}
517         size=${size%.png}
518
519         # this will skip non-numeric (22_mono_invert, 22_mono)
520         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
521         test -d "$dir" || continue
522
523         install -d $RPM_BUILD_ROOT$dir
524         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
525 done
526
527 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
528 # http://code.google.com/p/chromium/issues/detail?id=24507
529 gecko-mediaplayer*.so
530 EOF
531
532 # find locales
533 %find_lang %{name}.lang
534 # always package en-US
535 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
536
537 %clean
538 rm -rf $RPM_BUILD_ROOT
539
540 %pretrans
541 for d in locales resources; do
542         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
543                 install -d %{_datadir}/%{name}
544                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
545         fi
546 done
547 exit 0
548
549 %post
550 %update_icon_cache hicolor
551 %update_desktop_database
552 %update_browser_plugins
553
554 %postun
555 if [ "$1" = 0 ]; then
556         %update_icon_cache hicolor
557         %update_browser_plugins
558 fi
559
560 %files
561 %defattr(644,root,root,755)
562 %doc AUTHORS LICENSE
563 %{_browserpluginsconfdir}/browsers.d/%{name}.*
564 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
565 %dir %{_sysconfdir}/%{name}
566 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
567 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
568 %attr(755,root,root) %{_bindir}/%{name}
569 %{_mandir}/man1/%{name}.1*
570 %{_desktopdir}/*.desktop
571 %{_iconsdir}/hicolor/*/apps/%{name}.png
572 %dir %{_libdir}/%{name}
573 %{_libdir}/%{name}/chrome*.pak
574 %{_libdir}/%{name}/content_resources.pak
575 %{_libdir}/%{name}/resources.pak
576 %{_libdir}/%{name}/locales
577 %{_libdir}/%{name}/resources
578
579 %dir %{_datadir}/%{name}
580 %dir %{_datadir}/%{name}/locales
581 %{_datadir}/%{name}/locales/en-US.pak
582 %dir %{_datadir}/%{name}/resources
583 %{_datadir}/%{name}/resources/inspector
584
585 %dir %{_libdir}/%{name}/plugins
586 %attr(755,root,root) %{_libdir}/%{name}/%{name}
587 # These unique permissions are intentional and necessary for the sandboxing
588 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
589
590 # ffmpeg libs
591 %if %{without system_ffmpeg}
592 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
593 %endif
594
595 %if %{with nacl}
596 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
597 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
598 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
599 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
600 %endif
601
602 %files l10n -f %{name}.lang
603 %defattr(644,root,root,755)
This page took 0.083493 seconds and 3 git commands to generate.